Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 23rd February 2018, 23:18   #27081  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
CopyDirStructure() 00076 1200

I have been getting this specific error on a LOT of BDs lately. Whether it is trying to make a complete copy or shrink to ANY format
DeathStalker77 is offline   Reply With Quote
Old 24th February 2018, 14:41   #27082  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,357
Quote:
Originally Posted by DeathStalker77 View Post
I have been getting this specific error on a LOT of BDs lately. Whether it is trying to make a complete copy or shrink to ANY format
That is a "path not found" error. Are there any strange or unusual characters in the path name, maybe? Is it an exceptionally long path name?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 24th February 2018, 16:47   #27083  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Quote:
Originally Posted by jdobbs View Post
That is a "path not found" error. Are there any strange or unusual characters in the path name, maybe? Is it an exceptionally long path name?
Of the two most recent, one only had 21 characters and spaces, the other was 19 characters and the only "special" characters were [].
DeathStalker77 is offline   Reply With Quote
Old 24th February 2018, 21:16   #27084  |  Link
jfcarbel
Programmer
 
Join Date: Feb 2002
Location: Chicago, IL
Posts: 490
In order to keep Atmos audio is this correct understanding:
- TrueHD track must be selected
- Keep HD audio is selected in settings page
- Full Backup is selected

Is that correct?
jfcarbel is offline   Reply With Quote
Old 25th February 2018, 00:41   #27085  |  Link
worknstiff
Registered User
 
Join Date: Jun 2009
Posts: 304
@ jfcarbel RE: Too keep Atmos audio is this correct understanding:
- TrueHD track must be selected
- Keep HD audio is selected in settings page
- Full Backup is selected

Is that correct? Those must be checked but you don't have to do a "Full" backup, you can do a movie only, BUT it must be a BD25 backup. You can keep just the "Core" 1500k DTS if you do a DVD+R or DVD+R DL backup by leaving the "Keep HD Audio" checked. Backup to a DVD+R doesn't leave enough space to keep the ATMOS or TrueHD lossless audio.
worknstiff is offline   Reply With Quote
Old 25th February 2018, 23:33   #27086  |  Link
jfcarbel
Programmer
 
Join Date: Feb 2002
Location: Chicago, IL
Posts: 490
Quote:
Originally Posted by worknstiff View Post
@ jfcarbel RE: Too keep Atmos audio is this correct understanding:
- TrueHD track must be selected
- Keep HD audio is selected in settings page
- Full Backup is selected

Is that correct? Those must be checked but you don't have to do a "Full" backup, you can do a movie only, BUT it must be a BD25 backup. You can keep just the "Core" 1500k DTS if you do a DVD+R or DVD+R DL backup by leaving the "Keep HD Audio" checked. Backup to a DVD+R doesn't leave enough space to keep the ATMOS or TrueHD lossless audio.
Thanks was not sure movie only would work as I seem to see some prior posts indicating full backup. Yes, I understand the space atmos requires so a BD 25 or 50 is required.

Thanks.
jfcarbel is offline   Reply With Quote
Old 26th February 2018, 19:49   #27087  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Quote:
Originally Posted by jdobbs View Post
That is a "path not found" error. Are there any strange or unusual characters in the path name, maybe? Is it an exceptionally long path name?
I just got this on a path that was c:\temp\XXXXXXXX#### - 8 letters, 4 numbers, no spaces, no characters.
DeathStalker77 is offline   Reply With Quote
Old 26th February 2018, 20:15   #27088  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,357
Quote:
Originally Posted by DeathStalker77 View Post
I just got this on a path that was c:\temp\XXXXXXXX#### - 8 letters, 4 numbers, no spaces, no characters.
Sorry. I haven't a clue why you are getting it. But, the fact that I'm not getting any other similar reports leads me to believe it is something particular to your system.

Try deleting (or temporarily renaming) the BDREBUILDER.INI file and see what effect that has.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 26th February 2018, 20:25   #27089  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Quote:
Originally Posted by jdobbs View Post
Sorry. I haven't a clue why you are getting it. But, the fact that I'm not getting any other similar reports leads me to believe it is something particular to your system.

Try deleting (or temporarily renaming) the BDREBUILDER.INI file and see what effect that has.
Ok, I can try that. Nothing special with my system. I don't do any encodes or anything like that, just shrink what I think doesn't need to be a BD50. FWIW, both DVDRB and DVDShrink work (and yes, I know diff codecs and diff files structures )
DeathStalker77 is offline   Reply With Quote
Old 26th February 2018, 20:47   #27090  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Quote:
Originally Posted by jdobbs View Post
Sorry. I haven't a clue why you are getting it. But, the fact that I'm not getting any other similar reports leads me to believe it is something particular to your system.

Try deleting (or temporarily renaming) the BDREBUILDER.INI file and see what effect that has.
Even with a ONE letter path, it is still generating the same error. Deleting the INI, it is still generating the same error, and setting BDRB to not do ANY reduction results in the same error

Also, I do have Haali and ffdshow installed - and they are running when BDRB runs, if that is of any help.

Last edited by DeathStalker77; 26th February 2018 at 20:54.
DeathStalker77 is offline   Reply With Quote
Old 26th February 2018, 21:35   #27091  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
FWIW, here are the 2 INIs - 1st from the BDRB main directory, the 2nd from the job directory -

Code:
[Options]
VERSION=0.50.0.24
ENCODER=0
MODE=0
ENCODE_QUALITY=0
ONEPASS_ENCODING=2
AUTO_QUALITY=1
TARGET_SIZE=23500
PRIORITY_CLASS=0
AUDIO_TO_KEEP=eng;
SUBS_TO_KEEP=all
SD_CONVERT=0
OPEN_GOP=0
RESIZE_1080=0
RESIZE_1440=0
RESIZE_720=0
DEINTERLACE=1
SD_TO_1080=0
IGNORE_3D=0
CONVERT_WIDE=0
DTS_REENCODE=0
AC3_REENCODE=0
AC3_640=0
AC3_192=0
KEEP_HD_AUDIO=0
AUDIO_DRC=0
DECODER=0
AVCHD=0
REMOVE_WORKFILES=0
REMOVE_OUTPUT=0
USE_FILTERS=0
BDMV_CERT_ONLY=0
IVTC_PULLDOWN=0
ASSUME_DVD_PAL=0
FRIMSOURCE=0
COMPLETION_BEEP=0
OUTPUT_SBS=0
NEROAAC=0
SUPTITLE=0
PGSTOSRT=0
AUDIO_TRACK_LIMIT=1
SUBTITLE_TRACK_LIMIT=1
CUSTOM_TARGET_SIZE=23500
[Paths]
SOURCE_PATH=C:\TEMP\M\
WORKING_PATH=C:\TEMP\M\NEW\
=================
[Status]
LABEL=M
VERSION=v0.50.25
SOURCE_SIZE=31613603817
SOURCE_VIDEO_SIZE=31302899712
TARGET_SIZE=24641536000
REDUCTION=.777270863685282
RESIZE_1080=0
RESIZE_1440=0
AUDIO_TO_KEEP=eng;
KEEP_HD_AUDIO=0
SUBS_TO_KEEP=all
BACKUP_MODE=0
MOVIEONLY_TYPE=0
USE_LAVF=0
INSTANCES=1
DGDECNV=0
DGDECIM=0
FRIMSOURCE=0
FFMS2=0
SSIF_MODE=0
QUICK=0
ENCODE_STEP=0
COMPLETED=3
REBUILD_COMPLETE=0
[00000]
AUDIO=111
PGS=1
APULLDOWN=0
S1440=0
VIDEO2=0
V2MBRATE=0
M2TS_TARGET=23555272669
RATE=26457
SPLITS=1
NSTART=27000000
NEND=296641244
NSIZE=22893238272
FLINK=0
MLINK=0
[00045]
AUDIO=1
PGS=
APULLDOWN=0
S1440=0
VIDEO2=0
V2MBRATE=0
M2TS_TARGET=290033611
RATE=13720
SPLITS=1
NSTART=27000000
NEND=33668537
NSIZE=270723072
FLINK=0
MLINK=0
[00080]
AUDIO=1
PGS=
APULLDOWN=0
S1440=0
VIDEO2=0
V2MBRATE=0
M2TS_TARGET=485525615
RATE=26978
SPLITS=1
NSTART=27000000
NEND=32677547
NSIZE=446490624
FLINK=0
MLINK=0

And here is the log -
----------------------
[02/26/18] BD Rebuilder v0.50.25
[15:50:19] Source:  M
  - Input BD size: 29.44 GB
  - Approximate total content: [01:45:50.594]
  - Target BD size: 22.95 GB
  - Windows Version: 6.2 [9200]
  - Auto Quality: Good (Very Fast), ABR
  - Decoding/Frame serving: DirectShow
  - Audio Settings: AC3=0 DTS=0 HD=0 Kbs=448
[15:50:19] PHASE ONE, Encoding
 - [15:50:19] Processing: VID_00000 (1 of 3)
 - [15:50:19] Extracting A/V streams [VID_00000]
 - [15:53:00] Reencoding video [VID_00000]
   - Source Video: MPEG-4 (AVC), 1920x1080
   - Rate/Length: 23.976fps, 143,665 frames
   - Bitrate: 26,457 Kbs
 - [15:53:00] Reencoding: VID_00000, Pass 1 of 1
 - [16:20:13] Video Encode complete
 - [16:20:13] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
   - Track 4353 (eng): Keeping original audio
   - Track 4354 (eng): Keeping original audio
 - [16:20:13] Multiplexing M2TS
 - [16:21:39] Processing: VID_00045 (2 of 3)
 - [16:21:39] Extracting A/V streams [VID_00045]
 - [16:21:45] Reencoding video [VID_00045]
   - Source Video: MPEG-4 (AVC), 1920x1080
   - Rate/Length: 23.976fps, 3,553 frames
   - Bitrate: 13,720 Kbs
 - [16:21:45] Reencoding: VID_00045, Pass 1 of 1
 - [16:22:21] Video Encode complete
 - [16:22:21] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
 - [16:22:21] Multiplexing M2TS
 - [16:22:25] Processing: VID_00080 (3 of 3)
 - [16:22:25] Extracting A/V streams [VID_00080]
 - [16:22:31] Reencoding video [VID_00080]
   - Source Video: MPEG-4 (AVC), 1920x1080
   - Rate/Length: 23.976fps, 3,025 frames
   - Bitrate: 26,978 Kbs
 - [16:22:31] Reencoding: VID_00080, Pass 1 of 1
 - [16:23:05] Video Encode complete
 - [16:23:05] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
 - [16:23:05] Multiplexing M2TS
[16:23:09]PHASE ONE complete
[16:23:09]PHASE TWO - Rebuild Started
 - [16:23:09] Rebuilding BD file Structure
 - [16:23:10] CopyDirStructure() 00076  1200
 - [16:32:58] CopyDirStructure() 00076  1200
 - [16:32:59] CopyDirStructure() 00076  1200
 - [16:32:59] CopyDirStructure() 00076  1200
 - [16:33:00] CopyDirStructure() 00076  1200
 - [16:33:00] CopyDirStructure() 00076  1200
 - [16:33:00] CopyDirStructure() 00076  1200
 - [16:33:00] CopyDirStructure() 00076  1200
 - [16:33:01] CopyDirStructure() 00076  1200
 - [16:33:01] CopyDirStructure() 00076  1200
 - [16:33:01] CopyDirStructure() 00076  1200
 - [16:33:01] CopyDirStructure() 00076  1200
 - [16:33:02] CopyDirStructure() 00076  1200
 - [16:33:02] CopyDirStructure() 00076  1200
 - [16:33:02] CopyDirStructure() 00076  1200
[16:33:02] - Aborted per user request

Last edited by jdobbs; 27th February 2018 at 13:48.
DeathStalker77 is offline   Reply With Quote
Old 28th February 2018, 16:00   #27092  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Just getting this with more & more titles, no matter what the folder name Nothing's changed on my system except adding ffmpg and Haali Splitter
DeathStalker77 is offline   Reply With Quote
Old 28th February 2018, 19:26   #27093  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,357
Quote:
Originally Posted by DeathStalker77 View Post
Just getting this with more & more titles, no matter what the folder name Nothing's changed on my system except adding ffmpg and Haali Splitter
Something is wrong -- and I'm confident it isn't BD-RB. Otherwise I'd have 20 or more other people reporting it as well.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th February 2018, 19:31   #27094  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
So I have no clue as to how to go about troubleshooting this I'll try running it on another system for the heck of it.
DeathStalker77 is offline   Reply With Quote
Old 28th February 2018, 22:36   #27095  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Quote:
Originally Posted by jdobbs View Post
Something is wrong -- and I'm confident it isn't BD-RB. Otherwise I'd have 20 or more other people reporting it as well.
Ok, I just tried one of the same titles on a clean system that has never been used for anything but web surfing, and got the same error.
DeathStalker77 is offline   Reply With Quote
Old 28th February 2018, 23:28   #27096  |  Link
worknstiff
Registered User
 
Join Date: Jun 2009
Posts: 304
[@ DeathStalker77 RE: I got the same error.

I have noticed that you haven't posted an (Inspect) log, which is where I ALLWAYS start when I have any problems. It may show you some problem that's not obvious. Also I don't guess it makes any difference BUT I always use a different "Source" and "Working" drive. I find it doesn't bog my CPU down as much when it's reading and writing to the same one. I don't guess you're running any VM's or network drives are you?
worknstiff is offline   Reply With Quote
Old 28th February 2018, 23:42   #27097  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
Quote:
Originally Posted by worknstiff View Post
[@ DeathStalker77 RE: I got the same error.

I have noticed that you haven't posted an (Inspect) log, which is where I ALLWAYS start when I have any problems. It may show you some problem that's not obvious. Also I don't guess it makes any difference BUT I always use a different "Source" and "Working" drive. I find it doesn't bog my CPU down as much when it's reading and writing to the same one. I don't guess you're running any VM's or network drives are you?
FWIW, this is on an X99 system 6750k, 64gb RAM, and an SSD.

No, no VMs running. I've not seen an INSPECT log file - if you mean the BD-REBUILDER.LOG file, I did post that -

----------------------
[02/26/18] BD Rebuilder v0.50.25
[15:50:19] Source: M
- Input BD size: 29.44 GB
- Approximate total content: [01:45:50.594]
- Target BD size: 22.95 GB
- Windows Version: 6.2 [9200]
- Auto Quality: Good (Very Fast), ABR
- Decoding/Frame serving: DirectShow
- Audio Settings: AC3=0 DTS=0 HD=0 Kbs=448
[15:50:19] PHASE ONE, Encoding
- [15:50:19] Processing: VID_00000 (1 of 3)
- [15:50:19] Extracting A/V streams [VID_00000]
- [15:53:00] Reencoding video [VID_00000]
- Source Video: MPEG-4 (AVC), 1920x1080
- Rate/Length: 23.976fps, 143,665 frames
- Bitrate: 26,457 Kbs
- [15:53:00] Reencoding: VID_00000, Pass 1 of 1
- [16:20:13] Video Encode complete
- [16:20:13] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- Track 4353 (eng): Keeping original audio
- Track 4354 (eng): Keeping original audio
- [16:20:13] Multiplexing M2TS
- [16:21:39] Processing: VID_00045 (2 of 3)
- [16:21:39] Extracting A/V streams [VID_00045]
- [16:21:45] Reencoding video [VID_00045]
- Source Video: MPEG-4 (AVC), 1920x1080
- Rate/Length: 23.976fps, 3,553 frames
- Bitrate: 13,720 Kbs
- [16:21:45] Reencoding: VID_00045, Pass 1 of 1
- [16:22:21] Video Encode complete
- [16:22:21] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [16:22:21] Multiplexing M2TS
- [16:22:25] Processing: VID_00080 (3 of 3)
- [16:22:25] Extracting A/V streams [VID_00080]
- [16:22:31] Reencoding video [VID_00080]
- Source Video: MPEG-4 (AVC), 1920x1080
- Rate/Length: 23.976fps, 3,025 frames
- Bitrate: 26,978 Kbs
- [16:22:31] Reencoding: VID_00080, Pass 1 of 1
- [16:23:05] Video Encode complete
- [16:23:05] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [16:23:05] Multiplexing M2TS
[16:23:09]PHASE ONE complete
[16:23:09]PHASE TWO - Rebuild Started
- [16:23:09] Rebuilding BD file Structure
- [16:23:10] CopyDirStructure() 00076 1200
- [16:32:58] CopyDirStructure() 00076 1200
- [16:32:59] CopyDirStructure() 00076 1200
- [16:32:59] CopyDirStructure() 00076 1200
- [16:33:00] CopyDirStructure() 00076 1200
- [16:33:00] CopyDirStructure() 00076 1200
- [16:33:00] CopyDirStructure() 00076 1200
- [16:33:00] CopyDirStructure() 00076 1200
- [16:33:01] CopyDirStructure() 00076 1200
- [16:33:01] CopyDirStructure() 00076 1200
- [16:33:01] CopyDirStructure() 00076 1200
- [16:33:01] CopyDirStructure() 00076 1200
- [16:33:02] CopyDirStructure() 00076 1200
- [16:33:02] CopyDirStructure() 00076 1200
- [16:33:02] CopyDirStructure() 00076 1200
[16:33:02] - Aborted per user request
DeathStalker77 is offline   Reply With Quote
Old 1st March 2018, 14:24   #27098  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,357
Quote:
Originally Posted by DeathStalker77 View Post
FWIW, this is on an X99 system 6750k, 64gb RAM, and an SSD.

No, no VMs running. I've not seen an INSPECT log file - if you mean the BD-REBUILDER.LOG file, I did post that -

----------------------
Click on "Help/Inspect (Show Settings)"

It could be a hidden folder with a bad name on the disc, maybe?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 1st March 2018, 14:26   #27099  |  Link
DeathStalker77
Registered User
 
Join Date: Sep 2009
Posts: 16
[03/01/18] Checking System Settings
- BD-Rebuilder v0.50.25
- Windows Version: 6.2 [9200]
- Working Path Free Space: 153.18GB
- AVISYNTH Version: 2.6.1.0, not recommended version
- HAALI Splitter: Isn't recommended version
- FFDSHOW: 4532, not recommended version
- FFDSHOW VC-1 set to "wmv9", Ok
- FFDSHOW MPEG2 set to "libavcodec": Ok
- FFDSHOW AVC set to "libavcodec": Ok
- X264: Ok
- AFTEN: Ok
- FAAC: Ok
- MP4BOX: Ok
- WAVI: Ok
- TSMUXER: Ok
- FRIMEncode: Ok
- FRIMDecode: Ok
[03/01/18] Systems Settings Check complete

Interesting that AVISYNTH and HAALI say they aren't the recommended versions, as they are the official versions from the websites. Anything I can try?

*I'll check for hidden folders.
=========
Nope, checked and no hidden folders, no odd named folders - just what one would normally expect

Last edited by DeathStalker77; 1st March 2018 at 14:29.
DeathStalker77 is offline   Reply With Quote
Old 1st March 2018, 14:31   #27100  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,357
Quote:
Originally Posted by DeathStalker77 View Post
[03/01/18] Checking System Settings
- BD-Rebuilder v0.50.25
- Windows Version: 6.2 [9200]
- Working Path Free Space: 153.18GB
- AVISYNTH Version: 2.6.1.0, not recommended version
- HAALI Splitter: Isn't recommended version
- FFDSHOW: 4532, not recommended version
- FFDSHOW VC-1 set to "wmv9", Ok
- FFDSHOW MPEG2 set to "libavcodec": Ok
- FFDSHOW AVC set to "libavcodec": Ok
- X264: Ok
- AFTEN: Ok
- FAAC: Ok
- MP4BOX: Ok
- WAVI: Ok
- TSMUXER: Ok
- FRIMEncode: Ok
- FRIMDecode: Ok
[03/01/18] Systems Settings Check complete

Interesting that AVISYNTH and HAALI say they aren't the recommended versions, as they are the official versions from the websites. Anything I can try?

*I'll check for hidden folders.
=========
Nope, checked and no hidden folders, no odd named folders - just what one would normally expect
Yes. Read the first post of this thread... and download the correct versions. I doubt that has anything to do with your problem, though. But you never know.

CopyDirStructure() is a very simple routine consisting of 33 lines of code. It simply steps through the folder structure on the source and re-creates it on the destination. Somewhere in that process a path is presented that kicks off that error. The error isn't coming from BD-RB, it is coming from the operating system. BD-RB is only reporting it. It's possible that the path may be too long, as well as having bad characters in it. You'd have to look through the source structure to find out.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 1st March 2018 at 14:41.
jdobbs is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.