Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 9th March 2019, 17:16   #6801  |  Link
pommesmatte
Registered User
 
Join Date: Aug 2012
Posts: 42
Quote:
Originally Posted by tebasuna51 View Post
From DGDecodeNVManual.html

The problem is the top crop 134, it is not mod-4.
Thanks for pointing that out! You are correct, with 132 or 136 top cropping, the problem does not occur.
pommesmatte is offline   Reply With Quote
Old 10th March 2019, 00:53   #6802  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,511
Quote:
Originally Posted by taz742 View Post
So the question is since which version the bug appear to know which old driver version is it safe to use ?
I don't know. I always see in DGDecodeNVManual the recomendation of use crops and resizes in mod-4.

BTW I can't recommend use a old driver only to crop in mod-2.
The standard AviSynth Crop can do the job.
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 12th March 2019, 22:11   #6803  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 197
MKVToolNix v32.0.0 is released.
Zetti is offline   Reply With Quote
Old 13th March 2019, 11:40   #6804  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 197
x264 r2969 is released.
Zetti is offline   Reply With Quote
Old 15th March 2019, 11:09   #6805  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,401
Thanks, both have been updated
Zathor is offline   Reply With Quote
Old 12th April 2019, 22:30   #6806  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 197
MKVToolNix v33.0.0 is released.
Zetti is offline   Reply With Quote
Old 13th April 2019, 10:59   #6807  |  Link
imsrk48
Registered User
 
Join Date: Nov 2017
Posts: 115
Please add a feature for add Logo using MeGUI
imsrk48 is offline   Reply With Quote
Old 15th April 2019, 10:41   #6808  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 197
MKVToolNix v33.1.0 is released.
Zetti is offline   Reply With Quote
Old 24th April 2019, 12:07   #6809  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 197
MediaInfo v19.04 is released.
Zetti is offline   Reply With Quote
Old 24th April 2019, 13:40   #6810  |  Link
imsrk48
Registered User
 
Join Date: Nov 2017
Posts: 115
I'm facing problem with Encoding x265 to x264

https://mega.nz/#!EqpUAQAA!JOIFRxZzX...HY96eQewAkJGNE

Please Give Fix AOSP

Last edited by imsrk48; 24th April 2019 at 14:15.
imsrk48 is offline   Reply With Quote
Old 24th April 2019, 20:53   #6811  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,370
For some reason the source is opened as RGB32 while an Y4M pipe (from AviSynth via ffmpeg to x264) can not handle RGB. The MediaInfo doesn't show if the source is RGB to begin with or you have your DirectShow decoder set up to decode to RGB32.

Try:
Open source via ffms2/ffvideosource() instead of DirectShowSource()

If that does not work add as last line:
ConvertToYV12()
sneaker_ger is offline   Reply With Quote
Old 25th April 2019, 04:34   #6812  |  Link
imsrk48
Registered User
 
Join Date: Nov 2017
Posts: 115
Quote:
Originally Posted by sneaker_ger View Post
For some reason the source is opened as RGB32 while an Y4M pipe (from AviSynth via ffmpeg to x264) can not handle RGB. The MediaInfo doesn't show if the source is RGB to begin with or you have your DirectShow decoder set up to decode to RGB32.



Try:

Open source via ffms2/ffvideosource() instead of DirectShowSource()



If that does not work add as last line:

ConvertToYV12()
Already Tried ConvertToYV12()

After this MeGUI Says what is ConvertToYV12 () I can't understand something.
imsrk48 is offline   Reply With Quote
Old 25th April 2019, 04:36   #6813  |  Link
imsrk48
Registered User
 
Join Date: Nov 2017
Posts: 115
Quote:
Originally Posted by sneaker_ger View Post
For some reason the source is opened as RGB32 while an Y4M pipe (from AviSynth via ffmpeg to x264) can not handle RGB. The MediaInfo doesn't show if the source is RGB to begin with or you have your DirectShow decoder set up to decode to RGB32.



Try:

Open source via ffms2/ffvideosource() instead of DirectShowSource()



If that does not work add as last line:

ConvertToYV12()
How can i use your first method please explain Sir.

I really need to fix this. My Work Stopped because of this Issue.
imsrk48 is offline   Reply With Quote
Old 25th April 2019, 04:56   #6814  |  Link
imsrk48
Registered User
 
Join Date: Nov 2017
Posts: 115
@Zathor Sir Please

Add FFmpegSource Selection Option in MeGUI In-built.

Add Option For Auto Download Required Avisynth Plugins that Needed in Scripts.
imsrk48 is offline   Reply With Quote
Old 25th April 2019, 05:55   #6815  |  Link
imsrk48
Registered User
 
Join Date: Nov 2017
Posts: 115
Quote:
Originally Posted by sneaker_ger View Post
For some reason the source is opened as RGB32 while an Y4M pipe (from AviSynth via ffmpeg to x264) can not handle RGB. The MediaInfo doesn't show if the source is RGB to begin with or you have your DirectShow decoder set up to decode to RGB32.



Try:

Open source via ffms2/ffvideosource() instead of DirectShowSource()



If that does not work add as last line:

ConvertToYV12()
I'm re-seted megui & Tried ConvertToYV12()

Now Video Encoding but Encoding Speed Is Very Slow.
imsrk48 is offline   Reply With Quote
Old 26th April 2019, 22:19   #6816  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 197
FFmpeg v4.1.3 is released.
Zetti is offline   Reply With Quote
Old 29th April 2019, 04:12   #6817  |  Link
bowlingbeeg
Registered User
 
Join Date: Jun 2015
Posts: 4
Strange FPS values in DVD rips

I've noticed that ever since the VFR support was added last year that when I encode North American DVDs to mkv and play them back on Plex or Kodi the refresh rate of my projector switches from 24p to 60p. It appears that the FrameRateMode is set to Variable in MediaInfo for North American DVDs and that causes the new support to create the timestamp file which ffmpeg uses. Now I'm not exactly sure where things go wrong from there but the result is that the Kodi and Plex seem to think they should be switching to 60p whereas older DVD rips will stay at 24p. Looking at Plex, it seems to think the actual file is 20FPS and when I look at the track info in MKVToolNix I do see a "default duration" of 20FPS. MediaInfo does say the framerate is 23.976 but that the frame rate mode is variable instead of constant like I see on older rips. I'm not entirely sure if this is a bug or not but it's certainly different behavior than what it used to do.

My work flow is that I use makeMKV to rip to a mkv with the MPEG2 video track. Then I use OneClick in MeGUI(2896) to select that mkv file. That encodes it to an h264 and re-muxes it back into an mkv with the original audio.

I've attached the log file if that's needed.
Attached Files
File Type: 7z MeGUI_Log.7z (4.2 KB, 2 views)
bowlingbeeg is offline   Reply With Quote
Old 29th April 2019, 07:20   #6818  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,833
It often takes a while to get attachments approved here. Can you upload the log to a pastebin as well?
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 29th April 2019, 11:09   #6819  |  Link
bowlingbeeg
Registered User
 
Join Date: Jun 2015
Posts: 4
@LigH - Here you go

https://pastebin.com/3eeMh3td
bowlingbeeg is offline   Reply With Quote
Old 29th April 2019, 11:34   #6820  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,511
The attached file is already approved.

The video input (from makemkv) and the video output (from MeGUI) have the same parameters:

Quote:
FrameCount: 130288
FrameRate: 23.976
FrameRateMode: VFR
Duration: 01:30:34.095
Correct duration for 130288 frames at a CFR of 23.976

The audio extracted and merged have a coherent duration of 01:30:34.080

We need the timestamps file:
"G:\MainMovie\HOLMES_AND_WATSON\h2fkrskg.e0p\HOLMES_AND_WATSON_t00.mkv.timestamps.txt"
to see if there are some strange info to force a FPS of 20.

The MKVToolNix Header editor "default duration" show the "number of nanoseconds per frame"
For a 24000/1001 must show 41708333
For a 20 FPS must show 50000000 ns, is that correct?
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.