Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VapourSynth

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 11th June 2018, 17:39   #1  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 158
VapourSynth Installer, Applications, & Plugins for macOS

What began as a "beginners pack" installer turned into requests for practically everything coming out. It's really impractical to download everything over and over again to get simple updates, so I will be making the external plugins and placing them here in addition to reducing the installer down to a basic VapourSynth install. Each of these plugins are compiled on macOS 10.11 and modified in a way to work with any VapourSynth install. Simply copy the plugin autoloading path and any dependencies to the lib path (ex. /usr/local/lib/vapoursynth & /usr/local/lib).

NOTE: Anyone who used the previous all-in-one installer will need to download a new version of D2V Witch!
NOTE: For anyone already using brew, it is recommended you use that method to install VapourSynth instead of the installer!

Source Downloads

VapourSynth Installer:
Downloads
Installers include D2V Source, FFMS2, & LSMASHSource.
INFO: To access the python environment for the VapourSynth.framework just run vspython in terminal.
IMPORTANT: Installer requires Gatekeeper to be disabled, to do so run the following command in terminal:
Code:
sudo spctl --master-disable
Alternative VapourSynth Install Method:
NOTE: Gatekeeper does not need to be disabled for this method!
Use brew command:
Code:
brew install vapoursynth
IMPORTANT: Brew users will need to create and set the autoload folder prior to installing VapourSynth! Simply run the following commands:
Code:
mkdir -p /usr/local/lib/vapoursynth
mkdir -p "$HOME/Library/Application Support/VapourSynth"
touch "$HOME/Library/Application Support/VapourSynth/vapoursynth.conf"
echo UserPluginDir=/usr/local/lib/vapoursynth >> "$HOME/Library/Application Support/VapourSynth/vapoursynth.conf"
echo SystemPluginDir=/usr/local/lib/vapoursynth >> "$HOME/Library/Application Support/VapourSynth/vapoursynth.conf"

Applications:
D2V Witch v2
VapourSynth Editor
Wobbly v4

Plugins:
Downloads

Current List (& Dependencies):
AddGrain
AutoCrop
aWarpSharp2
Bifrost
Bilateral
BM3D (needs FFTW3F)
CNR2
ColorBars
CombMask
ContinuityFixer
CTMF
D2VSource (needs FFmpeg Libs)
DCTFilter (needs FFTW3F)
Deblock
DeblockPP7
DeCross
DegrainMedian
DeLogo (NOT TESTED)
DePan (needs FFTW3F)
Descale
DFTTest (needs FFTW3F)
DotKill
EEDI2
EEDI3CL (needs Boost & GCC Libs*)
FFMS2 (needs FFmpeg Libs & ZLib)
FFT3DFilter (needs FFTW3F & GCC Libs*)
FieldHint
FillBorders
Flash3kyuu Deband
Fluxsmooth
Format Conversion
GradCurve (NOT TESTED)
Histogram
HQDN3D
KNLMeansCL
LSMASHSource (needs FFmpeg Libs & L-Smash)
MSmoosh
MVTools (needs FFTW3F)
NNEDI3
NNEDI3CL (needs Boost)
RawSource
RemapFrames
Retinex
SangNom
SCXvid
SmoothUV
SSIQ
TCanny
TComb
TDeintMod
TemporalSoften
ToneMap
TTempSmooth
VagueDenoiser
VFR to CFR (NOT TESTED)
Yadifmod
ZNEDI3

*Library files from GCC 8.1.0 are needed for some plugins to work on macOS 10.11 due to C++17 code or other incompatibilities with the one included in the OS. Brew users will need to install GCC then use the following commands to link the needed dylibs:
Code:
sudo ln -s /usr/local/Cellar/gcc/8.1.0/lib/gcc/8/libstdc++.6.dylib /usr/local/lib/libstdc++.6.dylib
sudo ln -s /usr/local/Cellar/gcc/8.1.0/lib/gcc/8/libgcc_s.1.dylib /usr/local/lib/libgcc_s.1.dylib

Last edited by l33tmeatwad; 2nd December 2019 at 16:30. Reason: Updated information.
l33tmeatwad is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.