Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 ASP

Reply
 
Thread Tools Search this Thread Display Modes
Old 16th April 2020, 13:29   #1  |  Link
Mick
Registered User
 
Mick's Avatar
 
Join Date: Nov 2013
Location: France
Posts: 61
Xvid Field Order Question

Hello everyone

Xvid has a Option for "Top Field first" in it's Encoding Options. I encoded a short Sequence with PVR Plus HD using Xvid 1.3.2 from a 12 Year old VHS Tape. Once with "Top Field first" enabled, once disabled. Both captures seem to be the same and wonder if this Option in Xvid does anything.

Here some Details about the two Captures:

PAL, 640x480@25 Fps Interlaced
Pixel Aspect Ration is 1.3333:1 (Wide Screen)

I added two Samples. Can anybody verify which Sample of the two short Captures are really TFF ? Thank you all in advance for your Analysis and Comments.

Cheers

Mick

Downloads:
Sample01.avi

Sample02.avi
__________________
-> May U live 2 C the Dawn <-
Mick is offline   Reply With Quote
Old 16th April 2020, 14:11   #2  |  Link
videoh
Useful n00b
 
Join Date: Jul 2014
Posts: 1,484
They are both TFF, Mick. Maybe the default for the encoder is TFF. Try making a BFF one and see if that is different.

EDIT: Just noticed you can't explicitly set BFF, so having it default to TFF would be weird. But there seem to be lots of unresolved issues with field order in XVID:

https://mencoder-users.mplayerhq.nar...ld-order-issue

Last edited by videoh; 16th April 2020 at 14:24.
videoh is offline   Reply With Quote
Old 17th April 2020, 12:46   #3  |  Link
Mick
Registered User
 
Mick's Avatar
 
Join Date: Nov 2013
Location: France
Posts: 61
Hello videoh

thank you for your comment and ended up with the same results like you. I searched the Forum about the Interlaced Issue with Xvid and found this:

Quote: "interlaced encoding (BFF:1, TFF:2) - default is 1" (User b66pak)

Quote: "You must tell Xvid if your video is Bottom Field First (x = 1) or Top Field First (x = 2) so that it encodes the fields in the right order." (User thewebchat)

Link to the Thread:

Xvid Interlace encoding Problem

By default the Option "Top Field first" is disabled in the Encoding Dialog with Xvid so I guess it must be enabled if the Material is TFF. I captured today the same Sequence again but used TVR Plus HD this Time and made a direct Stream copy with VirtualDub 1.10.4. Sample 1 and 2 where exported with my Cinegy NLE without re-compression. (Intelligent and Smart Rendering enabled)

Could you please take a look at Sample 3 and 4 for me ? I captured Sequence 3 and 4 with the following Details:

PAL, 720x576 at 25 Fps Interlaced (YUY2)
Aspect Ratio is 1.4222:1 (Wide Screen)

All Captures are made directly with the Xvid Codec 1.3.2. Only the Audio was compressed to MP3 (Sample 1,3,4) and AC3 (Sample 2) in Stereo.

Here are the Download Links:

Sample03.avi

Sample04.avi

Thank you very much in advance

Cheers

Mick
__________________
-> May U live 2 C the Dawn <-

Last edited by Mick; 17th April 2020 at 12:55.
Mick is offline   Reply With Quote
Old 17th April 2020, 13:14   #4  |  Link
videoh
Useful n00b
 
Join Date: Jul 2014
Posts: 1,484
Hi Mick. Samples 03 and 04 are both TFF.

You can use this method. Make a script like this.

avisource("Sample03.avi")
assumetff()
separatefields()

Open it in VirtualDub(2) and if it plays normally it is TFF. If it plays back-and-forth then it is BFF. You can change TFF to BFF in your script to verify if you want.

http://rationalqm.us/faq.html

Last edited by videoh; 17th April 2020 at 13:16.
videoh is offline   Reply With Quote
Old 22nd April 2020, 16:47   #5  |  Link
Mick
Registered User
 
Mick's Avatar
 
Join Date: Nov 2013
Location: France
Posts: 61
Hello videoh

thank you for your Post and excuse my late reply. To exclude that Xvid 1.3.2 has a Bug what Interlaced concerns, I tried Version 1.2.2 from Koepi and Jawor with the same results. Xvid 1.3.2 build by Jawor behaves the same Way. What I will try next is a NTSC capture to see if it's BFF instead of TFF.

Somehow the Option TFF in the encoding options works because I noticed a Line Delay of about 40ms when I enabled it. Due to the current shut down Worldwide in many Countries I keep testing and publish the results here.

Take care and stay healthy

Cheers

Mick
__________________
-> May U live 2 C the Dawn <-
Mick is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.