Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th May 2020, 18:55   #1  |  Link
hotripper
Registered User
 
Join Date: Apr 2019
Posts: 53
MadVr stutter workaround

Thought I would post here to help anyone seeking out an answer. Stutter occurs when using some Nvidia cards, mostly Rtx2000 series although I have seen some other complaints from other series owners, and the problem is mostly with 24fps content 60, 30, and even 50 doesnt seem to be so bad (I have a 60hz 4k panel). I discovered a workaround last year and these workarounds seem to have been confirmed by some other members within the madvr or mpc threads. So I thought I'd make a dedicated thread where we can confirm and share things we have experienced.

Workarounds
My preferred option is to just go to Nvidia control panel>manage 3d settings>program settings>set vsync to on for your media player(No need to download Profiler Inspector, set frames presented in advanced to 1 or 3 in madvr not necessary either).

other options:
1.In madvr control panel set frames presented in advance to 1.(setting to 3 also works for some but not for me as the frequency of stutter was only reduced.
2.Or you can also try setting low latency mode to On in nvidia cp.
3.Or set windows power options setting to power saver.

They are ranked in most reliable starting with the first option. None are perfect or guaranteed to work as a fix for the future and may stop working as a fix. Some content may even become out of sync with the audio.

My experience with this issue has been quite weird. For a few months I was having no issues with stutter without having to use a workaround, madvr was functioning normally, then one day it was stuttering again, so now I am using the first workaround. I do not watch too many movies mostly game so I cannot say if it was a driver update or mpc or lav filter update which broke it. I had this issue on my Intel build and now on my AMD build with the only component in common is the rtx2070, I have tried 3 different cards and they all stutter. Sometimes even just a simple boot up will fix it for awhile. I have also noticed setting power option in nvidia cp to high performance for MPC makes it worse so keep it on adaptive or even optimal, note that it doesn't seem to matter when used in combination with the frames in advance to 1 workaround.

Anyhow, you can also search my profile for posts related to this topic if you feel it may help you.

So until we get a fix from the dev which looks like it is not going to happen please post your experiences with the stutter problem here.
__________________
3700X - RTX2070 - 970EVO - EVGA Supernova 750W Gold - Sony KD55X720E

Last edited by hotripper; 30th May 2020 at 00:10.
hotripper is offline   Reply With Quote
Old 24th May 2020, 21:01   #2  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,047
Setting frames presented in advance to 3 or below has worked well for me. That and keeping GPU power management mode on adaptive.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 25th May 2020, 04:51   #3  |  Link
hotripper
Registered User
 
Join Date: Apr 2019
Posts: 53
Cool. I will try to set it to 3. Since I sometimes do notice audio out of sync when at 1.
__________________
3700X - RTX2070 - 970EVO - EVGA Supernova 750W Gold - Sony KD55X720E
hotripper is offline   Reply With Quote
Old 27th May 2020, 11:55   #4  |  Link
Lebowsky
Registered User
 
Join Date: Apr 2007
Posts: 66
that's brilliant! I had been looking for a solution for this and this thread just magically appeared

for what its worth, I have the stutter problem on 50/60fps content on a laptop with Intel HD Graphics GPU. Setting frames in advance to 3 did the trick!

Last edited by Lebowsky; 27th May 2020 at 14:32.
Lebowsky is offline   Reply With Quote
Old 29th May 2020, 14:17   #5  |  Link
SirMaster
Registered User
 
Join Date: Feb 2019
Posts: 112
I’ve found enabling vsync globally or just for the media player from the nvidia control panel also gets rid of any stuttering.
SirMaster is offline   Reply With Quote
Old 29th May 2020, 16:16   #6  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,085
The info is already available here on doom9:
https://forum.doom9.org/showthread.p...70#post1871970 -> VSync
https://forum.doom9.org/showthread.php?t=176013 -> second note under Nvidia section -> frames in advance

Perhaps you find some more useful info there
Klaus1189 is offline   Reply With Quote
Old 29th May 2020, 23:50   #7  |  Link
hotripper
Registered User
 
Join Date: Apr 2019
Posts: 53
Quote:
Originally Posted by SirMaster View Post
Iíve found enabling vsync globally or just for the media player from the nvidia control panel also gets rid of any stuttering.
This seems to be working and is the best option. I swore I did try this but that was over a year ago. I will add it to the starter post as the preferred option. Thanks!

If other users could also confirm setting vsync to on for their media player in nvda cp works for them I am sure it would help others in need.
__________________
3700X - RTX2070 - 970EVO - EVGA Supernova 750W Gold - Sony KD55X720E
hotripper is offline   Reply With Quote
Old 30th May 2020, 00:28   #8  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,047
I have always set frames presented in advance to 3 anyway (for the improved responsiveness) so I never noticed the stutter expect after resetting settings or when testing. Historically forcing v-sync has sometimes caused problems and was not recommend. madVR intends to v-sync normally, but Windows 10 so maybe it helps sometimes today? In a quick test v-sync does not seem to do anything bad but I couldn't reproduce the stutters even with v-sync application controlled and frames presented in advance set to 8 either, so I couldn't test it as a solution.

VRR does not work with madVR, so with a G-sync compatible display it is important to force the video player to a fixed refresh rate, but I don't seem to need to force v-sync on. Perhaps there is more than one variable at play here.
__________________
madVR options explained

Last edited by Asmodian; 30th May 2020 at 00:33. Reason: v-sync = application controlled, not off
Asmodian is offline   Reply With Quote
Old 30th May 2020, 00:40   #9  |  Link
hotripper
Registered User
 
Join Date: Apr 2019
Posts: 53
Quote:
Originally Posted by Asmodian View Post
Perhaps there is more than one variable at play here.
Yes. Thanks for your input. This is on par with my experience. When I talked about weird things in the first post things like the workarounds mentioned simply just aren't needed then one day bam they are needed and stutter returns. nvda vsync is a tricky one, in the past it didnt help but then now we find out it does help. As MS and nvda changes rollout I will try to keep the starter post updated as much as possible for future reference.
__________________
3700X - RTX2070 - 970EVO - EVGA Supernova 750W Gold - Sony KD55X720E
hotripper is offline   Reply With Quote
Old 23rd November 2020, 09:13   #10  |  Link
bombadilio
Registered User
 
Join Date: Mar 2014
Posts: 8
Thank you so much and sorry for opening an old thread...
Any chance you know how to check if SVP is working though with this?

It looks great but I thought I enabled both but I cant tell if SVP is using the right profile.
bombadilio is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.