Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-2 Encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 10th January 2011, 19:21   #1  |  Link
um3k
Registered User
 
Join Date: May 2007
Posts: 220
I-Frame pulsing in HCenc

I'm trying to encode a video for DVD in HCenc, but I keep having problems with I-frame pulsing. I've tried several different matrices with little or no improvement, so I think the problem must lie with one of my other settings. The source is uncompressed, downscaled from edited HDV. It is fairly noisy in some parts, which makes the pulsing more noticeable, but it can be seen on clean frames, as well.

If someone can suggest a way to improve my encode, I would be very grateful. I want this film to be as high quality as I can get it.

Here is my HC.ini:

Code:
*BITRATE          7950
*MAXBITRATE       9000
*FRAMES           0 105168
*PROFILE          best
*GOP              12 0
*PROGRESSIVE
*AVSMEMORY        128
*PULLDOWN
*INTRAVLC         2
*MATRIX           mpeg
*LUMGAIN          3
um3k is offline   Reply With Quote
Old 11th January 2011, 00:41   #2  |  Link
Mug Funky
interlace this!
 
Mug Funky's Avatar
 
Join Date: Jun 2003
Location: i'm in ur transfers, addin noise
Posts: 4,555
*GOP 12 0

that 0 means no b-frames. you should probably make that a 2.

it could well be that the p-frames are having to take one for the team because of a lack of (more efficient) b-frames. the i-frames in this case would provide noticeable quality jolts.
__________________
sucking the life out of your videos since 2004
Mug Funky is offline   Reply With Quote
Old 11th January 2011, 03:47   #3  |  Link
um3k
Registered User
 
Join Date: May 2007
Posts: 220
I have a feeling you nailed it. Gonna try a test encode right now. Now I wonder, how the heck did I mess that one up? I must've been experimenting or something and forgot to set it back. Thanks, I'll let you know how it turns out!

EDIT: Thank you! The problem was exactly as you suggested, setting B-frames made a huge improvement. I probably would've figured it out eventually, but who knows how long it would've been before I looked at the B-frame settings!

Last edited by um3k; 11th January 2011 at 06:23.
um3k is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.