Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD & BD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th September 2010, 01:19   #9521  |  Link
worknstiff
Registered User
 
Join Date: Jun 2009
Posts: 313
@ RB_Newbie: Quote:I've had 3 audio out of sync results. I also just had the issue on "That Evening Sun".

Me too, I tried the Clown_BD path, but for some reason the resulting Blueray output would not load into BD_Rebuilder, something to the effect of error 6205: not BD format. This has started to happen more often lately that output from both multiAVCHD and Clown_BD is not recognised as BD. I finally had to use tsMuxerGUI after BD_Rebuilder finished to delay the audio and get back in sync, (after about 5 tries). I think that the problem I had with Mary & Max and Girl With Dragon was that I couldn't run it thru Clown_BD because these disks had audio streams that were not recognised as compliant. It is hard to keep the audio if it isn't detected. I second the motion to be able to blank some short m2ts files.
worknstiff is offline   Reply With Quote
Old 15th September 2010, 01:36   #9522  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
Quote:
Originally Posted by RB Newbie View Post
As stated, all BD-9 Movie-Only encodes.

I'm pretty sure but not 100% that the second movie that had this issue was "The Girl With the Dragon Tattoo". Did you do a full disc backup? I suspect the issue wouldn't show up there since the audio from different m2ts files isn't merged...if I understand things correctly.

I can try it again to confirm "The Girl With the Dragon Tattoo" if it would help. I suspect you could find the fix with some info on the audio track of the short intro segments causing this issue but I'm not sure what tool to use to provide it. BDInfo and BD-RB just appear to provide a summary of the audio tracks found.
I'll have to check because I don't remember -- but I believe it was movie-only.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 15th September 2010, 01:42   #9523  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
Quote:
Originally Posted by worknstiff View Post
@ RB_Newbie: Quote:I've had 3 audio out of sync results. I also just had the issue on "That Evening Sun".

Me too, I tried the Clown_BD path, but for some reason the resulting Blueray output would not load into BD_Rebuilder, something to the effect of error 6205: not BD format. This has started to happen more often lately that output from both multiAVCHD and Clown_BD is not recognised as BD. I finally had to use tsMuxerGUI after BD_Rebuilder finished to delay the audio and get back in sync, (after about 5 tries). I think that the problem I had with Mary & Max and Girl With Dragon was that I couldn't run it thru Clown_BD because these disks had audio streams that were not recognised as compliant. It is hard to keep the audio if it isn't detected. I second the motion to be able to blank some short m2ts files.
I'm amazed that I've never run into one of these types of discs considering how many I've tested.

[Edit] I just started "The Girl with the Dragon Tattoo" in movie-only as a test. I'd deleted it from my hard drive, so its copying again.

Good movie, by the way, a little disturbing but still good.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 15th September 2010 at 02:34.
jdobbs is offline   Reply With Quote
Old 15th September 2010, 02:43   #9524  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,267
@jdobbs

Here's a link to the thread I spoke of earlier (regarding "The Girl with the Dragon Tattoo"):

http://forum.doom9.org/showthread.ph...29#post1421929

Do read the entire thread - it contains only 4 or 5 posts - and confirms that my "fix" worked properly.

Sorry, I didn't follow up to see if the OP followed my advice to post in your sub-forum - He/She didn't...
setarip_old is offline   Reply With Quote
Old 15th September 2010, 02:46   #9525  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
Quote:
Originally Posted by setarip_old View Post
@jdobbs

Here's a link to the thread I spoke of earlier (regarding "The Girl with the Dragon Tattoo"):

http://forum.doom9.org/showthread.ph...29#post1421929

Do read the entire thread - it contains only 4 or 5 posts - and confirms that my "fix" worked properly.

Sorry, I didn't follow up to see if the OP followed my advice to post in your sub-forum - He/She didn't...
I have a tendency to ignore the "out-of-sync" reports -- because 99% of the time it's caused by people using the wrong version of the helper apps and they don't want to believe me when I tell them. I guess this might be the exception.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 15th September 2010, 03:04   #9526  |  Link
les9596
Registered User
 
Join Date: Jul 2010
Posts: 1
Hello everyone. Not sure if this is a bug, but I haven't been able to run it down any other way so I've got to bother you good folks. I've been using BD Rebuilder for about 6 mos now. Recently I've completed the build of a new PC using an AMD 1090T 6-core. Sure does wonders for my encode time, but the app is only using about 50% of available CPU. As far as I can see nothing else is throttling it. Is it some hidden option I need to set? Have I hit the wall?

Anybody have any idea why I'm not getting (close to) 100% CPU utilization on X264? Thanks for your time.

MOBO: ASUS M4A79TD PRO/USBB3
MEM: 4x2G Patriot PVS34G1333ELKRT
VGA: MSI 460GTX 1GD5 OC
HDD: 4-disk software RAID 0 array - Samsung HD103SJ
PS: Corsair 850TX
Windows 7 64-bit Home Premium

BD_Rebuilder v0.34.08
les9596 is offline   Reply With Quote
Old 15th September 2010, 03:10   #9527  |  Link
Capsbackup
Registered User
 
Join Date: Jul 2005
Posts: 1,995
After viewing the above link, it does not appear BD-RB does any reencoding, but keeps the original intact. I only see one m2ts audio file was reencoded, I think. Looks like a demux then remux.
So why would there be an audio async from this?
Quote:
Movie: Girl With a Dragon Tatoo - BluRay
Log:
[02:24:34] BD Rebuilder v0.34.04 (beta)
- Source: GIRL_WITH_THE_DRAGON_TATTOO
- Input BD size: 18.27 GB
- Approximate total content: [02:33:02.214]
- Target BD size: 22.66 GB
- Windows Version: 6.1 [7600]
- MOVIE-ONLY mode enabled
- Auto Quality: Good (Very Fast), One Pass
- Audio Settings: AC3=1 DTS=1 HD=0 Kbs=640
[02:24:34] PHASE ONE, Encoding
- [02:24:34] Extracting A/V streams [VID_00001]
- [02:47:10] Reencoding: VID_00001 (1 of 4)
- [02:47:10] Collecting video information
- [02:47:10] Keeping original video (no reencode)
- [02:47:10] Reencoding audio tracks (if req'd)
- [02:48:37] Multiplexing M2TS
- [02:48:38] Extracting A/V streams [VID_00000]
- [03:11:12] Reencoding: VID_00000 (2 of 4)
- [03:11:12] Collecting video information
- [03:11:12] Keeping original video (no reencode)
- [03:11:12] Multiplexing M2TS
- [03:19:34] Extracting A/V streams [VID_00017]
- [03:19:37] Reencoding: VID_00017 (3 of 4)
- [03:19:37] Collecting video information
- [03:19:37] Keeping original video (no reencode)
- [03:19:37] Multiplexing M2TS
- [03:19:38] Extracting A/V streams [VID_00018]
- [03:19:38] Reencoding: VID_00018 (4 of 4)
- [03:19:38] Collecting video information
- [03:19:38] Keeping original video (no reencode)
- [03:19:38] Multiplexing M2TS
Capsbackup is offline   Reply With Quote
Old 15th September 2010, 06:11   #9528  |  Link
Elvis Gratton
Registered User
 
Join Date: Apr 2010
Posts: 11
Millenium trilogy
-1 The Girl with the Dragon Tattoo
-2 The Girl Who Played with Fire
-3 The Girl Who Kicked the Hornet's Nest


Same problems here with Canadian (Québec/French) version of "The Girl Who Kicked the Hornet's Nest/La reine du palais des courants d'air"

- single M2TS
- 1x ac3 5.1 Swedish
- 1x ac3 5.1 French
- 1x DTS-HD + MLP 5.1 French
- 2x sub (PGS) French

The playlist is the problem, take a look on original mpls w/bdedit...

start time 10 min. on mpls
movie start time at (10.19.186) on mpls
color bar & other pic. 4 3 2 1 (19.186 sec.)
and finally the yellow bird

audio & sub,s out of sync for 19.186 sec.
__________________
DVD Rebuilder user

Last edited by Elvis Gratton; 15th September 2010 at 16:59.
Elvis Gratton is offline   Reply With Quote
Old 15th September 2010, 06:44   #9529  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
Quote:
Originally Posted by Capsbackup View Post
After viewing the above link, it does not appear BD-RB does any reencoding, but keeps the original intact. I only see one m2ts audio file was reencoded, I think. Looks like a demux then remux.
So why would there be an audio async from this?
It's happening in the audio join that is done by TSMuxer. I'm working on it.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 15th September 2010, 16:55   #9530  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
I fixed the out-of-sync audio issue related to "The Girl with the Dragon Tattoo" and the other similar discs. It'll be included in the next release.

I apparently did a full backup when testing that disc because I was able to repeat the issue in movie-only. Actually it is an issue with the source, not in BD-RB -- as all M2TS files in a single MPLS should have the same audio characteristics... but it's fixed anyway.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 15th September 2010, 17:20   #9531  |  Link
Capsbackup
Registered User
 
Join Date: Jul 2005
Posts: 1,995
Quote:
Originally Posted by jdobbs View Post
I fixed the out-of-sync audio issue related to "The Girl with the Dragon Tattoo" and the other similar discs. It'll be included in the next release.

I apparently did a full backup when testing that disc because I was able to repeat the issue in movie-only. Actually it is an issue with the source, not in BD-RB -- as all M2TS files in a single MPLS should have the same audio characteristics... but it's fixed anyway.
Excellent! As always, your time and efforts are greatly appreciated.
Capsbackup is offline   Reply With Quote
Old 15th September 2010, 18:34   #9532  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,267
@jdobbs
Quote:
Actually it is an issue with the source, not in BD-RB -- as all M2TS files in a single MPLS should have the same audio characteristics...
Reminiscent of the DVD-to-.AVI problems of several years ago, when Warner incorporated "lead-ins" were either silent or of a different audio format than the actual main movie.

Glad to hear that you've resolved it ;>}
setarip_old is offline   Reply With Quote
Old 15th September 2010, 21:48   #9533  |  Link
morenosgth
Registered User
 
Join Date: Sep 2010
Posts: 6
- Windows Version: 6.1 [7600]
- AVISYNTH Version: 2.5.7.0, Ok
- HAALI Splitter: Ok
- FFDSHOW: 3326, Ok
- WIN7 preferred AVC CODEC: Ok
- WIN7 preferred VC-1 CODEC: Ok
- WIN7 preferred MPEG2 CODEC: Ok
- FFDSHOW VC-1 set to "wmv9", Ok
- FFDSHOW MPEG2 set to "libavcodec": Ok
- FFDSHOW AVC set to "libavcodec": Ok
- BD Rebuilder v0.34.0.9, Ok
- X264: Ok
- AFTEN: Ok
- FAAC: Ok
- MP4BOX: Ok
- WAVI: Ok
- TSMUXER: Ok

[22:37:55] BD Rebuilder v0.34.09 (beta)
- Source: NO_ES_TAN_FACIL
- Input BD size: 33,05 GB
- Approximate total content: [02:00:16.834]
- Target BD size: 22,90 GB
- Windows Version: 6.1 [7600]
- Quality: Highest (Very Slow), Two Pass
- Audio Settings: AC3=1 DTS=0 HD=1 Kbs=640
[22:37:56] PHASE ONE, Encoding
- [22:37:56] Extracting A/V streams [VID_00010]
[22:37:56] PHASE ONE, Encoding
- [22:37:56] Extracting A/V streams [VID_00010]
- [22:45:01] Reencoding: VID_00010 (1 of 1)
- [22:45:01] Collecting video information
- [22:45:01] Keeping original video (no reencode)
- [22:45:01] Reencoding audio tracks (if req'd)
- [22:45:01] Multiplexing M2TS
- Error in attempt to multiplex: MUX_00010.meta
- SmartLabs tsMuxeR. Version 1.10.6 http://www.smlabs.net
[22:45:06] - Failed to build structure, aborted

still gives me the problem although I have disabled the filters comentastes me.
that can happen now. thank you very much
morenosgth is offline   Reply With Quote
Old 15th September 2010, 22:03   #9534  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
Quote:
Originally Posted by Capsbackup View Post
Excellent! As always, your time and efforts are greatly appreciated.
I also noticed that the subs are zero-length as a result of the source inconsistency as well. I'm adding a fix for that now.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 15th September 2010, 23:44   #9535  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,267
@jdobbs
Quote:
I also noticed that the subs are zero-length as a result of the source inconsistency as well. I'm adding a fix for that now.
Are you sure that's necessary?

I ask because, if I remember correctly (regarding my post about my earlier experience with "Tattoo"), initially the subs were in lockstep with the audiostreams - at first, out of synch just like the audio and then when the 11 seconds of silent video were separated from the movie-only, video, audio, and subs were all in synch...
setarip_old is offline   Reply With Quote
Old 16th September 2010, 00:53   #9536  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
Quote:
Originally Posted by setarip_old View Post
@jdobbs Are you sure that's necessary?

I ask because, if I remember correctly (regarding my post about my earlier experience with "Tattoo"), initially the subs were in lockstep with the audiostreams - at first, out of synch just like the audio and then when the 11 seconds of silent video were separated from the movie-only, video, audio, and subs were all in synch...
Yes, it's necessary. I don't want to separate or discard the silent video -- I want it to stay as intended in the original authoring and still make everything sync. In "Tattoo" is may not matter -- but it very possibly could in some future feature. There's also always the chance that one or the other of the audio or subs might exist and start in the first M2TS while the other doesn't -- so I have to cover all possibilities.

I've fixed it and just finished watching it back. The sound and subs are in-sync now.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 16th September 2010 at 00:58.
jdobbs is offline   Reply With Quote
Old 16th September 2010, 01:51   #9537  |  Link
allright
Registered User
 
Join Date: Aug 2002
Posts: 49
Damn, that's really to bad. I've donated several times, and just did it again, and will also do so in the future.
Your work is very much appreciated, hopefully people will wake up, and contribute to your work.

//JJ

Quote:
Originally Posted by jdobbs View Post
For those who have donated to BD Rebuilder -- I thank you, please don't feel as if you need to donate again, you've done enough. To those who haven't... it's been a week since I've gotten a donation -- and that one was $5.00. One of three things going have to happen... I kill this project and move on to something new that has better support/interest; I kill the freeware and move to "Professional Edition"; or donations start coming in. I'd prefer the latter.

I like writing this blu-ray software, but I lose interest in a project really fast when it's only popular enough to bring in $5 a week. I feel as if I'm doing my part to bring backups to the masses -- I ask that others share a little of the load too.
__________________
Good Luck

JJ
allright is offline   Reply With Quote
Old 16th September 2010, 03:22   #9538  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,267
@jdobbs
Quote:
I've fixed it and just finished watching it back. The sound and subs are in-sync now.
Congratulations - your method/choice is certainly the surest and BEST way to go ;>}
setarip_old is offline   Reply With Quote
Old 16th September 2010, 11:37   #9539  |  Link
colinhunt
Registered User
 
Join Date: Dec 2002
Posts: 1,022
Quote:
Originally Posted by jdobbs View Post
I fixed the out-of-sync audio issue related to "The Girl with the Dragon Tattoo" and the other similar discs. It'll be included in the next release.
This might in fact help with the Euro release of Robin Hood as well. I'm having the weirdest problem of non-existing subs with that one, but I'll wait for the next release before spending any more cycles on it.
colinhunt is offline   Reply With Quote
Old 16th September 2010, 14:29   #9540  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,929
BD Rebuilder v0.34.10 (beta)

I have updated the first post of this thread with a link to the latest release of BD-RB (v0.34.10). Changes for this release:
Code:
- Corrected an error in which the SETUP dialog was
  not correctly initializing the "Keep only BDMV and
  CERTIFICATE folders" checkbox upon load.
- Created a workaround for an issue in which some 
  poorly authored multi-part sources that have a 
  leading M2TS without audio can result in audio that 
  is out-of-sync on movie-only backups.
- Created a workaround for an issue in which some
  poorly authored multi-part sources that have a
  leading M2TS without subtitles can result in a
  movie-only backup in which subs do not exist.
- Other minor corrections and cosmetic fixes.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.