Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > PC Hard & Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 19th June 2020, 22:25   #1  |  Link
adamf154
Registered User
 
Join Date: Dec 2019
Posts: 1
Possible Ryzen 7 funny screen colour problem

Hi there I think I might have a ryzen 7 1700 black screen problem, for a while now my screen keeps going a funny colour (green, yellow, white, pink, black and blue) and basically crashes, and I have to restart the pc either from the on off button or turning the psu off and then on again, ive changed hdmi wires and tried different tvs, and its def not them, ive formatted windows many times with different versions in the last year but nothing helps, I thought it might be the graphics card, but I didnít have a replacement to check so I put my old cpu (amd a4 A10 processor) with onboard graphics in a month ago and have been montoring it weekly with no problems what so ever so I decided to put the gpu back in 2 weeks ago and try it, I didnít have any other connection options so I bought a display port to hdmi convertor, just incase it was an hdmi slot problem, and have had no problems whatsoever with that either so earlier tonight I decided to put the ryzen 7 back in and after about 3 hours the screan has went about 6 different colours and crashed just like before and if had to restart everytime, im getting really annoyed now, ive checked all drivers and everything is up to date, ive been looking online and others are having the same kind of problem with other ryzen cpu's but no real solutions, I donít have any asus or amd programs running, ive not overclocked anything at all, so I havenít got a clue whats happeinig

Ive just had to put the old processor back in as everytime I click a different tab on the taskbar its going a fuinny colour and crashing, I typed this up in word just incase it crashed as it auto saves it, so im glad I did now

Ryzen 7 1700 Ė just a year old

16Gb ram - couple of years old

Asus prime b350 motherboard year and a half old

Gtx 1050ti 4gb Ė less than a year old

120gb ssd - 3 months old

Windows 10 1909

850w psu Ė coming up for a year old

Thanks in advance for any helping sorting out this problem
adamf154 is offline   Reply With Quote
Old 24th June 2020, 02:55   #2  |  Link
Blue_MiSfit
Derek Prestegard IRL
 
Blue_MiSfit's Avatar
 
Join Date: Nov 2003
Location: Los Angeles
Posts: 5,745
Heat? How are your temps?
Blue_MiSfit is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:48.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.