Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VirtualDub, VDubMod & AviDemux

Reply
 
Thread Tools Search this Thread Display Modes
Old Yesterday, 00:38   #801  |  Link
Tehnicni
Registered User
 
Join Date: Mar 2019
Posts: 2
Opened jpg image is not correct

Attached you have 2 crops, 1st is from 1920 x 1080 picture (which I first resize from 12M pixels origin in VirtualDub) and 2nd from Print Screen how is these picture look opened in VirtualDub. Because of these I get ugly banding in time lapse video. https://youtu.be/IFP4W7nd9VM If I open (in VirtualDub) origin 12M pixels picture and downsize it to 1920 x 1080 with the same resize plugin, there is no banding. https://youtu.be/_zdAa1RwUvM
Without youtube reencoding banding in upper left corner is much uglier.
I also tried with VirtualDub 1.10.4 and it's the same.
I tried the quality of jpeg coding (in exporting downsized image in VirtualDub) 95 and 100 and it's the same.

Added later: Video make with VirtualDub with h264 8bit codec CQP 20 on my Dropbox
https://www.dropbox.com/s/9wzgh4wld5...50Q20.mp4?dl=0

Quite unusual, but for a sunset time lapse very serious mistake. In fact virtualdub it's for me, for time lapse, unusable.
Attached Images
  

Last edited by Tehnicni; Yesterday at 01:10.
Tehnicni is offline   Reply With Quote
Old Yesterday, 02:48   #802  |  Link
shekh
Registered User
 
Join Date: Mar 2015
Posts: 637
Quote:
Originally Posted by wonkey_monkey View Post
I'm not sure if this is a VirtualDub2 problem, but the following Avisynth script:

Code:
colorbars(pixel_type="rgbap8")
comes out all messed up. I was surprised it worked at all, given that VirtualDub2 doesn't understand pixel_type="rgbp8" (no alpha). Is it mistaking RGBAP8 for some other colour space?
rgbap8 and rgbp8 work for me but I have installed intermediate build of avs+ Pinterf gave me.
Which version of avs+ you have?
__________________
VirtualDub2
shekh is offline   Reply With Quote
Old Yesterday, 11:40   #803  |  Link
shekh
Registered User
 
Join Date: Mar 2015
Posts: 637
Tehnicni

It's all unclear. Do you mean
1. you have jpeg image (created in which program?)
2. vdub opens it with loss of quality?

If this is correct please share the image as is so I can examine it.
__________________
VirtualDub2
shekh is offline   Reply With Quote
Old Yesterday, 13:27   #804  |  Link
Tehnicni
Registered User
 
Join Date: Mar 2019
Posts: 2
Quote:
Originally Posted by shekh View Post
Tehnicni

It's all unclear. Do you mean
1. you have jpeg image (created in which program?)
2. vdub opens it with loss of quality?

If this is correct please share the image as is so I can examine it.
I'm sorry, as usually the main thing I forget. Here's the original picture https://www.dropbox.com/s/g9t47up1e5...m0630.jpg?dl=0 . Open it in VirtualDub, aplay crop (bottom 400, top 356), resize it to 1920 x 1080 with Precise Bilinear and export it as .jpg. Then import the same (downsizes) picture into VirtualDub and you will get streaks (band) around the colored cloud above slightly left on the picture.
Downsized image if you would need it: https://www.dropbox.com/s/65ibgcuxb4...0630.jpeg?dl=0
It seems to me that the Precise bilinear resize already changes the (round) cloud, perhaps because the downsizeing removes the noise.

PS: I'm working Time Lapse through the exported images, because I process them before re inported it into VirtualDub for making video.

Last edited by Tehnicni; Yesterday at 13:49.
Tehnicni is offline   Reply With Quote
Old Yesterday, 13:36   #805  |  Link
wonkey_monkey
Formerly davidh*****
 
wonkey_monkey's Avatar
 
Join Date: Jan 2004
Posts: 1,650
Quote:
Originally Posted by shekh View Post
rgbap8 and rgbp8 work for me but I have installed intermediate build of avs+ Pinterf gave me.
Which version of avs+ you have?
r2768.

RGBP8 results in "Couldn't locate decompressor for format '8BPS' (unknown)", while RGBAP8 looks like this:

__________________
My AviSynth filters / I'm the Doctor
wonkey_monkey is offline   Reply With Quote
Old Yesterday, 23:29   #806  |  Link
shekh
Registered User
 
Join Date: Mar 2015
Posts: 637
wonkey_monkey

avs+ needs a new build, there were changes. 8BPS output is deprecated (the fourcc is actually reserved by compressed format). Cant explain rgba picture but it is related for sure.
__________________
VirtualDub2
shekh is offline   Reply With Quote
Old Today, 00:48   #807  |  Link
shekh
Registered User
 
Join Date: Mar 2015
Posts: 637
Tehnicni

I think there is subtle difference in decoding jpeg. Luckily there is an option: in the file open dialog change "input driver/open using" dropdown to "Caching input driver". The result looks smoother to me this way, but the difference is so subtle it is hard to tell what is ground truth.

Note: Caching input driver (using ffmpeg decoder) emits picture in YCbCr 4:2:2 format which I think is good because you do resize (this way should preserve details better).
__________________
VirtualDub2
shekh is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:26.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.