Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th January 2021, 19:12   #8201  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,290
It depends on the videofile. Some files will take "long" till the jump to the exact position is "calculated", if it is not a keyframe. It will be much faster when the keyframes are used to jump to. But then you can only jump to keyframes and this depends how the frames are coded. There can be P, B and I frames, it depends on the encoder and it settings when creating the videofile. Jump to keyframes is faster but not so accurate.
Klaus1189 is offline   Reply With Quote
Old 14th January 2021, 22:03   #8202  |  Link
senzaparole
Registered User
 
Join Date: Jan 2020
Location: Italia
Posts: 49
Quote:
Originally Posted by Aleksoid1978 View Post
What version MPC-BE?
Try without madVR and only with internal filters.
Show MPC-BE's audio renderer Options.
Hello ,
1. the version is: 1.55 x64;

2. if I try without madVR it seems alright but I no longer have the madVR OSD to check. Anyway, I wouldn't want to give up madVR as a video renderer.

3. Here are the audio renderer settings. If I change the audio renderer I don't lose any more frames. I apologize for the italian words in the photo.




@klaus1189
thank you for trying
__________________
TV:LG B9 65 Amplifier: Denon X4500H Front Speakers: n. 3 XTZ Cinema M6 Subwoofer: XTZ 10.17 EDGE Atmos Speakers:n. 4 XTZ S2 Surround Speakers: n. 2 XTZ Spirit 2 - HTPC: Fractal Meshify C-RX 5700 XT
senzaparole is offline   Reply With Quote
Old 15th January 2021, 00:05   #8203  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,538
Quote:
Originally Posted by senzaparole View Post
Hello ,
1. the version is: 1.55 x64;
3. Here are the audio renderer settings.
1. Try latest SVN - https://yadi.sk/d/hlf1lfC8mKU58/!_last
3. Try change WASAPI method, Device buffer.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 15th January 2021, 04:31   #8204  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,485
MPC Video Renderer 0.5.2.1607
Description

Changes:
Fixed getting the displayed frame when outputting RGB 10-bit.
Fixed display of BGRA64 format.
Added support for BGR48 format.
Added correction after incorrect (unsupported) conversion from YCbCr BT.2020 to RGB after DXVA2 and D3D11 VP.
Fixed playback of some protected DVD-Videos.
Improved "Auto display HDR On/Off" option.
Fixed converting color space using shaders.
Various additions and fixes in statistics.
v0lt is offline   Reply With Quote
Old 15th January 2021, 05:47   #8205  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,290
Quote:
Originally Posted by Klaus1189 View Post
Where do I find STRING IDS_MAINFRM_61 to check in GUI?
So I can check
Klaus1189 is offline   Reply With Quote
Old 15th January 2021, 07:55   #8206  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,538
Quote:
Originally Posted by Klaus1189 View Post
So I can check
It's message when trying load subtitles and video-renderer is not compatible.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 15th January 2021, 12:07   #8207  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 2,081
Quote:
Originally Posted by chros View Post
Yes, and brutal stuttering as well even with SDR (1080p/2160p) content

Here's the interesting part: it works fine at 59Hz!!! (even with 23p/25p videos)
Issue happens if I set the TV (in Windows adapter settings) to:
- 23Hz with 23p video
- 25Hz with 25p video

I have 2 displays connected to the HTPC:
- monitor via DVI (only supports 60Hz, so I can't try it on this)
- TV via HDMI (supports 23/24/25/29/30/50/59/60Hz)

Something is not right. And as I said this only happens when Lav Video is set to d3d11-native and d3d11 output is enabled in mpcVR (more visible with "Flip" presentation).
Quote:
Originally Posted by chros View Post
Same with fullscreen exclusive. There's nothing on the stats screen.
But I could recreate it on my monitor as well:
it seems the problem only occurs when fps = display Hz or really close to it (59p on 60Hz)!
So, to try to reproduce it, play back:
- 1080p/2160p 59p SDR video on monitor @ 60Hz
- set LAV Video to d3d11 native (not copyback)
- set mpcVR to d3d11 and set Flip presentation
- it happens in window or fullscreen too

Can anyone reproduce this crazy stutter?
Quote:
Originally Posted by chros View Post
If I set Vertical Sync only to "Fast" in nvidia control panel the problem seems to go away and it works on TV and monitor as well. (None of the other vsync values help.)
- nvidia says about Fast: "GPU renders unconstrained similar to VSYNC OFF, but does not tear since frames in excess of the refresh rate of the monitor are dropped. Delivers latency that is very close to VSYNC off with no tearing"
- from this reddit post: "FAST-SYNC - De-coupled rendering and monitor refresh. VSYNC OFF but the monitor will only render completely rendered frames, thus eliminating tearing (MINOR input lag but NO TEARING! ) also it is monitor agnostic so it will work with any screen. It is analogous to hardware triple buffering but does not back-pressure the render pipeline."

I have never used this option, it was always on "Use the 3D application setting", so I don't know what affect it has with e.g. madvr.
But from this it's clear that it's some kind of timing issue with those settings.

Edit: yep, Fast vsync produces tearing with madvr, so it's not a solution
Quote:
Originally Posted by chros View Post
HLG suppot: a huge (!!!) thank You guys for this!
I watched couple of contents (using dxva2-copyback to don't have tearing/stuttering) and the result is absolutely stunning!
Quote:
Originally Posted by v0lt View Post
Thanks guys for the new release!
An update about the stuttering issue after short testing (last lavfilters is used from December):
- tested with SDR 59p on 60Hz monitor
- mpc-be starts in window mode: no stuttering
- put it into fullscreen (ctrl+enter): stuttering
- skip back/forward (left/right arrow keys) and let it play: no stuttering!!!
- put it into window (ctrl+enter): stuttering
- skip back/forward (left/right arrow keys) and let it play: no stuttering!!!
__________________
Ryzen 5 2600,Asus Prime b450-Plus,16GB,MSI GTX 1060 Gaming X 6GB(v398.18),Win10 LTSC 1809,MPC-BEx64+LAV+MadVR,Yamaha RX-A870,LG OLED65B8(2160p@23/24/25/29/30/50/59/60Hz) | madvr config
chros is offline   Reply With Quote
Old 15th January 2021, 12:46   #8208  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,538
Test with MPC-BE + internal filters.

chros - do you use DX9/DX11, Fulscreen or Fullscreen exclusive ?
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Last edited by Aleksoid1978; 15th January 2021 at 12:57.
Aleksoid1978 is offline   Reply With Quote
Old 15th January 2021, 18:06   #8209  |  Link
clsid
*****
 
Join Date: Feb 2005
Posts: 5,254
I have also seen a few reports from people who had stuttering when switching to or from fullscreen with MPCVR. I don't think issues is related to player or decoding filters.

Default settings, so DX9 non-exclusive. Mostly people with Intel GPUs. Using DX11 often solved it.
clsid is offline   Reply With Quote
Old 15th January 2021, 19:31   #8210  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 2,081
Quote:
Originally Posted by Aleksoid1978 View Post
Test with MPC-BE + internal filters.

chros - do you use DX9/DX11, Fulscreen or Fullscreen exclusive ?
Internal filters are fine since they use dxva2-copyback, as I said above the problem only appears when you use:
- d3d11-native (in lav video decoder)
- and the framerate of the file is close to the refresh rate of the display (e.g. 59p and 60Hz, 25p and 25Hz, etc)

In mpcVR: DX11, no Fullscreen exclusive. (I can upload a screenshot of the settings if you need it)

Now I watch an HLG file, and stuttering happens randomly even if I skip back/forward, but previously it was way worse.

I asked this before: has anyone tried/managed to recreate the issue?
__________________
Ryzen 5 2600,Asus Prime b450-Plus,16GB,MSI GTX 1060 Gaming X 6GB(v398.18),Win10 LTSC 1809,MPC-BEx64+LAV+MadVR,Yamaha RX-A870,LG OLED65B8(2160p@23/24/25/29/30/50/59/60Hz) | madvr config
chros is offline   Reply With Quote
Old 15th January 2021, 19:36   #8211  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,290
Quote:
Originally Posted by Aleksoid1978 View Post
It's message when trying load subtitles and video-renderer is not compatible.
Thanks, but unfortunately I don't can trigger this error-message. Can you or v0lt please check for me the length of the german translation if it fits and is not cut off? I am pretty sure it is a window like when you check for updates and will be fine, but to be sure. Only a small thing. I beg to do that little favor, it won't be much time in your programming environment (Check with 200% window scaling would be nice too, if that is possible) Thanks in advance
Klaus1189 is offline   Reply With Quote
Old 15th January 2021, 23:34   #8212  |  Link
senzaparole
Registered User
 
Join Date: Jan 2020
Location: Italia
Posts: 49
Quote:
Originally Posted by Aleksoid1978 View Post
1. Try latest SVN - https://yadi.sk/d/hlf1lfC8mKU58/!_last
3. Try change WASAPI method, Device buffer.
I solved the problem!!!!! In the MPC Audio Renderer settings it was enough to change the DEVICE BUFFER from 50 ms to DEFAULT!
Now I don't lose frames anymore and madVR's OSD is perfect!
Thanks for your help!: D
__________________
TV:LG B9 65 Amplifier: Denon X4500H Front Speakers: n. 3 XTZ Cinema M6 Subwoofer: XTZ 10.17 EDGE Atmos Speakers:n. 4 XTZ S2 Surround Speakers: n. 2 XTZ Spirit 2 - HTPC: Fractal Meshify C-RX 5700 XT
senzaparole is offline   Reply With Quote
Old 16th January 2021, 03:38   #8213  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,538
I don't understand what you mean "stuttering" ? Maybe more detail explain, screenshot/video ???
I use DX11 + FSE, all perfect after switching window/FSE mode.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 16th January 2021, 05:24   #8214  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,414
He was dropping frames and for some reason the frames were repeating more often too (audio buffer shouldn't affect this) You can see his posts in the MadVR forum.
ryrynz is offline   Reply With Quote
Old 16th January 2021, 07:04   #8215  |  Link
Kl3r
Registered User
 
Join Date: Apr 2020
Posts: 10
Hi! I am using MPC-BE in its stable version. It's my video player and I find it great!

I see on this forum that it is possible to install other extensions (madVR, LAV, ...).

Is the software not sufficient on its own? I don't quite understand it because I find the software to work fine "by default".

I have a 1080p display (not HDR), is this interesting for me?
Kl3r is offline   Reply With Quote
Old 16th January 2021, 09:08   #8216  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,485
Quote:
Originally Posted by Kl3r View Post
Is the software not sufficient on its own? I don't quite understand it because I find the software to work fine "by default".
It will be useful to install LAV Splitter in the system to support HLS streams and some rare formats. You don't need the rest.
v0lt is offline   Reply With Quote
Old 16th January 2021, 10:52   #8217  |  Link
Grimsdyke
Registered User
 
Join Date: Nov 2013
Location: Hannover, Germany
Posts: 185
In LAV splitter you can also increase cache size to quite high values which "can" be useful on systems with weaker/older hardware.
Grimsdyke is offline   Reply With Quote
Old 16th January 2021, 11:59   #8218  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,485
Quote:
Originally Posted by Grimsdyke View Post
In LAV splitter you can also increase cache size to quite high values which "can" be useful on systems with weaker/older hardware.
Probably not.
v0lt is offline   Reply With Quote
Old 16th January 2021, 12:44   #8219  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,538
Quote:
Originally Posted by ryrynz View Post
He was dropping frames and for some reason the frames were repeating more often too (audio buffer shouldn't affect this) You can see his posts in the MadVR forum.
Can somebody record video with enabled statistics in MPC VR. I never see drop or repeat frames - it's happened only when system is slow for decoding/output.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 16th January 2021, 15:07   #8220  |  Link
cmhrky
Registered User
 
Join Date: Jan 2017
Posts: 90
Latest Turkish translation with some fixes based on r5964.
cmhrky is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.