Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 3rd December 2018, 19:27   #6661  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,362
Quote:
Originally Posted by pommesmatte View Post
Setting in DGIndexNV.ini is always reset to not use Full Paths.
Are you sure about that? I force "Full_Path_In_Files=1" during every run of the dgindexnv step. How do you reproduce it? Do you open the DGIndexNV application manually inbetween? Could you please upload a log of the step?
Zathor is offline   Reply With Quote
Old 3rd December 2018, 20:29   #6662  |  Link
pommesmatte
Registered User
 
Join Date: Aug 2012
Posts: 29
Quote:
Originally Posted by Zathor View Post
Are you sure about that? I force "Full_Path_In_Files=1" during every run of the dgindexnv step. How do you reproduce it? Do you open the DGIndexNV application manually inbetween? Could you please upload a log of the step?
Steps to reproduce:
-DGIndexNV.ini includes "Full_Path_In_Files=1"
-During file indexing "Full_Path_In_Files=1" is removed from the file (resulting in relative file paths in the dgi file)
-After the process ends "Full_Path_In_Files=0" gets written back to the ini file
-<next run>
-DGIndexNV.ini includes "Full_Path_In_Files=0"
-During file indexing "Full_Path_In_Files=1" is set (resulting in absolute file paths in the dgi file)
-After the process ends "Full_Path_In_Files=1" gets written back to the ini file
-<repeat>

So without manually editing the file, only every second run is fine.

Last edited by pommesmatte; 3rd December 2018 at 20:32.
pommesmatte is offline   Reply With Quote
Old 3rd December 2018, 21:05   #6663  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,362
I am sadly not able to reproduce it. Could you please upload your dgindexnv.ini and a MeGUI log?
Zathor is offline   Reply With Quote
Old 3rd December 2018, 21:58   #6664  |  Link
pommesmatte
Registered User
 
Join Date: Aug 2012
Posts: 29
Quote:
Originally Posted by Zathor View Post
I am sadly not able to reproduce it. Could you please upload your dgindexnv.ini and a MeGUI log?


First run (resulting in absolute paths)
Code:
[Information] Log for job14 (idx, HANGMAN_F1_T2_Video - .mkv -> HANGMAN_F1_T2_Video - .dgi)
-[Information] [03.12.2018 21:47:15] Started handling job
-[Information] [03.12.2018 21:47:15] Preprocessing
-[Information] [03.12.2018 21:47:15] Full_Path_In_Files=1 written to DGIndexNV.ini
-[Information] [03.12.2018 21:47:15] Job command line: "C:\Multimedia\MeGUI-x64\tools\dgindexnv\dgindexnv.exe" -i "E:\_Eingang\hangman\HANGMAN_F1_T2_Video - .mkv" -o "E:\_Eingang\hangman\HANGMAN_F1_T2_Video - .dgi" -h
-[Information] [03.12.2018 21:47:15] Process started
-[Information] [03.12.2018 21:47:15] Standard output stream
--[Information] [03.12.2018 21:47:16] Project
-[Information] [03.12.2018 21:47:15] Standard error stream
-[Information] [03.12.2018 21:50:06] MediaInfo
--[Information] File: E:\_Eingang\hangman\HANGMAN_F1_T2_Video - .dgi
--[Information] Indexed file: E:\_Eingang\hangman\HANGMAN_F1_T2_Video - .mkv
--[Information] General
---[Information] Format: Matroska
---[Information] FileSize: 16226081661
---[Information] PlayTime: 01:38:22.814
--[Information] Video
---[Information] ID: 1
---[Information] StreamOrder: 0
---[Information] CodecID: V_MPEG4/ISO/AVC
---[Information] Format: AVC
---[Information] FormatInfo: Advanced Video Codec
---[Information] Width: 1920
---[Information] Height: 1080
---[Information] FrameCount: 141526
---[Information] FrameRate: 23.976
---[Information] FrameRateMode: CFR
---[Information] FrameRateModeString: Constant
---[Information] Duration: 01:38:22.820
---[Information] ScanType: Progressive
---[Information] Bits Depth: 8
---[Information] AspectRatio: 1.778
---[Information] AspectRatioString: 16:9
---[Information] PixelAspectRatio: 1.000
---[Information] Delay: 0
---[Information] Default: No
---[Information] Forced: No
-[Information] [03.12.2018 21:50:07] Postprocessing
-[Information] [03.12.2018 21:50:10] Job completed
DGIndexNV after that
Code:
Version=DGIndexNV 2053.0.0.161
Window_Position=197,125
Info_Window_Position=0,0
Process_Priority=2
Playback_Speed=3
AVS_Template_Folder=
AVS_Template_File=template.avs
AVS_Template_File_Index=0
AVS_Enable_Template=1
AVS_Overwrite=0
Full_Path_In_Files=1
MRUList[0]=E:\_Eingang\hangman\HANGMAN_F1_T2_Video - .mkv
MRUList[1]=E:\_Eingang\overboard\OVERBOARD_F2_T1_Video - .mkv
MRUList[2]=
MRUList[3]=
Enable_Info_Log=0
Loop_Playback=0
AVC_Extension=264
MPG_Extension=m2v
VC1_Extension=vc1
HEVC_Extension=265
Deinterlace=0
UsePF=0
AlwaysCrop=1
UseD3D=0
Snapped=0
ResponseOnAudioMismatch=0
Enable_Audio_Demux=1
CUDA_Device=255
Decode_Modes=0,0,0,0
Full_Info=1
Bare_Demux=0
Disable_Encrypted_Audio_Warning=0
Fine_Cropping=0
Force_Zoom=0
StrictAVC=0
PGSForcedOnly=0
Next run (resulting in relative paths)
Code:
[Information] Log for job15 (idx, PETER_RABBIT_F1_T2_Video - .mkv -> PETER_RABBIT_F1_T2_Video - .dgi)
-[Information] [03.12.2018 21:51:56] Started handling job
-[Information] [03.12.2018 21:51:56] Preprocessing
-[Information] [03.12.2018 21:51:56] Enable_Info_Log=1 written to DGIndexNV.ini
-[Information] [03.12.2018 21:51:56] ResponseOnAudioMismatch=1 written to DGIndexNV.ini
-[Information] [03.12.2018 21:51:56] Job command line: "C:\Multimedia\MeGUI-x64\tools\dgindexnv\dgindexnv.exe" -i "E:\_Eingang\peter hase\PETER_RABBIT_F1_T2_Video - .mkv" -o "E:\_Eingang\peter hase\PETER_RABBIT_F1_T2_Video - .dgi" -h
-[Information] [03.12.2018 21:51:56] Process started
-[Information] [03.12.2018 21:51:56] Standard output stream
--[Information] [03.12.2018 21:51:56] Project
-[Information] [03.12.2018 21:51:56] Standard error stream
-[Information] [03.12.2018 21:55:17] MediaInfo
--[Information] File: E:\_Eingang\peter hase\PETER_RABBIT_F1_T2_Video - .dgi
--[Information] Indexed file: E:\_Eingang\peter hase\PETER_RABBIT_F1_T2_Video - .mkv
--[Information] General
---[Information] Format: Matroska
---[Information] FileSize: 19074151615
---[Information] PlayTime: 01:34:42.677
--[Information] Video
---[Information] ID: 1
---[Information] StreamOrder: 0
---[Information] CodecID: V_MPEG4/ISO/AVC
---[Information] Format: AVC
---[Information] FormatInfo: Advanced Video Codec
---[Information] Width: 1920
---[Information] Height: 1080
---[Information] FrameCount: 136248
---[Information] FrameRate: 23.976
---[Information] FrameRateMode: CFR
---[Information] FrameRateModeString: Constant
---[Information] Duration: 01:34:42.683
---[Information] ScanType: Progressive
---[Information] Bits Depth: 8
---[Information] AspectRatio: 1.778
---[Information] AspectRatioString: 16:9
---[Information] PixelAspectRatio: 1.000
---[Information] Delay: 0
---[Information] Default: No
---[Information] Forced: No
-[Information] [03.12.2018 21:55:17] Postprocessing
-[Information] [03.12.2018 21:55:23] Job completed
DGIndexNV after that
Code:
Version=DGIndexNV 2053.0.0.161
Window_Position=197,125
Info_Window_Position=0,0
Process_Priority=2
Playback_Speed=3
AVS_Template_Folder=
AVS_Template_File=template.avs
AVS_Template_File_Index=0
AVS_Enable_Template=1
AVS_Overwrite=0
Full_Path_In_Files=0
MRUList[0]=E:\_Eingang\peter hase\PETER_RABBIT_F1_T2_Video - .mkv
MRUList[1]=E:\_Eingang\hangman\HANGMAN_F1_T2_Video - .mkv
MRUList[2]=E:\_Eingang\overboard\OVERBOARD_F2_T1_Video - .mkv
MRUList[3]=
Enable_Info_Log=1
Loop_Playback=0
AVC_Extension=264
MPG_Extension=m2v
VC1_Extension=vc1
HEVC_Extension=265
Deinterlace=0
UsePF=0
AlwaysCrop=1
UseD3D=0
Snapped=0
ResponseOnAudioMismatch=1
Enable_Audio_Demux=1
CUDA_Device=255
Decode_Modes=0,0,0,0
Full_Info=1
Bare_Demux=0
Disable_Encrypted_Audio_Warning=0
Fine_Cropping=0
Force_Zoom=0
StrictAVC=0
PGSForcedOnly=0

Last edited by pommesmatte; 3rd December 2018 at 22:03.
pommesmatte is offline   Reply With Quote
Old 3rd December 2018, 22:14   #6665  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,362
Ok, thanks, with your ini files I am able to reproduce it. Question is why this is happening. Before DGIndexNV starts the value is correct, afterwards it gets removed.
EDIT: Sorry, no clue. I made a line by line comparison and changed everything to the default one, however it still reverts to 0. Could you please delete your dgindexnv.ini and try it again?

Last edited by Zathor; 3rd December 2018 at 22:25.
Zathor is offline   Reply With Quote
Old 3rd December 2018, 22:26   #6666  |  Link
pommesmatte
Registered User
 
Join Date: Aug 2012
Posts: 29
Quote:
Originally Posted by Zathor View Post
Ok, thanks, with your ini files I am able to reproduce it. Question is why this is happening. Before DGIndexNV starts the value is correct, afterwards it gets removed.
Maybe it's related to those other option being changed (Enable_Info_Log and ResponseOnAudioMismatch)?
pommesmatte is offline   Reply With Quote
Old 3rd December 2018, 22:57   #6667  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,362
No, DGIndexNV resets several values to default at that run including the full path.

Please see my edit above and try to delete your ini file.

2896 is online
Zathor is offline   Reply With Quote
Old 4th December 2018, 11:21   #6668  |  Link
wthreex
Registered User
 
Join Date: Oct 2015
Posts: 40
is there a way to bypass foreign filename? i always get error on this and seems Megui unable to handle it (my file name: הפגנת השבת בירושלים

wthreex is offline   Reply With Quote
Old 4th December 2018, 19:22   #6669  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,362
Quote:
Originally Posted by wthreex View Post
is there a way to bypass foreign filename? i always get error on this and seems Megui unable to handle it (my file name: הפגנת השבת בירושלים)
Yes, as some filters are not able to deal with this characters you do have to rename the file before you process it.
Potentially I can do the same either in the way that
- the file is renamed during the whole process
- or the file is copied to the working path with a new file name
I tend to go the second way as this works every time (rename is only possible if the source can be modified).
Any thoughts?
Zathor is offline   Reply With Quote
Old 4th December 2018, 22:44   #6670  |  Link
pommesmatte
Registered User
 
Join Date: Aug 2012
Posts: 29
Quote:
Originally Posted by Zathor View Post
No, DGIndexNV resets several values to default at that run including the full path.

Please see my edit above and try to delete your ini file.

2896 is online
Deleting worked.

However I could reproduce the buggy behaviour again, by disabling full paths in DGIndexNV GUI (it seems that also was the culprit before).

After that the behaviour is as described. It can be repaired by deleting ini file OR by enabling the option IN THE GUI again, manually editing the option in the DGIndexNV.ini does not work however.
pommesmatte is offline   Reply With Quote
Old 4th December 2018, 22:50   #6671  |  Link
videoh
Registered User
 
Join Date: Jul 2014
Posts: 589
Quote:
Originally Posted by pommesmatte View Post
It can be repaired by deleting ini file OR by enabling the option IN THE GUI again, manually editing the option in the DGIndexNV.ini does not work however.
That doesn't make any sense to me, because using the GUI simply rewrites the INI file with the specified options.
videoh is offline   Reply With Quote
Old 5th December 2018, 08:01   #6672  |  Link
wthreex
Registered User
 
Join Date: Oct 2015
Posts: 40
Quote:
Originally Posted by Zathor View Post
Yes, as some filters are not able to deal with this characters you do have to rename the file before you process it.
Potentially I can do the same either in the way that
- the file is renamed during the whole process
- or the file is copied to the working path with a new file name
I tend to go the second way as this works every time (rename is only possible if the source can be modified).
Any thoughts?
it would be nice megui keeps the original file name, sometimes i've encode whole folder with 100 file with oneclick encoder and it's hard for me to manually rename every file in the folder.
wthreex is offline   Reply With Quote
Old 5th December 2018, 08:58   #6673  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,669
But if not every tool in the tool chain supports Unicode filenames, MeGUI will have to rename files at least temporarily (similar to the behaviour of ExactAudioCopy).
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 6th December 2018, 15:48   #6674  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,765
Quote:
Originally Posted by Zathor View Post
Based on the current issues (see above) I cannot fully change it as I would like it as I do not have the time for it. So in 2896 this will be partially changed/adjusted based on your feedback.
Cheers.

So far so good. I assume it's not possible to completely fix the DGIndexNV problem with mod2 video.
I made another sample, 602x362 this time. DGIndexNV adds "CLIP 0 6 0 6" to the index file, but it seems only the mod4 part of the padding is cropped. The rest is resized. There's probably nothing MeGUI could do to work around that.

There also seems to be some frame rate oddness. When I opened the original vob file I used to create the mod2 test MKV with DGIndexNV, it showed the frame rate as 29.970030 and the index file said
FPS 30000 / 1001
However for the MKV encode I made from the vob file, DGIndexNV itself showed 29.970031, but the index file said
FPS 299700 / 10000

As well as the mod2 problem videoh said doesn't need fixing because it's not a problem, you can see the LWLibavVideoSource vs DGDecode frame rate difference in the screenshots. Maybe MeGUI should automatically add AssumeFPS to a DGSource script?

LWLibavVideoSource("D:\test.mkv.lwi")



DGSource("D:\test.dgi")



The rest of the GUI unfriendliness seems to have been worked around, although given there's mod2 issues preventing MeGUI from correctly calculating any aspect error, I'd consider blocking DGIndexNV for mod2 sources.

Thanks for the hard work!

Last edited by hello_hello; 6th December 2018 at 15:55.
hello_hello is offline   Reply With Quote
Old 6th December 2018, 15:54   #6675  |  Link
LouieChuckyMerry
Registered User
 
LouieChuckyMerry's Avatar
 
Join Date: Feb 2014
Posts: 236
Quote:
Originally Posted by wthreex View Post
it would be nice megui keeps the original file name, sometimes i've encode whole folder with 100 file with oneclick encoder and it's hard for me to manually rename every file in the folder.
Using something like Everything, to sort by type then select all, in conjunction with something like Renamer or Bulk Rename Utility makes renaming large numbers of files quite simple.
LouieChuckyMerry is offline   Reply With Quote
Old 6th December 2018, 16:57   #6676  |  Link
videoh
Registered User
 
Join Date: Jul 2014
Posts: 589
Quote:
As well as the mod2 problem videoh said doesn't need fixing because it's not a problem
Not a problem in DGDec code (I have clarified my previous post). The issue is possibly caused by a bug in NVDec (acknowledged by nVidia). There is nothing I can do to fix this in DGDec code. nVidia has entered an internal bug report and the driver will be fixed at some point in the future.

If you provide the stream I can look at your FPS matter. However, the difference appears practically insignificant. It might be resolved already with a change I did for Zathor (not yet slipstreamed): prefer the container frame rate over the ES frame rate. With your stream I can confirm or disconfirm that.

Last edited by videoh; 6th December 2018 at 21:40.
videoh is offline   Reply With Quote
Old 6th December 2018, 19:56   #6677  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,765
Quote:
Originally Posted by videoh View Post
Not a problem in DGDec code. The issue is caused by a bug in NVDec (acknowledged by nVidia). There is nothing I can do to fix this in DGDec code. nVidia has entered an internal bug report and the driver will be fixed at some point in the future.
Did you know that before you hassled me for a sample, but decided to demand one anyway, or did you find out afterwards without needing a sample from me after-all?
hello_hello is offline   Reply With Quote
Old 6th December 2018, 20:27   #6678  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,362
Quote:
Originally Posted by hello_hello View Post
Did you know that before you hassled me for a sample, but decided to demand one anyway, or did you find out afterwards without needing a sample from me after-all?
I have provided a sample. Could we however please go back to the MeGUI topic?
Zathor is offline   Reply With Quote
Old 6th December 2018, 20:40   #6679  |  Link
videoh
Registered User
 
Join Date: Jul 2014
Posts: 589
Quote:
Originally Posted by hello_hello View Post
Did you know that before you hassled me for a sample, but decided to demand one anyway, or did you find out afterwards without needing a sample from me after-all?
I am not hassling anybody nor demanding anything. I am trying to help to get reported issues resolved.

The first sample that I politely requested and that you declined to supply was for your cropping issue. I was aware of the NVDec issue but needed to confirm that this was the root issue for you and not something else. Be aware that issues with the same or similar symptoms can sometimes be caused by different root causes.

This second sample that I have politely requested is to confirm or disconfirm that your FPS issue is resolved by my recent change not yet slipstreamed. The file that Zathor has kindly supplied cannot help me to confirm that your file is or is not now handled properly regarding FPS detection. Can you please provide this sample that shows your FPS issue? Thank you.

Last edited by videoh; 6th December 2018 at 21:26.
videoh is offline   Reply With Quote
Old 8th December 2018, 06:33   #6680  |  Link
kuchikirukia
Registered User
 
Join Date: Oct 2014
Posts: 401
Does high bit depth input no longer work in MeGUI? I updated to 2867 and now 16 bit from dither tools doesn't seem to work. I see MeGUI is now using ffmpeg instead of avs4x26x.exe.
kuchikirukia is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.