Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > New and alternative video codecs

Reply
 
Thread Tools Search this Thread Display Modes
Old 25th April 2017, 07:37   #201  |  Link
wiak
Registered User
 
Join Date: Jul 2003
Location: somewhere north
Posts: 260
Quote:
Originally Posted by GTPVHD View Post
https://bitmovin.com/bitmovin-suppor...ce-open-media/

Another company joins the Rebel Alliance.
fixed it for you
__________________
Woah! Ninja?! http://nwgat.ninja/ (AV1 Overview)
"Not available in your region" has now been redefined as "Go Pirate, you filthy scum" Nwgat
wiak is offline   Reply With Quote
Old 29th April 2017, 06:45   #202  |  Link
blurred
Registered User
 
Join Date: Jul 2016
Posts: 14
Some optimistic benchmarks: https://www.linkedin.com/pulse/aom-a...c-marc-clement
blurred is offline   Reply With Quote
Old 29th April 2017, 06:49   #203  |  Link
blurred
Registered User
 
Join Date: Jul 2016
Posts: 14
Optimistic benchmarks from Elecard: https://www.linkedin.com/pulse/aom-a...c-marc-clement
blurred is offline   Reply With Quote
Old 5th May 2017, 19:10   #205  |  Link
bstrobl
Registered User
 
Join Date: Jun 2016
Posts: 55
NAB Show 2017:

http://www.nabshow.com/video/algorithms-power-web-video
bstrobl is offline   Reply With Quote
Old 7th May 2017, 22:21   #206  |  Link
dapperdan
Registered User
 
Join Date: Aug 2009
Posts: 179
Did the Netflix rep say they were supporting work on the Eve encoder and seeing an extra 5% improvement? That's pretty cool.
dapperdan is offline   Reply With Quote
Old 8th May 2017, 09:06   #207  |  Link
easyfab
Registered User
 
Join Date: Jan 2002
Posts: 327
http://www.streamingmediaglobal.com/...ticleID=118062

OT @dappedan

"he mentioned that they weren't using the stock open-source VP9 encoder available from Google. Rather, they were encoding with technology from a company called Two Orioles, which was founded by Ronald Bultje, a lead VP9 developer. Ronca mentioned that in particular, Netflix had found that the open-source VP9's two-pass rate control mechanism was suboptimal, and that Bultje's encoder is currently about 8% more efficient than Google's."

/OT

"Google's Frost claimed that AV1 was currently 30-35% more efficient than VP9"

Is correct that's nice .
easyfab is offline   Reply With Quote
Old 8th May 2017, 12:53   #208  |  Link
dapperdan
Registered User
 
Join Date: Aug 2009
Posts: 179
That does introduce ambiguity into their comments about e.g. AV1 is 20% better than VP9, do they mean libvpx or eve encoded VP9? Since that could mean a further 8% difference.
dapperdan is offline   Reply With Quote
Old 20th May 2017, 14:34   #209  |  Link
Gravitator
Registered User
 
Join Date: May 2014
Posts: 169
I do not get normal (smeared squares) AV1 playback through tmodLAV.
Samples > https://www.elecard.com/videos
Gravitator is offline   Reply With Quote
Old 20th May 2017, 14:51   #210  |  Link
mzso
Registered User
 
Join Date: Oct 2009
Posts: 838
Quote:
Originally Posted by Gravitator View Post
I do not get normal (smeared squares) AV1 playback through tmodLAV.
Samples > https://www.elecard.com/videos
Which other options are there to play AV1 videos?
mzso is offline   Reply With Quote
Old 20th May 2017, 14:53   #211  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,413
You are dealing with experimental software and the bitstream hasn't been frozen yet. A sample created with yesterday's encoder might not work with today's decoder. Such things are expected. If you think you found a "real" bug in either encoder or decoder report it to the developers.
sneaker_ger is offline   Reply With Quote
Old 20th May 2017, 15:10   #212  |  Link
Gravitator
Registered User
 
Join Date: May 2014
Posts: 169
Quote:
Originally Posted by mzso View Post
Which other options are there to play AV1 videos?
Elecard MPEG Player (only my processor can not cope - it slows down).
Gravitator is offline   Reply With Quote
Old 20th May 2017, 15:13   #213  |  Link
mzso
Registered User
 
Join Date: Oct 2009
Posts: 838
Quote:
Originally Posted by sneaker_ger View Post
You are dealing with experimental software and the bitstream hasn't been frozen yet. A sample created with yesterday's encoder might not work with today's decoder. Such things are expected. If you think you found a "real" bug in either encoder or decoder report it to the developers.
Do you know of recent samples one can download?
mzso is offline   Reply With Quote
Old 20th May 2017, 15:17   #214  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,413
I don't.
sneaker_ger is offline   Reply With Quote
Old 20th May 2017, 16:30   #215  |  Link
wiak
Registered User
 
Join Date: Jul 2003
Location: somewhere north
Posts: 260
here is the thing "its not finished, so a newer or older decoder will not work, it has to be exact"
there is one way to do it, its to encode a file and use
Quote:
./aomdec file.webm| mpv -
__________________
Woah! Ninja?! http://nwgat.ninja/ (AV1 Overview)
"Not available in your region" has now been redefined as "Go Pirate, you filthy scum" Nwgat
wiak is offline   Reply With Quote
Old 1st June 2017, 17:58   #216  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: Germany
Posts: 5,635
How does 2 pass work?

D:\Projekte\VS\VB\StaxRip\bin\Apps\ffmpeg\ffmpeg.exe -i D:\Temp\staxrip\Eli_temp\Eli.avs -f yuv4mpegpipe - | D:\Projekte\VS\VB\StaxRip\bin\Apps\aomenc\aomenc.exe - --passes=2 --pass=1 --target-bitrate=1167 -o D:\Temp\staxrip\Eli_temp\Eli_out.webm

av_interleaved_write_frame(): Broken pipe
Error writing trailer of pipe:: Broken pipe
frame= 1 fps=0.0 q=-0.0 Lsize= 191kB time=00:00:00.03 bitrate=46971.0kbits/s speed=0.0618x
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 39397.984375%
Conversion failed!
stax76 is offline   Reply With Quote
Old 1st June 2017, 18:06   #217  |  Link
wiak
Registered User
 
Join Date: Jul 2003
Location: somewhere north
Posts: 260
Quote:
Originally Posted by stax76 View Post
How does 2 pass work?

D:\Projekte\VS\VB\StaxRip\bin\Apps\ffmpeg\ffmpeg.exe -i D:\Temp\staxrip\Eli_temp\Eli.avs -f yuv4mpegpipe - | D:\Projekte\VS\VB\StaxRip\bin\Apps\aomenc\aomenc.exe - --passes=2 --pass=1 --target-bitrate=1167 -o D:\Temp\staxrip\Eli_temp\Eli_out.webm

av_interleaved_write_frame(): Broken pipe
Error writing trailer of pipe:: Broken pipe
frame= 1 fps=0.0 q=-0.0 Lsize= 191kB time=00:00:00.03 bitrate=46971.0kbits/s speed=0.0618x
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 39397.984375%
Conversion failed!
1. you cant pipe
2. its default
3. so far i know
__________________
Woah! Ninja?! http://nwgat.ninja/ (AV1 Overview)
"Not available in your region" has now been redefined as "Go Pirate, you filthy scum" Nwgat
wiak is offline   Reply With Quote
Old 1st June 2017, 18:17   #218  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: Germany
Posts: 5,635
Is there a avs/vs reader then?
stax76 is offline   Reply With Quote
Old 1st June 2017, 18:19   #219  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,413
I vaguely remember you having the same problem with the VP9 encoder. With auto-2pass piping doesn't work because it cannot rewind the pipe. But manual 2pass should be possible or is that feature not available in the AV1 encoder? Or does it really not support pipe input at all?
sneaker_ger is offline   Reply With Quote
Old 1st June 2017, 18:21   #220  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: Germany
Posts: 5,635
staxrip uses ffmpeg for VP9 but I don't remember how it works. I've tried with avs input:

C:\WINDOWS\system32>D:\Projekte\VS\VB\StaxRip\bin\Apps\aomenc\aomenc.exe D:\Temp\staxrip\Eli_temp\Eli.avs --target-bitrate=1167 -o D:\Temp\staxrip\Eli_temp\Eli_out.webm
Fatal: Specify stream dimensions with --width (-w) and --height (-h)

edit:

C:\WINDOWS\system32>D:\Projekte\VS\VB\StaxRip\bin\Apps\aomenc\aomenc.exe D:\Temp\staxrip\Eli_temp\Eli.avs --target-bitrate=1167 --width=1280 --height=720 -o D:\Temp\staxrip\Eli_temp\Eli_out.webm
Pass 1/2 frame 0/0 0B 0b/f 0b/s 0 us (0.00 fps)
Failed to initialize encoder: Invalid parameter
rc_twopass_stats_in requires at least two packets.
stax76 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.