Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th June 2019, 22:22   #6321  |  Link
SirMaster
Registered User
 
Join Date: Feb 2019
Posts: 40
Quote:
Originally Posted by stax76 View Post
Not supported by mpc, players I'm aware of are:

Lua: vlc, mpv(.net)
JavaScript: mpv(.net)
AngelScript: PotPlayer
COM Automation: JRiver
C Python: Kodi
IronPython: mpv.net
dotnet add-ons: mpv.net
PowerShell: mpv.net
CS-Script: mpv.net
Thanks.

If only mpv supported madVR!
SirMaster is offline   Reply With Quote
Old 8th June 2019, 04:22   #6322  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,120
Quote:
Originally Posted by SirMaster View Post
Does anyone know if there is some sort of API or mechanism that I can use to hook into MPC-BE's events like play, pause, stop?

For instance I want to run a script that turns off my room lighting when playback in mpc-be starts, and turns on room lighting when playback is paused or stopped.

Any ideas of how I could do this?
1. You can use the web interface. And see variables.html page.
2. See MPC API.
Both methods work for MPC-BE and MPC-HC.
v0lt is offline   Reply With Quote
Old 9th June 2019, 11:19   #6323  |  Link
ZoNi
Registered User
 
ZoNi's Avatar
 
Join Date: Nov 2011
Location: Serbia
Posts: 28
Small wish list: customizable fonts size & type in GUI; add some basic video&audio info.

ZoNi is offline   Reply With Quote
Old 9th June 2019, 11:21   #6324  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,206
Quote:
Originally Posted by ZoNi View Post
Small wish list: customizable fonts size & type in GUI; add some basic video&audio info.

Not planned.
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 9th June 2019, 11:22   #6325  |  Link
ZoNi
Registered User
 
ZoNi's Avatar
 
Join Date: Nov 2011
Location: Serbia
Posts: 28


May I ask you why not? Is it technically complicated?
ZoNi is offline   Reply With Quote
Old 9th June 2019, 12:40   #6326  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,206
Quote:
Originally Posted by ZoNi View Post


May I ask you why not? Is it technically complicated?
Just not planned
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 9th June 2019, 12:46   #6327  |  Link
ZoNi
Registered User
 
ZoNi's Avatar
 
Join Date: Nov 2011
Location: Serbia
Posts: 28
Oh, OK

Well, if you can&want, maybe this suggestion can be added to your "plan list". I guess it can be usefull for many who watch films on Full HD / Ultra HD screens.
ZoNi is offline   Reply With Quote
Old 9th June 2019, 13:59   #6328  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 71
I imported a playlist from another player which uses utf-8 without bom and some entries are broken in mpc-be. Is this unsupported or a bug? (mpc-hc works fine.)

Last edited by mogli; 9th June 2019 at 15:52.
mogli is offline   Reply With Quote
Old 9th June 2019, 14:40   #6329  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: Germany
Posts: 5,635
Quote:
Originally Posted by v0lt View Post
1. You can use the web interface. And see variables.html page.
2. See MPC API.
Both methods work for MPC-BE and MPC-HC.
I always forget this, added it to the mpv.net wiki now.

https://github.com/stax76/mpv.net/wi...native-Players
stax76 is offline   Reply With Quote
Old 9th June 2019, 19:28   #6330  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,120
Quote:
Originally Posted by mogli View Post
I imported a playlist from another player which uses utf-8 without bom and some entries are broken in mpc-be. Is this unsupported or a bug? (mpc-hc works fine.)
What is the format of the playlist?
Sample playlist file?
v0lt is offline   Reply With Quote
Old 9th June 2019, 23:59   #6331  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,206
Quote:
Originally Posted by mogli View Post
I imported a playlist from another player which uses utf-8 without bom and some entries are broken in mpc-be. Is this unsupported or a bug? (mpc-hc works fine.)
Upload playlist.
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 10th June 2019, 08:20   #6332  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 71
Problem identified: some filenames include symbols with character codes around 128000.
I made 2 sample playlists illustrating the problem.
mogli is offline   Reply With Quote
Old 11th June 2019, 02:56   #6333  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,206
Quote:
Originally Posted by mogli View Post
Problem identified: some filenames include symbols with character codes around 128000.
I made 2 sample playlists illustrating the problem.
Thank you - opening of such playlists is fixed.
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 12th June 2019, 07:21   #6334  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 71
Thanks, opening such playlists works now. However opening them for the first time is very slow, the next time it's ok.

Also most youtube videos don't work for me anymore, hope it isn't related: The title and duration of the video is immediately found and shown in the playlist but it doesn't start and after a short time it says 'invalid' and 'file not found'. example youtube video
mogli is offline   Reply With Quote
Old 12th June 2019, 07:33   #6335  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,206
Google change page formats
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 13th June 2019, 01:26   #6336  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,171
I've never had any luck with 'Open ISO image' if I use this it just does nothing. If have to double click in Explorer with Virtual Clone Drive installed and Windows presents me with the option to play back the disc.
Any chance of having MPC-BE work out of the box with Blu-ray ISOs? Not sure if location is a problem but I have these on a shared network drive.
ryrynz is offline   Reply With Quote
Old 13th June 2019, 05:35   #6337  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,206
Quote:
Originally Posted by ryrynz View Post
I've never had any luck with 'Open ISO image' if I use this it just does nothing. If have to double click in Explorer with Virtual Clone Drive installed and Windows presents me with the option to play back the disc.
Any chance of having MPC-BE work out of the box with Blu-ray ISOs? Not sure if location is a problem but I have these on a shared network drive.
There is no any trouble with Opening ISO.
MPC-BE use - DTLite or Virtual Clone Drive or Win8+ virtual disk
First - look at DTLite
Second - look at Virtual Clone Drive
Third - Win8+ virtual disk.
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 13th June 2019, 06:15   #6338  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 5,723
so opening iso with MPC-be is a feature and not working by accident like in mpc-hc?

if that's the case it is not working correctly. it is just opening the iso as a file not as a disc as far as i can see which may or may not work.
huhn is offline   Reply With Quote
Old 13th June 2019, 06:32   #6339  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,120
ryrynz
MPC-BE mounts ISO images using Win8+ mount API, DAEMON Tools Lite v4 or Virtual CloneDrive v5.5.

As far as I know, MPC-HC is not able to open ISO images. If this happens, it is not opening an image, it is opening an ISO file as MPEG-TS. This is a stupid way to work with ISO files.

Last edited by v0lt; 13th June 2019 at 06:37.
v0lt is offline   Reply With Quote
Old 13th June 2019, 07:51   #6340  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,171
For whatever reason it's not working for me (1903), is it working for you?

Last edited by ryrynz; 13th June 2019 at 07:54.
ryrynz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.