Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th September 2018, 18:18   #27781  |  Link
Ch3vr0n
Registered User
 
Join Date: Jan 2009
Posts: 1,274
@jdobbs SPECIAL_3D_MUX no change in PowerDVD 17, pixellation still present BUT reduced IMO using FRIM_SW_DECODE=0 and FRIM_SW_ENCODE=0 (and thus using hardware encoding), commenting out both lines (and pulling dummy display hdmi display plug) and running a 2nd test

Last edited by Ch3vr0n; 27th September 2018 at 18:30.
Ch3vr0n is offline   Reply With Quote
Old 27th September 2018, 19:13   #27782  |  Link
spotswood
Registered User
 
Join Date: Mar 2009
Posts: 55
Windows 10 error

Quote:
Originally Posted by jdobbs View Post
The first error has nothing to do with BD Rebuilder, since it isn't using the installer.

Did you run the .BAT file as administrator? Also, make sure you are running it from within that folder.
Yes, ran as Administrator from the BDRB folder, sorry I didn't specify above, post updated...

Quote:
Originally Posted by Mark_Venture View Post
@spotswood its outlined in step 3.1 in the OP instructions...

But to be honest, when I right click on the bat file and select "run as admin", It seems to fail because it always seems to try and run from C:\windows\system32 instead of the BD Rebuilder folder so it fails (because the OCX isn't in the win\system32 folder).

So its probably better to open an Administrative CMD prompt (Start -> Windows System -> right click on CMD Prompt -> More -> Run As Administrator)... When it launches, while in the window change to the BD-Rebuilder directory, and run the batch file from there (that is where the BAT file and the OCX file reside).... OR edit the BAT file, specify the path to the OCX file... then save/run it.
Thanks for the tip, edited the .bat file, ran as administrator and success. All good now, thanks guys... ;^)

Last edited by spotswood; 27th September 2018 at 19:16.
spotswood is offline   Reply With Quote
Old 27th September 2018, 19:24   #27783  |  Link
ggtop
Registered User
 
Join Date: Mar 2003
Posts: 284
Hi jdobbs,
thank you for the new version. Just installed and it reports itself as v0.60.01 as per INI:
Code:
[Options]
VERSION=0.60.0.1
ggtop is offline   Reply With Quote
Old 27th September 2018, 22:22   #27784  |  Link
Ch3vr0n
Registered User
 
Join Date: Jan 2009
Posts: 1,274
Update, even with software encoding the glitching is still present @jdobbs. So it looks like it didn't work (at least not for me), think it can be safely removed again in the next build. Considering i was the only one even persisting in finding a possible cause for this and a possible solution. Thanks for trying anyway!
Ch3vr0n is offline   Reply With Quote
Old 28th September 2018, 00:32   #27785  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by Ch3vr0n View Post
@jdobbs just a heads-up, SPECIAL_3D_MUX isn't documented in changes.txt
Code:
- Added a new hidden option SPECIAL_3D_MUX.
  If set to 1 the TSMUXER parameters for
  "insertSEI" and "contSPS" are excluded
  from the video command line in the meta
  file.  Some have reported that this fixes
  pixelation that has been experienced.
This is from changes.txt
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 00:34   #27786  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by ggtop View Post
Hi jdobbs,
thank you for the new version. Just installed and it reports itself as v0.60.01 as per INI:
Code:
[Options]
VERSION=0.60.0.1
My mistake. I forgot to update the system version number for the compile, but the text labels (such as the form header and the help dialog) should be correct.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 00:39   #27787  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by spotswood View Post
Yes, ran as Administrator from the BDRB folder, sorry I didn't specify above, post updated...

Thanks for the tip, edited the .bat file, ran as administrator and success. All good now, thanks guys... ;^)
Good news. I'll file that one for future reports.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 00:40   #27788  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by Ch3vr0n View Post
Update, even with software encoding the glitching is still present @jdobbs. So it looks like it didn't work (at least not for me), think it can be safely removed again in the next build. Considering i was the only one even persisting in finding a possible cause for this and a possible solution. Thanks for trying anyway!
Thanks for the report. I'll remove that option in the next release. Too bad. It would have been good to kill it.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 04:28   #27789  |  Link
MrVideo
Registered User
 
MrVideo's Avatar
 
Join Date: May 2007
Location: Wisconsin
Posts: 1,548
Quote:
Originally Posted by Sharc View Post
Some TV stations in Europe broadcast HD as 720p50 rather than 1080i25. I remember the hot debates about what is better when HD TV was introduced.
Same here, where two OTA networks are 720p59.94 (ABC and FOX). Supposedly the reason was sports. But, that point is moot now, since all of the main cameras that cover sports are high-speed for great slo-mo. That means the slo-mo plays out as if it were 1080p.

IMHO, 720 is HD-lite. Especially now that 4K exists (not OTA, yet) and 8K is around the corner. I've always considered 720 to be inferior HD.
__________________
My Total Eclipse 2017 Photos
MrVideo is offline   Reply With Quote
Old 28th September 2018, 09:04   #27790  |  Link
musiclover
Registered User
 
Join Date: Jul 2005
Posts: 97
Quote:
Originally Posted by jdobbs View Post
Code:
- Added a new hidden option SPECIAL_3D_MUX.
  If set to 1 the TSMUXER parameters for
  "insertSEI" and "contSPS" are excluded
  from the video command line in the meta
  file.  Some have reported that this fixes
  pixelation that has been experienced.
This is from changes.txt
He probably means HIDDENOPTS.TXT
musiclover is offline   Reply With Quote
Old 28th September 2018, 12:33   #27791  |  Link
FreaQ
Starfish
 
FreaQ's Avatar
 
Join Date: Aug 2004
Posts: 97
Hi jdobbs,

did not see a reponse regarding my problem.
I updated to 0.60.2 and BD-RB still reencodes even though FORCE_NOENCODE=1 ist set.

Quote:
Originally Posted by FreaQ View Post
After a long time I tried to use BD-RB today again.
I just wanted to blank some annoying warnings and keep the rest as is.
Even though the option FORCE_NOENCODE=1 is set, BD-RB reencodes the video.
So I tried a dryrun with all extras, movie and warnings enabled. I also set the target size to 55000 MB. At first it was promising, the short warnings were not reencoded. But as soon as the movie kicked in BD-RB startet reencodeing. I aborted the process.
I am not sure if I am missing something. The BD has multiangle (3 angles).



Code:
----------------------
[09.25.18] BD Rebuilder v0.50.25
[14:39:38] Source:  
  - Input BD size: 40,89 GB
  - Approximate total content: [02:31:47.906]
  - Target BD size: 53,71 GB
  - Windows Version: 6.2 [9200]
  - Quality: High Quality (Default), Two Pass
  - Decoding/Frame serving: X264/LAVF
  - Audio Settings: AC3=0 DTS=0 HD=1 Kbs=640
[14:39:38] PHASE ONE, Encoding
 - [14:39:38] Processing: VID_00006 (1 of 99)
 - [14:39:38] Extracting A/V streams [VID_00006]
 - [14:39:42] Reencoding video [VID_00006]
 - [14:39:42] Keeping original video (no reencode)
 - [14:39:43] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
 - [14:39:43] Multiplexing M2TS
 - [14:39:46] Processing: VID_00100 (2 of 99)
 - [14:39:46] Extracting A/V streams [VID_00100]
 - [14:39:50] Reencoding video [VID_00100]
 - [14:39:50] Keeping original video (no reencode)
 - [14:39:50] Processing audio tracks
 - [14:39:50] Multiplexing M2TS
.
.
.
 - [14:50:26] Processing: VID_00339 (89 of 99)
 - [14:50:26] Extracting A/V streams [VID_00339]
 - [14:50:29] Reencoding video [VID_00339]
 - [14:50:29] Keeping original video (no reencode)
 - [14:50:29] Processing audio tracks
 - [14:50:29] Multiplexing M2TS
 - [14:50:33] Processing: VID_00340 (90 of 99)
 - [14:50:33] Extracting A/V streams [VID_00340]
 - [14:50:37] Reencoding video [VID_00340]
 - [14:50:37] Keeping original video (no reencode)
 - [14:50:37] Processing audio tracks
 - [14:50:37] Multiplexing M2TS
 - [14:50:40] Processing: VID_00341 (91 of 99)
 - [14:50:40] Extracting A/V streams [VID_00341]
 - [14:50:44] Reencoding video [VID_00341]
 - [14:50:44] Keeping original video (no reencode)
 - [14:50:44] Processing audio tracks
 - [14:50:44] Multiplexing M2TS
 - [14:50:48] Processing: VID_00810 (92 of 99)
 - [14:50:48] Extracting A/V streams [VID_00810]
 - [14:50:53] Reencoding video [VID_00810]
   - Source Video: MPEG-4 (AVC), 1920x1080
   - Rate/Length: 23,976fps, 2.214 frames
   - Bitrate: 28.750 Kbs
 - [14:50:53] Reencoding: VID_00810, Pass 1 of 2
 - [14:51:11] Reencoding: VID_00810, Pass 2 of 2
[14:51:16]PHASE ONE aborted by user request
Code:
[Options]
VERSION=0.50.0.24
MODE=0
ENCODE_QUALITY=2
ONEPASS_ENCODING=0
AUTO_QUALITY=0
SD_CONVERT=0
OPEN_GOP=0
RESIZE_1080=0
RESIZE_1440=0
RESIZE_720=0
DEINTERLACE=0
SD_TO_1080=0
CONVERT_WIDE=0
DTS_REENCODE=0
AC3_REENCODE=0
AC3_640=1
AC3_192=0
KEEP_HD_AUDIO=1
AVCHD=1
REMOVE_WORKFILES=1
MOVIE_ONLY_LOOP=0
REMOVE_OUTPUT=0
USE_FILTERS=0
BDMV_CERT_ONLY=1
USE_LAVF=0
IVTC_PULLDOWN=1
ASSUME_DVD_PAL=1
UNMASK_CHAPTER=1
COMPLETION_BEEP=0
DGDECNV=0
OUTPUT_3D=0
NEROAAC=0
SUPTITLE=0
AUDIO_TRACK_LIMIT=0
SUBTITLE_TRACK_LIMIT=0
CUSTOM_TARGET_SIZE=55000
ENABLE_TEST=1
ENABLE_BLANKING=1
DTSX_ENABLE=1
AUDIO_TO_KEEP=deu;eng;ger;
SUBS_TO_KEEP=deu;eng;ger;
MIN_M2TS_SIZE=1
BLANK_THRESHOLD=10
TARGET_SIZE=55000
FORCE_NOENCODE=1
ENCODER=0
IGNORE_3D=0
AUDIO_DRC=0
DECODER=2
FRIMSOURCE=0
OUTPUT_SBS=0
PGSTOSRT=0
FreaQ is offline   Reply With Quote
Old 28th September 2018, 15:15   #27792  |  Link
Ch3vr0n
Registered User
 
Join Date: Jan 2009
Posts: 1,274
@jdobbs is there a way to do full disc backup, and output to an ssif using structure? I'd test that otherwise

Verstuurd vanaf mijn Nexus 6P met Tapatalk
Ch3vr0n is offline   Reply With Quote
Old 28th September 2018, 16:41   #27793  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by musiclover View Post
He probably means HIDDENOPTS.TXT
I didn't add it because if it worked, it would be set and not have to be a hidden option. If it didn't work (as is the case), it will simply go away.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 16:42   #27794  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by Ch3vr0n View Post
@jdobbs is there a way to do full disc backup, and output to an ssif using structure? I'd test that otherwise

Verstuurd vanaf mijn Nexus 6P met Tapatalk
No. To get that structure you have to use TSMUXER to create the ISO, and it only does one file at a time.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 17:02   #27795  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by FreaQ View Post
Hi jdobbs,

did not see a reponse regarding my problem.
I updated to 0.60.2 and BD-RB still reencodes even though FORCE_NOENCODE=1 ist set.
Try turning off "IVTC...pulldown" in SETUP. There are several settings that can prevent noencode mode (in order obey the settings) -- that's the one that is the most common culprit.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th September 2018, 18:53   #27796  |  Link
Ch3vr0n
Registered User
 
Join Date: Jan 2009
Posts: 1,274
Quote:
Originally Posted by jdobbs View Post
No. To get that structure you have to use TSMUXER to create the ISO, and it only does one file at a time.
In that case, is it difficult for you to add? Maybe the glitching is due to the in-mux and ssif won't glitch. Maybe it's worth a try.

Sent from my Nexus 7 with Tapatalk
Ch3vr0n is offline   Reply With Quote
Old 28th September 2018, 19:27   #27797  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,265
Quote:
Originally Posted by Ch3vr0n View Post
In that case, is it difficult for you to add? Maybe the glitching is due to the in-mux and ssif won't glitch. Maybe it's worth a try.

Sent from my Nexus 7 with Tapatalk
More than difficult, virtually impossible without my having to write a piece of software that is equivalent to TSMUXER. Either way... in-mux is 100% within standard and is present on commercial discs -- so in that case the issue is with the player, not TSMUXER or BD-RB.

Have you tried doing a movie-only backup to an ISO to see if the problem still exists? My guess is it will have the same issue.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 28th September 2018 at 19:33.
jdobbs is offline   Reply With Quote
Old 28th September 2018, 19:33   #27798  |  Link
Ch3vr0n
Registered User
 
Join Date: Jan 2009
Posts: 1,274
No worries, just a question. I'll stick with my standard methods then. Process with bdrb, use a standalone I've hooked up to my PC's 3d monitor. Zero glitching, never has. I never doubted bdrb since 3d was first added.

Verstuurd vanaf mijn Nexus 6P met Tapatalk
Ch3vr0n is offline   Reply With Quote
Old 28th September 2018, 23:44   #27799  |  Link
Mark_Venture
Registered User
 
Join Date: Jan 2010
Posts: 180
UHD question...

So I just did Infinity Wars 4K alt movie only MKV... I forgot, until after it was done, to change it from 1920x1080 intact to another profile to keep it 4K.. there isn't one..

Can I just edit the MISC\Alternate.txt file to add one?

Also, since Infinity Wars 4K/UHD is HDR, the output loses HDR and the color is off...

BUT at least it completes and looks good otherwise
Mark_Venture is offline   Reply With Quote
Old 29th September 2018, 01:25   #27800  |  Link
AmigaFuture
Registered User
 
Join Date: Apr 2003
Location: Within the main Source.
Posts: 823
Role Madels update..

I checked further into this..

Code:
00000.track_4113.264
[...]
All the files from the Playlist are gathered, BD-RB makes a TEMP BD, and before the MKV file is made the that file is created with 0 bytes and the MKV creation fails. There are 41 chapter points for the extras, and a single AC-3 is made while several VC1 files are extracted for the process.

Code:
[09/28/18] BD Rebuilder v0.60.02
[16:39:24] Source:  ROLE_MODELS_[UNRATED]_ANYDVD_TAKE_2_00100
  - Input BD size: 5.84 GB
  - Approximate total content: [00:49:49.819]
  - Windows Version: 6.1 [7601]
  - MOVIE-ONLY/ALTERNATE OUTPUT mode enabled
  - Mode: MKV, Intact Video, Intact Audio
  - Quality: High Quality (Default)
  - Decoding/Frame serving: DirectShow
  - Audio Settings: AC3=0 DTS=0 HD=0 Kbs=640
[16:39:26] PHASE ONE, Encoding
 - [16:39:26] Processing: VID_00361 (1 of 81)
 - [16:39:26] Extracting A/V streams [VID_00361]
 - [16:39:33] Reencoding video [VID_00361]
 - [16:39:33] Keeping original video (no reencode)
 - [16:39:33] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
(Only 1 audio...)
[...]
 - [16:45:09] Extracting A/V streams [VID_00441]
 - [16:45:13] Reencoding video [VID_00441]
 - [16:45:13] Keeping original video (no reencode)
 - [16:45:13] Processing: VID_00442 (81 of 81)
 - [16:45:13] Extracting A/V streams [VID_00442]
 - [16:45:18] Reencoding video [VID_00442]
 - [16:45:18] Keeping original video (no reencode)
[16:45:18]PHASE ONE complete
[16:45:18]PHASE TWO - Rebuild Started
 - [16:45:18] Building ALTERNATE OUTPUT Structure
 - Failed in attempt to multiplex: MUX_MOVIE_ONLY.meta
 - Not enought buffer for parse video stream. Current frame num 0
[16:46:25] - Failed to REBUILD
Now what I thought to be a work-around.. Make BD of the particular extras..
Code:
[09/28/18] BD Rebuilder v0.60.02
[16:54:38] Source:  ROLE_MODELS_[UNRATED]_ANYDVD_TAKE_2_00100
  - Input BD size: 5.84 GB
  - Approximate total content: [00:49:49.819]
  - Target BD size: 46.26 GB
  - Windows Version: 6.1 [7601]
  - MOVIE-ONLY mode enabled
  - Auto Quality: Good (Very Fast), ABR
  - Decoding/Frame serving: DirectShow
  - Audio Settings: AC3=0 DTS=0 HD=0 Kbs=640
[16:54:40] PHASE ONE, Encoding
 - [16:54:41] Processing: VID_00361 (1 of 81)
 - [16:54:41] Extracting A/V streams [VID_00361]
 - [16:54:47] Reencoding video [VID_00361]
 - [16:54:47] Keeping original video (no reencode)
 - [16:54:47] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
 - [16:54:47] Processing: VID_00362 (2 of 81)
[...]
 - [17:00:28] Processing: VID_00442 (81 of 81)
 - [17:00:28] Extracting A/V streams [VID_00442]
 - [17:00:33] Reencoding video [VID_00442]
 - [17:00:33] Keeping original video (no reencode)
[17:00:33]PHASE ONE complete
[17:00:33]PHASE TWO - Rebuild Started
 - [17:00:33] Rebuilding BD file Structure
[17:01:33] - Encode and Rebuild complete
[17:01:33] JOB: ROLE_MODELS_[UNRATED]_ANYDVD_TAKE_2 finished.
Now making MKV from it..
Code:
[09/28/18] BD Rebuilder v0.60.02
[17:05:34] Source:  ROLE_MODELS_[UNRATED]_ANYDVD_TAKE_2_00000
  - Input BD size: 5.84 GB
  - Approximate total content: [00:49:49.820]
  - Windows Version: 6.1 [7601]
  - MOVIE-ONLY/ALTERNATE OUTPUT mode enabled
  - Mode: MKV, Intact Video, Intact Audio
  - Quality: High Quality (Default)
  - Decoding/Frame serving: DirectShow
  - Audio Settings: AC3=0 DTS=0 HD=0 Kbs=640
[17:05:36] PHASE ONE, Encoding
 - [17:05:36] Processing: VID_00000 (1 of 1)
 - [17:05:36] Extracting A/V streams [VID_00000]
 - [17:06:40] Reencoding video [VID_00000]
 - [17:06:40] Keeping original video (no reencode)
 - [17:06:40] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
[17:06:40]PHASE ONE complete
[17:06:40]PHASE TWO - Rebuild Started
 - [17:06:40] Building ALTERNATE OUTPUT Structure
[17:08:14] - Encode and Rebuild complete
[17:08:14] JOB: ROLE_MODELS_[UNRATED]_ANYDVD_TAKE_2 finished.
Extra 7 or 8 is where the sync is lost..for both BD and MKV.

I think it's the context of MUX_MOVIE_ONLY.meta you asked for?
Code:
MUXOPT --no-pcr-on-video-pid --new-audio-pes --demux --vbr --vbv-len=500 --start-time=27000000
V_MS/VFW/WVC1, "Q:\OUTPUT\WORKFILES\00000.track_4113.vc1", fps=23.976, contSPS
Do you have the movie? I'll help if not..
__________________
Life is not a journey to the grave; but rather to skid out broadside, thoroughly used, torn and warn and loudly proclaim; WOW; What a ride!!! Soon, I'm going to do it AGAiN in different skin!!
AmigaFuture is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:08.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.