Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Subtitles

Reply
 
Thread Tools Search this Thread Display Modes
Old 12th May 2017, 14:22   #161  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,666
XySubFilter is based on VSFilter, while AssFilterMod uses libass, which is an entirely different rendering library.
clsid is offline   Reply With Quote
Old 14th May 2017, 16:16   #162  |  Link
amayra
Quality Checker
 
amayra's Avatar
 
Join Date: Aug 2013
Posts: 166
Quote:
Originally Posted by ashlar42 View Post
May I ask why the decision of starting almost from scratch instead of working on improving XySubFilter? Was it not open sourced?
Simple curiosity, not criticism of any kind, as devs are clearly free to do whatever the hell they want with their own time.
1 XySubFilter is open source
2 AssFilterMod is a fork of AssFilter "ISubRenderProvider meets libass. Working prototype.
" by Alex Marsev
3 always check behind you before posing dude
__________________
I love Doom9
amayra is offline   Reply With Quote
Old 15th May 2017, 04:06   #163  |  Link
blaster00
Registered User
 
Join Date: Jun 2010
Posts: 29
with some sub from http://www.zimuzu.tv/fsubtitle http://subhd.com/sub0
for ass
1. AssFilterMod crashes mpc-hc with madvr or evr-cp many times.
2. It takes a lot of times before play real start.
3. Border And Shadow behaves very differently with AssFilterMod other then mpc internal and xysubfilter.
for srt
both AssFilterMod and sub file is loaded, but nothing is showed. Not quite much, but happened.
Sorry for my English, and no snapshot.

Also don't know how to switch sub tracks.

Last edited by blaster00; 15th May 2017 at 05:34.
blaster00 is offline   Reply With Quote
Old 27th May 2017, 16:47   #164  |  Link
ashlar42
Registered User
 
Join Date: Jun 2007
Posts: 266
Quote:
Originally Posted by amayra View Post
1 XySubFilter is open source
2 AssFilterMod is a fork of AssFilter "ISubRenderProvider meets libass. Working prototype.
" by Alex Marsev
3 always check behind you before posing dude
It's quite ironic that you spent the time to reply, suggesting me to "check behind" when you clearly did *not* answer my main question.

"May I ask why the decision of starting almost from scratch instead of working on improving XySubFilter?"

The fact that XySubFilter is open source only strenghtens my curiosity. Reading these nine pages it looks a lot like reinventing the wheel. *But* I'm not a developer, so I simply asked what was the reason for the decision taken by Blitzker. I *think* he might be the only one capable of providing an answer.

And I stress that it's his time, his project and he can do whatever the hell most pleases him. I'm just curious. Maybe I'll learn something in the process.

Cheers.
ashlar42 is offline   Reply With Quote
Old 27th May 2017, 17:13   #165  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,666
XySubFilter code is a giant complex mess which makes it unlikely to attract new developers.

AssFilterMod is open source as well. All the complex stuff is in an external library (libass) that he doesn't need to worry about. The AssFilterMod filter is just a wrapper for libass. So it is a relatively small amount of code to maintain.
clsid is offline   Reply With Quote
Old 10th June 2017, 23:10   #166  |  Link
Shinobu
Satsuki'S Softs Maker
 
Shinobu's Avatar
 
Join Date: Feb 2003
Posts: 180
Great job with this filter, got lots of ass fx witch just don't wokrs with vsfilter or xysubfilter.
Is there any way to autoswitch from your ass filter to vsfilter/xysubfilter for unsupported format (.sub,.pgs...)

Thanks a lot
Shinobu is offline   Reply With Quote
Old 7th August 2017, 06:45   #167  |  Link
lion09503
Registered User
 
Join Date: Jan 2009
Posts: 10
any news when this will be updated again?
lion09503 is offline   Reply With Quote
Old 27th August 2017, 15:01   #168  |  Link
amayra
Quality Checker
 
amayra's Avatar
 
Join Date: Aug 2013
Posts: 166
Quote:
Originally Posted by lion09503 View Post
any news when this will be updated again?
i did try to add support to pgs in my fork but no luck
__________________
I love Doom9
amayra is offline   Reply With Quote
Old 30th August 2017, 16:14   #169  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 4,100
did you try it with the vsfilter code or the ffmpeg code?
huhn is offline   Reply With Quote
Old 31st August 2017, 03:10   #170  |  Link
amayra
Quality Checker
 
amayra's Avatar
 
Join Date: Aug 2013
Posts: 166
Quote:
Originally Posted by huhn View Post
did you try it with the vsfilter code or the ffmpeg code?
i used MPC code and hoped to see some improvement with ISR code
__________________
I love Doom9
amayra is offline   Reply With Quote
Old 21st September 2017, 01:10   #171  |  Link
cyberscott
Registered User
 
Join Date: Oct 2007
Posts: 65
Incompatibility with Ryzen CPU?

I recently built a Windows 10 64 bit (all latest updates) PC with a Ryzen 1800x cpu and a Nvida 1080 GPU.

AssFilterMod with MPC CE 64 bit, LAV and Madvr, all latest builds. Render times jump all over the place, video stutters like crazy. Doesn't matter the resolution /upcale of the video or of the subtitles. I tried different native resolutions from 480p and 1080p and upscales to 4k, no difference.
Same thing happens with xysubfilters as well so maybe something common to the code? On my Intel based system, AssFilterMod plays perfectly fine and stable. Internal renderer on the new build is fine.

Can anyone with a Ryzen CPU try AssFilterMod to see if they have issues as well?
cyberscott is offline   Reply With Quote
Old 21st September 2017, 03:31   #172  |  Link
lion09503
Registered User
 
Join Date: Jan 2009
Posts: 10
Quote:
Originally Posted by cyberscott View Post
I recently built a Windows 10 64 bit (all latest updates) PC with a Ryzen 1800x cpu and a Nvida 1080 GPU.

AssFilterMod with MPC CE 64 bit, LAV and Madvr, all latest builds. Render times jump all over the place, video stutters like crazy. Doesn't matter the resolution /upcale of the video or of the subtitles. I tried different native resolutions from 480p and 1080p and upscales to 4k, no difference.
Same thing happens with xysubfilters as well so maybe something common to the code? On my Intel based system, AssFilterMod plays perfectly fine and stable. Internal renderer on the new build is fine.

Can anyone with a Ryzen CPU try AssFilterMod to see if they have issues as well?
I'm using a 1700 together with a gtx1060 running on a 4k display. I'm using lav filters,madvr and potplayer together with assfiltermod and I'm having no problems during playback.
lion09503 is offline   Reply With Quote
Old 21st September 2017, 08:58   #173  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 4,100
did you change the nvidia power setting to adaptive?
huhn is offline   Reply With Quote
Old 21st September 2017, 21:31   #174  |  Link
cyberscott
Registered User
 
Join Date: Oct 2007
Posts: 65
Quote:
Originally Posted by huhn View Post
did you change the nvidia power setting to adaptive?
Most definitely. I always keep it on adaptive and insure it is on adaptive after each video card driver install. Also tried "prefer maximum performance" for the heck of it with no change.
I've tried adjusting the render queues in Madvr to their highest to lowest settings with a few random settings in between but no luck.
Went as far as disabling cores in the Ryzen processor but no change.
Both AssFilterMod and xysubfilter exhibit the exact same behavior.
The internal subtitle renderer works fine.

I hope others with a Ryzen processors can chime in to determine if it is actually the processor / platform causing the weirdness.
cyberscott is offline   Reply With Quote
Old 21st September 2017, 22:30   #175  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 4,100
can you make a screen of the OSD in playback?
huhn is offline   Reply With Quote
Old 22nd September 2017, 00:27   #176  |  Link
cyberscott
Registered User
 
Join Date: Oct 2007
Posts: 65
Quote:
Originally Posted by huhn View Post
can you make a screen of the OSD in playback?
Here you go, though I don't know if it will help much. The render times jump all over the place when the subtitles are playing. I've seen it go over 2000!
I played the video at its' native resolution of 1080p but crazy jumping rendering times happen no matter the resolution or scaling setting if subtitles are being rendered. If no subtitles are being displayed, the video plays fine.
Absolutely no playback issues if the internal subtitle renderer is use.
I have no issue using the internal subtitle renderer but I want to see if the Ryzen platform is the problem and let the commuity/devs take a crack at solving this.

https://photos.google.com/photo/AF1Q...PP-FhACW_jcjpC
cyberscott is offline   Reply With Quote
Old 22nd September 2017, 02:02   #177  |  Link
amayra
Quality Checker
 
amayra's Avatar
 
Join Date: Aug 2013
Posts: 166
someone need to pick up this project
__________________
I love Doom9
amayra is offline   Reply With Quote
Old 22nd September 2017, 12:21   #178  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 4,100
your screen is 404.
huhn is offline   Reply With Quote
Old 22nd September 2017, 18:04   #179  |  Link
cyberscott
Registered User
 
Join Date: Oct 2007
Posts: 65
Quote:
Originally Posted by huhn View Post
your screen is 404.
Try this one.
https://drive.google.com/file/d/1YNw...w?usp=drivesdk
cyberscott is offline   Reply With Quote
Old 22nd September 2017, 19:03   #180  |  Link
cyberscott
Registered User
 
Join Date: Oct 2007
Posts: 65
Quote:
Originally Posted by lion09503 View Post
I'm using a 1700 together with a gtx1060 running on a 4k display. I'm using lav filters,madvr and potplayer together with assfiltermod and I'm having no problems during playback.
Thanks for that info. I haven't tried another player outside of MPC-BE yet. I'll probably give potplayer a try this weekend to see if anything changes.

Last edited by cyberscott; 22nd September 2017 at 23:57.
cyberscott is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.