Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Subtitles

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th December 2018, 05:38   #1041  |  Link
supercoolman
Registered User
 
Join Date: Feb 2008
Posts: 13
there are issue with XySubFilter 3.1.0.746 BETA3 where last line of an external SSA subtitle is not displayed if it doesn't end with line break. in a text editor, this means SSA file must end with a blank/empty line
haven't test the latest version to see if it's fixed, but also don't see this fixed in the newer releases' Bug Fix section



confirmed 3.1.0.752 also has the same behaviour

Last edited by supercoolman; 27th December 2018 at 08:36.
supercoolman is offline   Reply With Quote
Old 29th December 2018, 02:12   #1042  |  Link
Mano
Registered User
 
Join Date: Jul 2008
Posts: 48
Is it normal that when i enable sub in video the color of the movie changed?


Default no sub
https://imgur.com/oprrT9R

With english sub selected
https://imgur.com/SSo0l5f
Mano is offline   Reply With Quote
Old 29th December 2018, 23:54   #1043  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
@supercoolman Thanks for reporting that. Looks like it is caused by a bug this Read Buffering commit written by the Aegisub author. Since Aegisub always adds a new line at end of file this must have been overlooked. I'll try to see if he's still around to push a fix.

@Mano That is a bug in madVR, I believe. XySubFilter only provides subtitles, it never touches the video. I seem to remember someone reporting a bug like that with HDR video in one of the madVR threads months ago, but if it still isn't fixed you should probably open a bug report so it isn't forgotten about.

Last edited by cyberbeing; 30th December 2018 at 00:24.
cyberbeing is offline   Reply With Quote
Old 30th December 2018, 08:10   #1044  |  Link
pinterf
Registered User
 
Join Date: Jan 2014
Posts: 1,240
Quote:
Originally Posted by supercoolman View Post
there are issue with XySubFilter 3.1.0.746 BETA3 where last line of an external SSA subtitle is not displayed if it doesn't end with line break. in a text editor, this means SSA file must end with a blank/empty line
haven't test the latest version to see if it's fixed, but also don't see this fixed in the newer releases' Bug Fix section

confirmed 3.1.0.752 also has the same behaviour
I was reported a similar issue, see issue and fix here:
https://github.com/pinterf/xy-VSFilter/issues/1
https://github.com/pinterf/xy-VSFilt...2c7414fc5072f0
As I recall there had been other similar parts in the code but I could test and fix only this specific one.

@cyberbeing: if the project is still somewhat live again, I'd recommend this x64 fix as well:
https://github.com/pinterf/xy-VSFilt...2d32806f8c24cf
pinterf is offline   Reply With Quote
Old 31st December 2018, 20:15   #1045  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Thanks pinterf, I'll merge those in. Looks like you only fixed it for SRT, I assume the same change could be used for SSA/ASS?

Test Build [previous 750 test build + pinterf SRT & x64 fixes + pinterf fix used for SSA/ASS (untested)]

Any idea if your fix for the missing last line could be moved from STS.cpp to TextFile.cpp, since that is where the regression occurred? It would prevent the need to add that fix for every text subtitle format in STS.cpp, and simply things.

The project is still pretty much dead, aside from minimal maintenance on my part.

Last edited by cyberbeing; 31st December 2018 at 23:47.
cyberbeing is offline   Reply With Quote
Old 1st January 2019, 21:33   #1046  |  Link
supercoolman
Registered User
 
Join Date: Feb 2008
Posts: 13
I have been manually fixing that (adding newlines) on all ASS subs over the years. just decided to bring it up. didn't know bug was filed on that already

btw/ot, what's going on with aegisub? is it in not, less or similarly active than XySubFilter ?
supercoolman is offline   Reply With Quote
Old 2nd January 2019, 01:10   #1047  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Pretty much, though back in June 2018 he did push out a new trunk build on his site with some fixes from his Github. With the original MPC-HC team dying off, and even Libass updating rather rarely nowadays, everything has sort of stagnated. Or rather the state of subtitle development has returned to the status quo from before we first released xy-VSFilter in 2011 which triggered a large peak in interest in the following years, so you could argue this is actually the normal state of things.
cyberbeing is offline   Reply With Quote
Old 2nd January 2019, 12:55   #1048  |  Link
pinterf
Registered User
 
Join Date: Jan 2014
Posts: 1,240
Quote:
Originally Posted by cyberbeing View Post

Any idea if your fix for the missing last line could be moved from STS.cpp to TextFile.cpp, since that is where the regression occurred? It would prevent the need to add that fix for every text subtitle format in STS.cpp, and simply things.

The project is still pretty much dead, aside from minimal maintenance on my part.
I don't remember, unfortunately I don't have overview on the project as a whole, tried to find a more practical place for it but due to my ignorance the actual fix remained where I put it first.
pinterf is offline   Reply With Quote
Old 2nd January 2019, 17:51   #1049  |  Link
supercoolman
Registered User
 
Join Date: Feb 2008
Posts: 13
finishing OT...

I was wondering since this GitHub project has been getting commits, but not a single release since 2014
supercoolman is offline   Reply With Quote
Old 4th January 2019, 23:18   #1050  |  Link
krmit
Registered User
 
Join Date: Jul 2013
Posts: 4
Quote:
Originally Posted by supercoolman View Post
finishing OT...

I was wondering since this GitHub project has been getting commits, but not a single release since 2014
Well, last release (r8942) was 06/09/18, and previous - about 2 years ago.
krmit is offline   Reply With Quote
Old 28th February 2019, 15:07   #1051  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,983
Any reason why the vertical padding option is disabled/broken?

It seems to work fine if I re-enable the relevant settings in IDirectVobSubXy.h
Of course it can b0rk accurate ASS positioning, but that is the users choice.
clsid is offline   Reply With Quote
Old 16th June 2019, 08:09   #1052  |  Link
TheRancher
Registered User
 
Join Date: Oct 2010
Posts: 42
It seems the "Override placement" checkbox isn't working. I tried it with a SRT subtitle in both madVR and EVR (MPC-HC & PotPlayer). Can you fix it?

madVR is placing subtitles too far to the bottom. EVR has no such problems, but I can't get MPC-HC to use both XySubFilter and ISR under it, which isn't the case when using DirectVobSub (I need both of them in order to properly set up opaque boxes around subtitles). I'm also not sure how to configure PotPlayer to use external filters outside of madVR. Can you guys help?

Also, take a look at this. It's what I'm trying to do, but still no success.
TheRancher is offline   Reply With Quote
Old 16th June 2019, 19:56   #1053  |  Link
supercoolman
Registered User
 
Join Date: Feb 2008
Posts: 13
found another weird behaviour. when there are 2 external ASS subs do the following steps and XySubFilter will switch sub on its own

1. pause playback
2. make change or edit XySubFilter's current rendering subtitle
3. resume playback
4. XySubFilter automatically switch to the other subtitle
5. manually selecting the edited subtitle and XySubFilter happily use it without any error/issue

this means there was no error, mistake or issue for the edited subtitle. not sure why XySubFilter would switch the rendering subtitle
supercoolman is offline   Reply With Quote
Old 23rd June 2019, 09:18   #1054  |  Link
zvans18
Registered User
 
zvans18's Avatar
 
Join Date: Jun 2015
Posts: 22
Is lag at typesetting just par for the course or is my XySubFilter misconfigured? It even happens with the basic stuff Crunchyroll, and therefore Horriblesubs, has been doing lately.

MPC-BE 1.5.3 x64 + madvr + LAV filters + XySubFilter
__________________
Windows 10 // i7-8700k + GTX 1080 SLI // MPC-BE x64 + LAV + XySubFilter
zvans18 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.