Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th March 2021, 21:15   #21  |  Link
LowDead
Elit Amans
 
Join Date: Feb 2005
Location: Sweden
Posts: 265
Quote:
Originally Posted by kpic View Post
LD; Not sure what part you are on - were you able to get the title to play at all with the inserted subtitles? Or maybe it sounds like you are trying to get them to auto default 'on'?

For my title it had already a subtitle track so I basically just had to replace the Japanese sub track with English track, so testing after that was easy - I didn't have to tell it to add a brand new track. But I'm thinking once you edit in BDedit you should be able to instruct the title to use the enclosed sub track.
Yes, all steps finished and it played without problem, didn't even have problem with the disc not showing correct language either. Also I added subtitle and didn't replace. I wanted to get it to display automagically.. Also to first display menu would be a bonus..

Will post the revised steps soon..

//LD
__________________
Windows 10 Pro 64-bit, Intel i7-8700K@3.70GHz, 32GB, Intel UHD Graphics 630 128MB, NVIDIA RTX 2070 8GB, PIONEER BDR-S09XLT, ASUS BW-16D1HT, LG CX 65", Samsung UBD-K8500, Sony PS3
LowDead is offline   Reply With Quote
Old 6th April 2021, 22:12   #22  |  Link
kpic
Registered User
 
Join Date: Oct 2001
Posts: 70
Found a limitation;

So my 4k test title is fine, I even put it on a BD-DL disc and tested on my Oppo 203 and it read it fine with the added-in sub tracks no issue.

Currently it has a 4.0 & 2.0 DTS track I wanted to add my DTS-HD 7.1 audio track to it. So I did it all over again this time muxing in that 7.1 audio track, ran through BDRB and it played fine on my software player. So fire up BDedit to 'add' in the audio track the same way I did the sub track; this time I went to the 'AU' entry under 'Playlist' tab and added in my audio track using the '+' button and changed the language to 'JPN', I also had to adjust the stream number (1102) to match what was in the clipinf tab, select 'save' and done.

So sent this revised version to my software player and it did indeed read the extra audio track but it showed up as 'DTS'HD 5.1' instead of '7.1' - This is not a limitation of my software players it does recognize '7.1' tracks - In BDEdit I had selected the 'DTS-HD XLL' entry so I assume it is correct for that? Well anyway it is the 7.1 track that is in the stream but it indicates '5.1'. I'm not sure if I made a wrong selection in there somewhere as there were other options such as 'DTS', 'DD' and a few others so maybe I picked the wrong one, or maybe this is a limitation of BDedit?

I found out something else while I was trying all this; if you are in the 'Playlist' tab and finish making the changes and select the 'apply to clpi' button it does change the entries under the 'clipinf' tab but it also broke whatever BDRB fixed, I assume this is because BDedit wrote over my 'fixed' clipinfo file from BDRB, I don't recall if I did that for the subtitle entries or not so whatever you do do not select the 'apply to clpi' button you see under that tab as I'm pretty sure you'll be running it through BDRB again for a fixed version.
kpic is offline   Reply With Quote
Old 7th April 2021, 21:37   #23  |  Link
LowDead
Elit Amans
 
Join Date: Feb 2005
Location: Sweden
Posts: 265
I see you posted over at the BD-RB thread and got a reply that solved the problem.. I just finished watching my test disc and it was flawless.. I will post a new revised "guide" soon and it doesn't require BDedit at all, unless you want to make streams default or make the main menu appear first.. right now I got a major headache and I don't want to accidentally put any false instructions in the guide..

//LD
__________________
Windows 10 Pro 64-bit, Intel i7-8700K@3.70GHz, 32GB, Intel UHD Graphics 630 128MB, NVIDIA RTX 2070 8GB, PIONEER BDR-S09XLT, ASUS BW-16D1HT, LG CX 65", Samsung UBD-K8500, Sony PS3
LowDead is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.