Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th November 2009, 02:32   #41  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
Flash is a broken piece of crap. This is somehow news?
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 02:33   #42  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
CpT your site doesn't seem to work with firefox 3.7a1 ? i see only a white screen with no video playing strange

The Problems don't occur with the 50 second here but already start @ the 6 second and appear some frame then some frame are clear and then you see them (black blocks) again totally unwatchable Mobile this way

PS: I hope TI is gonna fix this weightp problem in their current CX64+ DSP Decoder fast, and i wonder if current Tegra has also issues with it (Zune HD, Samsung YP-M1)
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004

Last edited by CruNcher; 14th November 2009 at 02:48.
CruNcher is offline   Reply With Quote
Old 14th November 2009, 02:41   #43  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
Quote:
Originally Posted by Dark Shikari View Post
Flash is a broken piece of crap. This is somehow news?
/signed! Its a royal pain that's for sure.

@Cruncher
Sound like that version of ff is borked. I don't test with/for pre-release or beta versions of anything. By the time it comes out the whole thing will have been rewritten 100 times over. And tbh I don't give a crap about Mobile viewing.

Sorry for getting OT.

Last edited by CpT; 14th November 2009 at 19:36.
CpT is offline   Reply With Quote
Old 14th November 2009, 09:32   #44  |  Link
Astrophizz
Registered User
 
Join Date: Jul 2008
Posts: 184
Quote:
Originally Posted by Dark Shikari View Post
Flash is a broken piece of crap. This is somehow news?
You said it works perfectly with flash and now you say the fact that it doesn't work isn't news? So you changed your stance?
Astrophizz is offline   Reply With Quote
Old 14th November 2009, 09:41   #45  |  Link
jmartinr
Registered User
 
jmartinr's Avatar
 
Join Date: Dec 2007
Location: Enschede, NL
Posts: 296
@CpT
This one: http://vizmu.com/movie-trailers/812/129863/ shows corruption too at 1:10.
__________________
Roelofs Coaching
jmartinr is offline   Reply With Quote
Old 14th November 2009, 10:06   #46  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
@jmartinr
Yea I'm sure there's quite a few. I ran a bunch of tests but checked emm all in vlc. -apparently was a mistake on my part.

I'm re-encoding that one as I type this. When I get a chance I'll search for more. Thanks for finding it.

Last edited by CpT; 14th November 2009 at 19:17.
CpT is offline   Reply With Quote
Old 14th November 2009, 10:21   #47  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
Quote:
Originally Posted by Astrophizz View Post
You said it works perfectly with flash and now you say the fact that it doesn't work isn't news? So you changed your stance?
"Changed my stance"? What, is this a political issue or something?

I saw evidence that it was broken and concluded that it was broken. What else is there to it?
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 11:18   #48  |  Link
Astrophizz
Registered User
 
Join Date: Jul 2008
Posts: 184
I worded that wrong, sorry. I just thought it was odd that your first time you said that flash had problems with weightp you said it as though it wasn't anything new.
Astrophizz is offline   Reply With Quote
Old 14th November 2009, 11:32   #49  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
Quote:
Originally Posted by Astrophizz View Post
I worded that wrong, sorry. I just thought it was odd that your first time you said that flash had problems with weightp you said it as though it wasn't anything new.
Flash having problems period isn't anything new
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 11:33   #50  |  Link
Astrophizz
Registered User
 
Join Date: Jul 2008
Posts: 184
True
Astrophizz is offline   Reply With Quote
Old 14th November 2009, 13:00   #51  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
But it's not only flash Mainconcepts Decoder that is affected here. ON which Hardware STB solutions did you evaluated it, is there a list of Chips that are working ?
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004
CruNcher is offline   Reply With Quote
Old 14th November 2009, 13:01   #52  |  Link
plonk420
amd & h.264 fanboy
 
plonk420's Avatar
 
Join Date: Jun 2002
Location: NTSC
Posts: 419
just wanted to report --weightp 2 works on PS3 (like 10 refs)
plonk420 is offline   Reply With Quote
Old 14th November 2009, 13:02   #53  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
Quote:
Originally Posted by CruNcher View Post
But it's not only flash Mainconcepts Decoder that is affected here. ON which Hardware STB solutions did you evaluated it, is there a list of Chips that are working ?
How about a list of chips that are not working?

The likelihood of a hardware decoder failing to abide by the specification is rather low given the relative thoroughness that ASIC developers give to following the specification.
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 13:05   #54  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
Ok so in case of TIs Omap 3440 Decoder currently used on their DSP it's a Software Implementation bug, i wonder if it's also failing on the new Motorala Droid i guess it uses the same Decoder Core from TI or one of TI's partner my guess somehow is the Decoder is Inginients one
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004
CruNcher is offline   Reply With Quote
Old 14th November 2009, 20:22   #55  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
Quote:
Originally Posted by CruNcher View Post
Ok so in case of TIs Omap 3440 Decoder currently used on their DSP it's a Software Implementation bug
IIRC the iPhone 3GS uses the OMAP and it decodes things just fine.
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 21:37   #56  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
Nope it uses Samsung S5PC100 Chip (though also Cortex A8 based) and their Decoder Research as seen here http://www.youtube.com/watch?v=tSrsGPgIsEQ and here http://www.youtube.com/watch?v=zEWrV8LuX04

Hopefully we gonna see CoreCodecs own implementation running on the A8 or even better on the A8 + on the CX64+ beagleboard way
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004

Last edited by CruNcher; 14th November 2009 at 21:42.
CruNcher is offline   Reply With Quote
Old 15th November 2009, 21:52   #57  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
It turns out that at least one of the problematic streams (not the "2012" trailer though) contained invalid offsets due to at least one, if not two, bugs in weightp's analysis. This means that most of the problematic decoders probably work just fine.

A fix will be incoming as soon as I can get a hold of Dylan.
Dark Shikari is offline   Reply With Quote
Old 15th November 2009, 21:58   #58  |  Link
Chengbin
Registered User
 
Join Date: Oct 2007
Posts: 1,059
Quote:
Originally Posted by Dark Shikari View Post
This means that most of the problematic decoders probably work just fine.

A fix will be incoming as soon as I can get a hold of Dylan.
So after this fix the problematic decoders, like CoreAVC 1.9.5 and Archos PMPs, can play streams with weightp 2 without problems?
Chengbin is offline   Reply With Quote
Old 15th November 2009, 22:00   #59  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,688
Quote:
Originally Posted by Chengbin View Post
So after this fix the problematic decoders, like CoreAVC 1.9.5 and Archos PMPs, can play streams with weightp 2 without problems?
Not all, just some. Flash and CoreAVC 1.9.5 are still broken.
Dark Shikari is offline   Reply With Quote
Old 15th November 2009, 22:03   #60  |  Link
poisondeathray
Registered User
 
Join Date: Sep 2007
Posts: 4,233
Has Adobe been notified RE: flash and recent x264 changes?

Lots of websites use x264 e.g. vimeo, youtube etc... , maybe not the most recent builds, but it could cause issues soon...
poisondeathray is offline   Reply With Quote
Reply

Tags
artifacts, coreavc, corruption, weightp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.