Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Subtitles

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th January 2021, 21:14   #1321  |  Link
ismail0100
Registered User
 
Join Date: Dec 2015
Posts: 37
I bother you sorry, but language master file change and after I change translate. Here is the latest Turkish language version. You write "remove redundant language tags" so I use latest source and translated file.

https://www.mediafire.com/file/o9pc4...2021).xml/file

And three little problem for your XmlContentTranslator.
First for now, open lanuage master file not working.
Second on the first picture you see version info need update.
And latest, second picture you see, may the problem text include ctrl+v, just guess.

I am using CareUEyes so may picture be a little warm.


Last edited by ismail0100; 13th January 2021 at 21:16.
ismail0100 is offline   Reply With Quote
Old 14th January 2021, 11:28   #1322  |  Link
von Suppé
Registered User
 
von Suppé's Avatar
 
Join Date: Dec 2013
Posts: 296
Hi Nikse,

I noticed your posts @ https://forum.videohelp.com/threads/...with-HDR-video
In the new SUP edit function there is the possibility to save the result as BDN xml/png. Considering what has been discussed in the formentioned thread, would it be a good idea - if possible - to implement the opposite possibility too?
I mean in the same way that it works with SUP now, add something like File --> Import (non-OCR) --> "BDN xml/png subtitle file for edit" ? And after the edits, being able to save as SUP?

I think it's really weird that BDSup2Sub's SUP --> xml/png conversion is not lossless and that a filter comes into play when not resizing, but purely extracting SUP images to lossless xml/png as-is. And vice-versa, for that matter.

BTW the brightness tool works nicely. Thanks!
von Suppé is offline   Reply With Quote
Old 15th January 2021, 17:05   #1323  |  Link
Nikse555
Registered User
 
Join Date: Feb 2004
Location: Mars
Posts: 359
@ismail0100: Thx for the updated translation
EDIT: Xml Content Translator updated a little...

@von Suppé: In latest beta the sup edit can now also open BdnXml files: https://github.com/SubtitleEdit/subt...leEditBeta.zip
(also added "Adjust alpha").

Last edited by Nikse555; 15th January 2021 at 20:16.
Nikse555 is offline   Reply With Quote
Old 15th January 2021, 20:43   #1324  |  Link
von Suppé
Registered User
 
von Suppé's Avatar
 
Join Date: Dec 2013
Posts: 296
Great! Gonna check it out

[EDIT] During my first quick and dirty testing the PNG/XML import --> save as SUP, it seems to be working okay.

I did notice something. After importing a xml file with a framerate of 23.976, the "Frame rate" window in the editor screen says 25. This is only the case with SE-created xml files.
For framerate, there's a - small - difference in SE's exported xml script, compared to other ones.

SE uses <FrameRate="23976">

Other xml use <FrameRate="23.976">

After adding the "dot" in your xml-script, framerate is showed properly. But I have a question about that properly shown framerate.
When I save that xml (so, with the framerate properly shown 23.976) as SUP again, can you confirm that this framerate is honoured in the exported SUP?
I ask this because when I open this SUP in another tool, it shows framerate 25 again, instead of 23.976.

Another - minor - thing, concerning SE's xml export: it would be nice to be able to set "language".

Thanks Nikse. This already great non-OCR editing tool has a worthy addition with the XML to SUP conversion.

Thereby, it is more than a relieve to see that during the export from XML to SUP, SE honours the transparent rectangular background of the image and leaves that intact in the resulting SUP. This will keep sequential subtitles "seemed to be written on the same line".
It can be very uneasy to the eye when subtitles are "bobbing" up and down, especially when there is little or no time between them.
This unwanted behaviour is often overlooked and not dealt with properly by other subtitle tools.

Keep up the good work, Nikse!
Will continue testing.

Cheers

Last edited by von Suppé; 16th January 2021 at 10:16.
von Suppé is offline   Reply With Quote
Old 16th January 2021, 21:57   #1325  |  Link
deusexe
Registered User
 
Join Date: Dec 2020
Posts: 6
Quote:
Originally Posted by Janusz View Post
For what you want to achieve use now "Edit/Multiple replace ...".
For this you would need the wildcards option. Maybe in the next versions. Or it would be easier to restore what was "remove ellipses at the beginning of the line" ...
deusexe is offline   Reply With Quote
Old 16th January 2021, 22:43   #1326  |  Link
Nikse555
Registered User
 
Join Date: Feb 2004
Location: Mars
Posts: 359
@von Suppé: thx, frame rate stuff hopefully fixed here: https://github.com/SubtitleEdit/subt...leEditBeta.zip

@deusexe: I think if you set "Continuation style" to "none", then "Remove leading '...'" will be shown in "Fix common errors".
Nikse555 is offline   Reply With Quote
Old 17th January 2021, 00:12   #1327  |  Link
Atlantis
Registered User
 
Join Date: Feb 2002
Posts: 476
I have come to situations where there are - for one person talking like this.

-This is a sub-title
example on 2 lines.

So removing - at the beginning of subtitles is necessary. It should not remove - in the middle of the sentence. It should not delete - if there are 2 at the beginning of 2 lines like this:

-How are you?
-I'm good.

Currently I do it by replace which is a pain. Anyway to automate this?
Atlantis is offline   Reply With Quote
Old 17th January 2021, 11:17   #1328  |  Link
Nikse555
Registered User
 
Join Date: Feb 2004
Location: Mars
Posts: 359
Quote:
Originally Posted by Atlantis View Post
I have come to situations where there are - for one person talking like this.

-This is a sub-title
example on 2 lines.

So removing - at the beginning of subtitles is necessary. It should not remove - in the middle of the sentence. It should not delete - if there are 2 at the beginning of 2 lines like this:

-How are you?
-I'm good.

Currently I do it by replace which is a pain. Anyway to automate this?
Try "Fix common errors" with "Remove dialog dashes in single lines" checked.
Nikse555 is offline   Reply With Quote
Old 17th January 2021, 22:32   #1329  |  Link
deusexe
Registered User
 
Join Date: Dec 2020
Posts: 6
Quote:
Originally Posted by Nikse555 View Post
I think if you set "Continuation style" to "none", then "Remove leading '...'" will be shown in "Fix common errors".

Either I don't know which option you are talking about and I am doing something wrong, or it is impossible to restore "remove the ellipsis from the beginning of the sentence" in "Fix common errors"
deusexe is offline   Reply With Quote
Old 17th January 2021, 23:19   #1330  |  Link
Atlantis
Registered User
 
Join Date: Feb 2002
Posts: 476
Thank you. Man I wish I knew that much earlier! I think I have spent hours removing -
and I did read the entries in Fix common errors
Atlantis is offline   Reply With Quote
Old Yesterday, 07:00   #1331  |  Link
von Suppé
Registered User
 
von Suppé's Avatar
 
Join Date: Dec 2013
Posts: 296
Quote:
Originally Posted by Nikse555 View Post
frame rate stuff hopefully fixed here: https://github.com/SubtitleEdit/subt...leEditBeta.zip
Yep, it works properly. Thanks for the fix

Quote:
Originally Posted by Atlantis View Post
Man I wish I knew that much earlier! I think I have spent hours removing...

Quote:
Originally Posted by Nikse555 View Post
I think if you set "Continuation style" to "none", then "Remove leading '...'" will be shown in "Fix common errors".
Damn, I wish I knew thís earlier. I spent hours of removing leading...
von Suppé is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.