Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VapourSynth

Reply
 
Thread Tools Search this Thread Display Modes
Old 23rd December 2018, 06:56   #41  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
The following plugins were updated:
DFTTest
FFT3DFilter
MVTools
NNEDI3
TDeintMod
l33tmeatwad is offline   Reply With Quote
Old 8th July 2019, 16:18   #42  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
VapourSynth R46 installer is now up, only updates are VapourSynth (R46) and Zimg (2.9.1).
l33tmeatwad is offline   Reply With Quote
Old 10th August 2019, 04:24   #43  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
VapourSynth R47 installer is now up, only updates are VapourSynth (R47.1) and Zimg (2.9.2).
l33tmeatwad is offline   Reply With Quote
Old 18th August 2019, 18:43   #44  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
VapourSynth R47.2 installer is now up, only update was VapourSynth (R47.2).
l33tmeatwad is offline   Reply With Quote
Old 2nd November 2019, 01:37   #45  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
VapourSynth R48 installer is now up, only update was VapourSynth (R48).
l33tmeatwad is offline   Reply With Quote
Old 27th November 2019, 17:09   #46  |  Link
karesch
Registered User
 
karesch's Avatar
 
Join Date: Apr 2011
Location: Hungary
Posts: 6
Installing on Catalina

Hi Folks,

I'm an experienced AviSynth user and now I've tried to install VapourSynth on Catalina using brew. Used the method recommended by l33tmeatwad (creating autoload folders, Gatekeeper disabled). Installed ffms2 using brew, as brew recommended during VapourSynth install. Installed a few plugins in the autoload folder.

But, when I try to start the most basic scripts in VapourSynth Editor:
Code:
from vapoursynth import core
video = core.ffms2.Source(source='/Users/karesch/Movies/gabor.vob')
video = core.std.Transpose(video)
video.set_output()
nothing happens, the log window shows:
Code:
Traceback (most recent call last):
File "src/cython/vapoursynth.pyx", line 1946, in vapoursynth.vpy_evaluateScript
File "src/cython/vapoursynth.pyx", line 1947, in vapoursynth.vpy_evaluateScript
File "", line 2, in 
File "src/cython/vapoursynth.pyx", line 1679, in vapoursynth._CoreProxy.__getattr__
File "src/cython/vapoursynth.pyx", line 1539, in vapoursynth.Core.__getattr__
AttributeError: No attribute with the name ffms2 exists. Did you mistype a plugin namespace?
I thought that somehow the vapoursynth PluginDirs are not set correctly, but they seem to be fine, and the
Code:
/usr/local/lib/vapoursynth
includes:
Code:
ffmsindex			libfft3dfilter.dylib
finesharp.py			libfftw3f.3.dylib
havsfunc.py			libfftw3f_threads.3.dylib
libavcodec.58.dylib		libmiscfilters.dylib
libavformat.58.dylib		libmorpho.dylib
libavresample.4.dylib		libmvtools.dylib
libavutil.56.dylib		libnnedi3.dylib
libd2vsource.dylib		libremovegrain.dylib
libdeblock.dylib		libswscale.5.dylib
libdepan.dylib			libvinverse.dylib
libeedi3.dylib			libvivtc.dylib
libffms2.4.dylib		nnedi3_weights.bin
libffms2.dylib
Does anybody know, what am I doing wrong? Are there further links to be set up?

Thanks a lot for help.

update:
found a solution, now it works


Apparently The issue was that a few dylib files were not set executable by brew.

Last edited by karesch; 27th November 2019 at 18:13.
karesch is offline   Reply With Quote
Old 2nd December 2019, 16:11   #47  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
Glad you found a solution. Side note, I should probably fix my instructions, because you don't need to disable gatekeeper unless you are using the package installer (not brew).
l33tmeatwad is offline   Reply With Quote
Old 30th December 2019, 06:32   #48  |  Link
Frank Booth
Registered User
 
Join Date: Aug 2019
Posts: 3
Newbie Needing Help With Deinterlacing on Mac

Hello,

I've come to this forum because I need to deinterlace some SD video, and upscale it to HD. As I'm sure you know the built in deinterlacers in video editors produce quite severe jaggies, and I'm looking for a better result. However I am not a programmer, and I feel overwhelmed by the in this new environment. What I'm writing to ask if there's anyone who would be willing to do some hand holding, to help me install the software and run a script to get a high quality deinterlace. I am running macOS 10.13

Thank you in advance. Apologies if I have posted in the wrong place, I'm new to the forums and wasn't sure where else to post.
Frank Booth is offline   Reply With Quote
Old 2nd January 2020, 20:53   #49  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
Quote:
Originally Posted by Frank Booth View Post
Hello,

I've come to this forum because I need to deinterlace some SD video, and upscale it to HD. As I'm sure you know the built in deinterlacers in video editors produce quite severe jaggies, and I'm looking for a better result. However I am not a programmer, and I feel overwhelmed by the in this new environment. What I'm writing to ask if there's anyone who would be willing to do some hand holding, to help me install the software and run a script to get a high quality deinterlace. I am running macOS 10.13

Thank you in advance. Apologies if I have posted in the wrong place, I'm new to the forums and wasn't sure where else to post.
If all of this is a little overwhelming I would recommend my VapourSynth 101 guide which goes step by step to walk you through how everything works and how to use filters. As for installing, the VapourSynth installer linked on the first post of this thread may be a good start, however if you do not want to deal with downloading plugins then AMVpack may be a good option as well. AMVpack was a project I started years ago that helps (AMV) video editors get started quickly and easily with advanced tools so they don't have to deal with the complications of setting everything up or compiling things.
l33tmeatwad is offline   Reply With Quote
Old 21st January 2020, 04:04   #50  |  Link
Frank Booth
Registered User
 
Join Date: Aug 2019
Posts: 3
Newbie Needing Help With Deinterlacing on Mac

Thank you meatwad! I appreciate the help! I'll follow the guide and report back here on my progress
Frank Booth is offline   Reply With Quote
Old 29th January 2020, 11:24   #51  |  Link
Frank Booth
Registered User
 
Join Date: Aug 2019
Posts: 3
Newbie Needing Help With Deinterlacing on Mac

Quote:
Originally Posted by l33tmeatwad View Post
If all of this is a little overwhelming I would recommend my VapourSynth 101 guide which goes step by step to walk you through how everything works and how to use filters. As for installing, the VapourSynth installer linked on the first post of this thread may be a good start, however if you do not want to deal with downloading plugins then AMVpack may be a good option as well. AMVpack was a project I started years ago that helps (AMV) video editors get started quickly and easily with advanced tools so they don't have to deal with the complications of setting everything up or compiling things.
I have followed your instructions and have VS working up to a point. I don't really know what I'm doing but I have the following script working because the preview works.

import vapoursynth as vs
core = vs.get_core()
video = core.ffms2.Source(r'/Volumes/music/forencoding/gabrielle.mov')
video.set_output()



When I attempt the following script (which I have simply copied from your thread)..

import vapoursynth as vs
core = vs.get_core()
import havsfunc as haf

clip = core.ffms2.Source(source="/Volumes/music/forencoding/gabrielle.mov")
clip = core.resize.Bicubic(clip=clip,format=vs.YUV422P8)
deint = haf.QTGMC(clip, Preset='Fast', TFF=True)
deint.set_output()

I get the following error:

Failed to evaluate the script:
Python exception: Resize error: Matrix must be specified when converting to YUV or GRAY from RGB

Traceback (most recent call last):
File "src/cython/vapoursynth.pyx", line 1847, in vapoursynth.vpy_evaluateScript
File "/Users/macbook/Desktop/first script.vpy", line 16, in
File "src/cython/vapoursynth.pyx", line 1739, in vapoursynth.Function.__call__
vapoursynth.Error: Resize error: Matrix must be specified when converting to YUV or GRAY from RGB

What I am trying to achieve is the highest quality deinterlace. I am not requiring any other functionality. Deinterlacing is my only goal. Can you please walk me through the steps, in language that would suit somebody who is completely over his head (filmmaker not programmer)? Also does the AMV pack include QTGMC, which I understand is the best deinterlacer? Thank you so much.
Frank Booth is offline   Reply With Quote
Old 29th January 2020, 13:05   #52  |  Link
Lypheo
Registered User
 
Join Date: Sep 2018
Posts: 14
Quote:
Originally Posted by Frank Booth View Post

I get the following error:

Failed to evaluate the script:
Python exception: Resize error: Matrix must be specified when converting to YUV or GRAY from RGB
As the error message very clearly states, you need to specify a YUV matrix. Try:
core.resize.Bicubic(clip=clip,format=vs.YUV422P8, matrix_s="709")
Lypheo is offline   Reply With Quote
Old 29th January 2020, 18:58   #53  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
I will update my guide to point out RGB sources need to be converted to use certain filters earlier in the guide to avoid this in the future, thanks for catching that.
l33tmeatwad is offline   Reply With Quote
Old 29th January 2020, 20:05   #54  |  Link
Myrsloik
Professional Code Monkey
 
Myrsloik's Avatar
 
Join Date: Jun 2003
Location: Ikea Chair
Posts: 2,250
Quote:
Originally Posted by l33tmeatwad View Post
I will update my guide to point out RGB sources need to be converted to use certain filters earlier in the guide to avoid this in the future, thanks for catching that.
Poke the script authors too, proper checks are more helpful.
__________________
VapourSynth - proving that scripting languages and video processing isn't dead yet
Myrsloik is offline   Reply With Quote
Old 14th February 2020, 11:55   #55  |  Link
Nico8583
Registered User
 
Join Date: Jan 2010
Location: France
Posts: 761
Hi, I would like to try VapourSynth for Windows to replace AviSynth but I don't find FFMS2 or L-SMASH plugin. Any link to download ? Thank you !
Nico8583 is offline   Reply With Quote
Old 20th March 2020, 07:10   #56  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 101
l33tmeatwad, i would like to appreciate you for sharing those plugins and installer packages. This definitely simplifies a lot of things.
As a new user, i attempt to connect VapourSynth to Hybrid.app on macOS and expect to use QTGMC deinterlace. I must admit that it was rather complicated adventure. I spend more than week to collect info from endless different forums to make it work. In the end i create package and guide that finally just works out of box:

VapourSynth + QTGMC Deinterlace + Hybrid UI FAQ for macOS. Currently it discussed and tested here https://forum.selur.net/showthread.p...d=6894#pid6894 and here https://forum.blackmagicdesign.com/v...p?f=3&t=109259

I also have huge request for your VapourSynth Installer - Please include all plugins and Hybrid scripts inside.

It is total pain to download plugins one by one from Mediafire (it don't allow folder download for free).
People just lost inside those endless folders, versions and variations of Plugins and scripts, and this is the main source of problems: Missing Plugins, Missing Dependencies, Dependencies placed in wrong folder, Missing, Scripts, Wrong location, Alias link deleted by accident, Original .dylib file replaced and Alias link no more works. Error, Error, Error.

Why don't just include into VapourSynth installer all possible plugins, dependencies and scripts so it will work for any possible task and with any possible UI wrapper without additional adjustment? Full plugins package weights only 50MB but may save weeks and months of wasted time.

P.S. Hybrid is no more developed for macOS, but it still works ok. As you may see in Hybrid forum, i was able to update FFmpeg and MKVToolNix inside Hybrid. Selur also suggsted to update MP4Box binary and .dylib files, but he is not sure which files are safe to replace on macOS. Maybe you can suggest something here: https://forum.selur.net/showthread.p...d=6903#pid6903
shph is offline   Reply With Quote
Old 20th March 2020, 15:22   #57  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
I originally had started out with all the plugins compiled into one package, but that is a bit much if someone just wants to just upgrade VapourSynth. I understand it can be a pain to download all the plugins individually, however unless I find a better way to host them it is just how it has to be for now.

The installer was made with the software Packages, my recommendation to make it easier for others to use Hybrid would be to create a companion installer that has the dependencies and places them where they need to go. If you want I am more than happy to help you get started and answer any questions. I'm involved in a lot of different things and I just don't have the capacity to cater to every software that has certain dependancies, I actually haven't had enough time to keep up to date with all the plugins since no one else is contributing at this time.

As for upgrading stuff, I would not recommend replacing system files at all, I would replace things either in the app itself or self contain them like I did with the VapourSynth installer and create link files if needed. Dependency locations for dylib files can actually be changed, if you need any help with this feel free to contact me as I know it can get a bit complicated trying to avoid replacing anything on the system level.
l33tmeatwad is offline   Reply With Quote
Old 21st March 2020, 09:21   #58  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 101
For those who just wants to upgrade VapourSynth, you may add option to installer to select VapourSynth with basic plugins or VapourSynth with all plugins selected with checkboxes. It is so simple. Almost every Mac installer pkg have option like this.

New versions of FFmpeg and MKVToolNix i replaced inside Hybrid works just great. Few people on forums (including me) tested it over week without any issues. The main reason for me to use updated FFmpeg - is updated version of ProRes codec with a lot of bugfixes.
As i understand MP4Box is sort of h264 related part so it is less critical for me. If replacing dylib files is not safe, let's keep things without changes yet.
shph is offline   Reply With Quote
Old 21st March 2020, 09:30   #59  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,169
to clarify about the .dylib files: the files I meant are not system files but files inside the MacOS folder of the Hybrid.app which would only influence tools in the Hybrid MacOS folder not system wide, so only thin that can break through replacing them is a tool in the Hybrid MacOS folder to not work
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 28th March 2020, 20:27   #60  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 295
VapourSynth R49 installer is now up with Zimg updated to 2.9.3 and Python updated to 3.7.6. Make sure to backup any added scripts from site-packages before installing as it will remove the Python 3.6 folders. You can access the site-packages folder from the "Add Scripts" shortcut in the VapourSynth desktop folder.

UPDATE: I may update this for Python 3.8 later, however I wanted to go ahead and get this out there and I had already updated my framework to 3.7 and knew it worked.

Last edited by l33tmeatwad; 28th March 2020 at 20:36. Reason: Updated Information
l33tmeatwad is offline   Reply With Quote
Reply

Tags
meatwadismagical, meatwadthegreat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:08.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.