Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old Yesterday, 19:53   #821  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,050
How to properly mux 29.97 fps interlaced avc content with mkvmerge?

My source is interlaced AVC (duration: 00:00:41.542) and using:
Code:
mkvmerge --ui-language en -o "E:\Output\avc - interlaced_new_new.mkv" --global-tags "E:\Output\avc - interlaced_new_new_2020-07-05@20_21_37_3510__03.xml" -d 0 --default-track 0:yes XXXXXXX--fourcc 0:MP4V --no-chapters --compression -1:none --forced-track 0:yes --no-audio --no-subtitles "E:\Output\avc - interlaced_new_new_2020-07-05@20_21_37_3510_02.264" --default-track 0:yes --sync 0:-67 --forced-track 0:no -a 0 --compression -1:none --no-video --no-subtitles --no-chapters "E:\Output\iId_1_aid_4352_DELAY_-67ms_2020-07-05@20_21_37_3510_01.ac3"
as a base (and replacing the XXXXXXX):

I get:
when using:
Code:
--default-duration 0:30000/1001i --fix-bitstream-timing-information 0
Quote:
Frame rate mode : VFR
Frame rate mode : Variable
Frame rate : 29.970
Frame rate : 29.970 (30000/1001) FPS
FrameRate_Num : 30000
FrameRate_Den : 1001
Original frame rate : 14.985
Original frame rate : 14.985 (15000/1001) FPS
FrameRate_Original_Num : 15000
FrameRate_Original_Den : 1001
Duration : 00:01:23.083
when using:
Code:
--default-duration 0:60000/1001i --fix-bitstream-timing-information 0
Quote:
Frame rate mode : VFR
Frame rate mode : Variable
Frame rate : 59.940
Frame rate : 59.940 (59940/1000) FPS
FrameRate_Num : 59940
FrameRate_Den : 1000
Original frame rate : 29.970
Original frame rate : 29.970 (30000/1001) FPS
FrameRate_Original_Num : 30000
FrameRate_Original_Den : 1001
Duration : 00:00:41.542
when using:
Code:
--default-duration 0:30000/1001fps --fix-bitstream-timing-information 0
Quote:
Frame rate mode : VFR
Frame rate mode : Variable
Frame rate : 59.940
Frame rate : 59.940 (59940/1000) FPS
FrameRate_Num : 59940
FrameRate_Den : 1000
Original frame rate : 29.970
Original frame rate : 29.970 (30000/1001) FPS
FrameRate_Original_Num : 30000
FrameRate_Original_Den : 1001
Duration : 00:00:41.542
when using:
Code:
--default-duration 0:60000/1001fps --fix-bitstream-timing-information 0
Quote:
Frame rate mode : VFR
Frame rate mode : Variable
Frame rate : 119.884
Frame rate : 119.884 FPS
Original frame rate : 60.000
Original frame rate : 60.000 FPS
Duration : 00:00:20.770
when using:
Code:
--default-duration 0:30000/1001fps
Quote:
Frame rate mode : Variable
Frame rate : 59.940
Frame rate : 59.940 (59940/1000) FPS
FrameRate_Num : 59940
FrameRate_Den : 1000
Original frame rate : 29.970
Original frame rate : 29.970 (30000/1001) FPS
FrameRate_Original_Num : 30000
FrameRate_Original_Den : 1001
Duration : 00:00:41.542
when using:
Code:
--default-duration 0:30000/1001i
Quote:
Frame rate mode : Constant
Frame rate : 29.970
Frame rate : 29.970 (30000/1001) FPS
FrameRate_Num : 30000
FrameRate_Den : 1001
Duration : 00:01:23.083
when using:
Code:
--default-duration 0:60000/1001fps
Quote:
Frame rate mode : Variable
Frame rate : 119.884
Frame rate : 119.884 FPS
Original frame rate : 29.970
Original frame rate : 29.970 (30000/1001) FPS
FrameRate_Original_Num : 30000
FrameRate_Original_Den : 1001
Duration : 41 s 501 ms
when using:
Code:
--default-duration 0:60000/1001i
Quote:
Frame rate mode : Variable
Frame rate : 59.940
Frame rate : 59.940 (59940/1000) FPS
FrameRate_Num : 59940
FrameRate_Den : 1000
Original frame rate : 29.970
Original frame rate : 29.970 (30000/1001) FPS
FrameRate_Original_Num : 30000
FrameRate_Original_Den : 1001
Duration : 00:00:41.542
So none of the above seem to totally correct, what I was aiming for was:
Quote:
Frame rate mode : Constant
Frame rate : 29.970
Frame rate : 29.970 (30000/1001) FPS
FrameRate_Num : 30000
FrameRate_Den : 1001
Duration : 00:00:41.542
What am I missing? How to do it correctly?

Cu Selur
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Reply

Tags
matroska

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.