Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th December 2017, 05:32   #47581  |  Link
austonrush
Registered User
 
Join Date: Oct 2015
Posts: 32
Quote:
Originally Posted by Rippner View Post
already changed, I use 2160p23, but without reclock I have 1 repeat frame every XX minutes, with reclock every XX hours

d3d11 worked, thanks!

well at the end the problem was mpc-hc seems perfect now.
another "probem": with 23.976fps video I use 23hz and in madvr is 23.97860hz, but with a 25fps video I use 25hz and in madvr is 24.99870hz and maybe i'm wrong, but doesn't seems smooth. 24.99870 is correct or should be more high?
Inside madvr you can enable "treat 25p movie as 24p" (requires reclock). it's under display modes menu for your monitor or tv. I personally prefer this to interlaced 50hz.
austonrush is online now   Reply With Quote
Old 7th December 2017, 07:16   #47582  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,247
Quote:
Originally Posted by Gopa View Post
If supersampling, is not activated, via image upscaling, then, how do I turn it off? 720p to 2160p: double, twice or x4, to 2880p & then, downscale, to 2160p. 720p to 1440p: double, once, to 1440p & then the TV, upscales, to 2160p.
I think what huhn meant was that you should prevent madVR from downscaling to 2160p. Use NGU for 720 -> 1440 and use Jinc to go from 1440p -> 2160p.

You can enable this by setting:
activate doubling / quadrupling...
<- doubling: ... only if scaling factor is 2.0x (or bigger)
<- quadrupling: ... only if scaling factor is 4.0x (or bigger)

By default madVR uses 1.2x and 2.4x respectively.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 7th December 2017, 08:29   #47583  |  Link
SirSwede
Registered User
 
Join Date: Nov 2017
Posts: 38
Quote:
Originally Posted by Asmodian View Post
I think what huhn meant was that you should prevent madVR from downscaling to 2160p. Use NGU for 720 -> 1440 and use Jinc to go from 1440p -> 2160p.

You can enable this by setting:
activate doubling / quadrupling...
<- doubling: ... only if scaling factor is 2.0x (or bigger)
<- quadrupling: ... only if scaling factor is 4.0x (or bigger)

By default madVR uses 1.2x and 2.4x respectively.
Is that something that is included in your Settings.bin file?
SirSwede is offline   Reply With Quote
Old 7th December 2017, 14:54   #47584  |  Link
Rippner
Registered User
 
Join Date: Sep 2017
Posts: 37
Quote:
Originally Posted by austonrush View Post
What are your settings under the video tab for reclock? As someone else suggested uncheck time stretch
default
Quote:
Originally Posted by austonrush View Post
Inside madvr you can enable "treat 25p movie as 24p" (requires reclock). it's under display modes menu for your monitor or tv. I personally prefer this to interlaced 50hz.
I can try
Rippner is offline   Reply With Quote
Old 7th December 2017, 15:46   #47585  |  Link
Siso
Registered User
 
Siso's Avatar
 
Join Date: Sep 2013
Location: Bulgaria
Posts: 344
Quote:
Originally Posted by Rippner View Post
default

I can try
Use the latest reclock beta. 1.9.0.6 Beta (May 11, 2017)
Siso is offline   Reply With Quote
Old 7th December 2017, 16:15   #47586  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 610
yeah, quite a bit has been added / removed recently -

1.9.0.6 beta - 10/05/2017
* New: Added support for PowerDVD 17
* Change: Updated MediaInfo.dll to 0.7.95.0

1.9.0.5 beta - 08/05/2017
* New: Added debug DWORD registry value "NoMediaInfo". If set to 1, the old DirectShow estimator will be used.

1.9.0.4 beta - 08/05/2017
* Change: MediaInfo estimator improved

1.9.0.3 beta - 16/01/2017
* Change: MediaInfo estimator improved
* Fix: Built in estimator was enabled for file playback by default.

1.9.0.2 beta - 22/12/2016
* Fix: MediaInfo estimator treated audio files as video file

1.9.0.1 beta - 21/12/2016
* New: Retired the old Direct Show framerate estimator for file playback
- MediaInfo.dll (https://mediaarea.net/en/MediaInfo) is used instead
- Using the built-in estimator is no longer recommended for file playback
- Using the built-in estimator is no longer the default for file playback
- Windows 9x is no longer supported. May it rest in peace.
* New: Framerate cache was actually quite unusable.
The behavior is changed:
- default framerate will no longer stored in cache
- setting a default framerate will not stop automatic detection, automatic
detection will always override default framerate setting
- setting a framerate manually during playback will store it in the cache
- manually setting the framerate to "unknown/automatic" will delete if from the cache
- a manual framerate in the cache will stop automatic detection of the built-in estimator
- manually setting the framerate to "unknown" will enable automatic detection of the built-in estimator
ATTENTION: This is beta software!
As there are many changes to many parts of ReClock, things might not work right away as expected.
mclingo is online now   Reply With Quote
Old 7th December 2017, 16:41   #47587  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
I am using an AMD RX 480 with madvr and it is working well. It also works well after the latest Windows updates and driver updates. I use full screen windowed mode instead of FSE. FSE doesn’t work well with NVidia and AMD, which I believe is a madvr issue. I love the stability of the RX 480.

However, I can only set the RX 480 to ‘NGU Sharp – High’ with all additional enhancements turned off to avoid skipping frames. I have experimented with ‘NGU Sharp – Very High’ and other enhancements and I must say that I see no differences between high and very high. The enhancements are also negligible.

I can think of two main reasons why I can’t see differences

1. I use high quality (almost BR quality) films: 1080 -> 4K
2. The projector (JVC X5000) picture grain cannot enhance the differences

A third reason could perhaps be my RX 480. I am not sure. What if I compare my ‘RX 480 – NGU Sharp – High’ to a ‘GTX 1070Ti – NGU Sharp – Very High (with enhancements turned on)’, will I see a significant difference?

I am asking this because I am planning to buy a new graphics card for my gaming PC. I was thinking of moving the RX 480 from the HTPC to the gaming PC. Then I need a new gfx card in my HTPC. The GTX 1080 is far too expensive and the AMD RX 580 is in my budget but it is similar to my RX 480. Another candidate could be the GTX 1070 Ti. With the GTX 1070 Ti I assume that I can set madvr to ‘NGU Sharp - Very High’ with most enhancements turned on. Is this right? I also want to use HDR in the future. Will the GTX 1070 Ti significantly improve the picture quality which I did not get with my RX 480?

BTW What I don’t want to use is reclock and other workaround tools with NVidia. For my AMD RX 480 I don’t need this and I get a most stable result. My projector switches to the appropriate frequency for the movie.

I need some advice.
Thanks.

Last edited by HillieSan; 7th December 2017 at 16:53.
HillieSan is offline   Reply With Quote
Old 7th December 2017, 17:36   #47588  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 610
Quote:
Originally Posted by HillieSan View Post
I am using an AMD RX 480 with madvr and it is working well. It also works well after the latest Windows updates and driver updates. I use full screen windowed mode instead of FSE. FSE doesn’t work well with NVidia and AMD, which I believe is a madvr issue. I love the stability of the RX 480.

However, I can only set the RX 480 to ‘NGU Sharp – High’ with all additional enhancements turned off to avoid skipping frames. I have experimented with ‘NGU Sharp – Very High’ and other enhancements and I must say that I see no differences between high and very high. The enhancements are also negligible.

I can think of two main reasons why I can’t see differences

1. I use high quality (almost BR quality) films: 1080 -> 4K
2. The projector (JVC X5000) picture grain cannot enhance the differences

A third reason could perhaps be my RX 480. I am not sure. What if I compare my ‘RX 480 – NGU Sharp – High’ to a ‘GTX 1070Ti – NGU Sharp – Very High (with enhancements turned on)’, will I see a significant difference?

I am asking this because I am planning to buy a new graphics card for my gaming PC. I was thinking of moving the RX 480 from the HTPC to the gaming PC. Then I need a new gfx card in my HTPC. The GTX 1080 is far too expensive and the AMD RX 580 is in my budget but it is similar to my RX 480. Another candidate could be the GTX 1070 Ti. With the GTX 1070 Ti I assume that I can set madvr to ‘NGU Sharp - Very High’ with most enhancements turned on. Is this right? I also want to use HDR in the future. Will the GTX 1070 Ti significantly improve the picture quality which I did not get with my RX 480?

BTW What I don’t want to use is reclock and other workaround tools with NVidia. For my AMD RX 480 I don’t need this and I get a most stable result. My projector switches to the appropriate frequency for the movie.

I need some advice.
Thanks.
i've got my AMD RX 550 working well now but i have to use reclock after I picked up the creators fall update, prior to that It was rock solid even with FSE.

I personally need FSE for 3d movies but I could turn it on and off, however i've got it stable now with it on.

Even with FSE off though I couldnt get rid of the frame drops / repeats, dont know how other people are getting this to work on the creators update.

Are you saying you use the win 10 creators update in 4K and get no frame drops or repeats without using reclock?

If so would you mind posting your CONTROL J screen when in a movie so I can have a look how yours different to mine.
mclingo is online now   Reply With Quote
Old 7th December 2017, 17:53   #47589  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
Quote:
Originally Posted by mclingo View Post
Are you saying you use the win 10 creators update in 4K and get no frame drops or repeats without using reclock?
Yes.

In the past I used Bluesky FRC and it did work well. It was smooth at 60 Hz. I didn't get reclock to work without frame drops. The problem of using Bluesky FRC and reclock is that madvr has to process the images at 60 hz; 1080 -> 4K. Therefore, it could not go higher than 'NGU Sharp -- Medium'.

What solved this problem was to let madvr switch my projector and TV to 23 Hz (or 24, 25 hz). On the projector I had to enable a motion enhancer to get rid of judder. The judder is part of the projector and it can eliminate it by enabling this option. I think most 4K projectors have this option. Since madvr processes the images at 23 Hz (and not at 60 hz) it has more time to process 'NGU Sharp -- High' without frame drops. So reclock or Bluesky FRC is not needed.

BTW If I had an ultra fast AMD gfx card I would probably go back to Bluesky FRC. This is best optimised for AMD and movies are very smooth at 60 hz. It gave me the smoothest picture. But switching to the native frequency is also fine.
Be careful, 4K @ 60 Hz requires a very good cable.

Last edited by HillieSan; 7th December 2017 at 18:10.
HillieSan is offline   Reply With Quote
Old 7th December 2017, 18:03   #47590  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 610
Quote:
Originally Posted by HillieSan View Post
Yes.

In the past I used Bluesky FRC and it did work well. It was smooth at 60 Hz. I didn't get reclock to work without frame drops. The problem of using Bluesky FRC and reclock is that madvr has to process the images at 60 hz. Therefore, it could not go higher than 'NGU Sharp -- Medium'.

What solved my problem was to let madvr switch my projector and TV to 23 Hz (or 24, 25 hz). On the projector I had to use a motion enhancer to get rid of judder. The judder is part of the projector and it can eliminate it by enabling this option. I think most 4K projectors have this option. Since madvr processes the images at 23 Hz (and not at 60 hz) it has more time to process 'NGU Sharp -- High' without frame drops.

BTW If I had a faster AMD gfx card I would go back to Bluesky FRC. This is best optimised for AMD and movies are very smooth at 60 hz. It gave me the smoothest picture. But switching to the native frequency is also fine.
Be careful, 4K @ 60 Hz requires a very good cable.
I may have a look at bluesky at some point myself.

So you're using reclock at the moment then?
mclingo is online now   Reply With Quote
Old 7th December 2017, 18:16   #47591  |  Link
Gopa
Registered User
 
Join Date: Oct 2017
Posts: 27
720p: upscaled with madVR

Quote:
Originally Posted by Asmodian View Post
I think what huhn meant was that you should prevent madVR from downscaling to 2160p. Use NGU for 720 -> 1440 and use Jinc to go from 1440p -> 2160p.

You can enable this by setting:
activate doubling / quadrupling...
<- doubling: ... only if scaling factor is 2.0x (or bigger)
<- quadrupling: ... only if scaling factor is 4.0x (or bigger)

By default madVR uses 1.2x and 2.4x respectively.
Thank you! NGU Sharp high/luma doubling; luma quadrupling/disabled; activate doubling only if scaling factor is 2.0x (quadrupling is greyed-out); if any more scaling/Jinc AR; RCA anything I want; Best images for 720p are now upscaled to 2160p with madVR!
Gopa is offline   Reply With Quote
Old 7th December 2017, 18:17   #47592  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
I am not using reclock and I am not using Bluesky FRC.

I think you should not use reclock for your RX 550. Bluesky FRC is a better alternative.
You must add Bluesky FRC to the external filters in mpc be/hc or potplayer.

EDIT: And you need to turn on AMD Fluid Motion Video in the driver.

Does your TV/projector/monitor support 23 Hz? If it does than don't use any tools. Let the RX 550 do it. This is what I use.

Last edited by HillieSan; 7th December 2017 at 18:28.
HillieSan is offline   Reply With Quote
Old 7th December 2017, 18:42   #47593  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 610
Quote:
Originally Posted by HillieSan View Post
I am not using reclock and I am not using Bluesky FRC.

I think you should not use reclock for your RX 550. Bluesky FRC is a better alternative.
You must add Bluesky FRC to the external filters in mpc be/hc or potplayer.

EDIT: And you need to turn on AMD Fluid Motion Video in the driver.

Does your TV/projector/monitor support 23 Hz? If it does than don't use any tools. Let the RX 550 do it. This is what I use.
right, so you're not using reclock or FRC at the moment, you're desktop is 4k and you are using windows 10 fall update - and you're not getting any frame drops or repeats??
mclingo is online now   Reply With Quote
Old 7th December 2017, 18:48   #47594  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
Yes, that's right :-)

I don't think that Windows 10 fall update causes the frame drops and repeats.

Last edited by HillieSan; 7th December 2017 at 18:51.
HillieSan is offline   Reply With Quote
Old 7th December 2017, 18:52   #47595  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
What display are you using? brand and type
HillieSan is offline   Reply With Quote
Old 7th December 2017, 18:56   #47596  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 610
Quote:
Originally Posted by HillieSan View Post
Yes, that's right :-)
ok thanks very much for confirming, in that case something must be wrong with my setup, without reclock MADVR is locked to frame drops every 40 seconds almost bang on in everything, 4k and 1080p material.

could you help with the below?

- can you post your list of display modes in MADVR
- what do you have ticked in MADVR rendering page?
- have you tweaked anything from stock MADVR anywhere in rendering or anything relevant anywhere else?
- which media player are you using?
- what interval is CONTROL J showing in between dropped frames / repeated frames exactly, can you post a screen shot?
mclingo is online now   Reply With Quote
Old 7th December 2017, 19:00   #47597  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
Quote:
Originally Posted by mclingo View Post
without reclock MADVR is locked to frame drops every 40 seconds almost bang on in everything
That's good (= normal) :-) It should perform drop frames every 2 seconds without using anything.

First I need to know your display to see what settings you need.

Last edited by HillieSan; 7th December 2017 at 19:58.
HillieSan is offline   Reply With Quote
Old 7th December 2017, 19:12   #47598  |  Link
austonrush
Registered User
 
Join Date: Oct 2015
Posts: 32
Quote:
Originally Posted by Rippner View Post
default

I can try
Change the value for for both maximum slow down and Maximum speed up to 5%. Once done clean all of your frame rate history under advanced.
austonrush is online now   Reply With Quote
Old 7th December 2017, 19:47   #47599  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 116
Quote:
Originally Posted by mclingo View Post
ok thanks very much for confirming, in that case something must be wrong with my setup, without reclock MADVR is locked to frame drops every 40 seconds almost bang on in everything, 4k and 1080p material.

could you help with the below?

- can you post your list of display modes in MADVR
- what do you have ticked in MADVR rendering page?
- have you tweaked anything from stock MADVR anywhere in rendering or anything relevant anywhere else?
- which media player are you using?
- what interval is CONTROL J showing in between dropped frames / repeated frames exactly, can you post a screen shot?
Please let me know what display you are using. It is important to know what the display is able to do.

In the meantime I give you some of my settings :-)

It wrote them here as 5 different steps. I hope that this will help.

-------------------------------------------------------------

STEP 1 -- Windows --

Delete reclock.
Update Windows and drivers.

STEP 2 -- LAV 0.70.2.80--

Hardware Decoder to use: D3D11
Hardware Device to use: Automatic (Native)
Software Deinterlacing Algorithm: No Software Deinterlacing

STEP 3 -- MADVR 0.92.9 --

devices->display->display modes->

[v] switch to match display mode...
(0) .. when playback starts

the rest is unticked or empty

processing->artifact removal->

all unticked

processing->image enhancements->

all unticked

scaling algorithms->chroma upscaling->

only Jinc ticked

scaling algorithms->image downscaling->

only SSIM ticked and set to '1D-strength 100%'

scaling algorithms->image upscaling->

option NGU Sharp is ticked and algoritm quality set to 'high',
all other options are set to 'let madVR decide'

Note: I think you should set algoritm quality to 'medium'

scaling algorithms->upscaling refinement->

all unticked

rendering->general settings->

[v] delay playback start until render queue is full
[v] use Direct3D 11 for presentation (Windows 7 and newer)
[v]present a frame for every VSync

all other options are uniticked

CPU queue size: 16
GPU queue size: 8

rendering->windows mode->

[v] present several frames in advanced

all default

rendering->exclusive mode->

all default

Note: I read here in forum that a buffer of 4 is better than 8 in order to avoid FSE black screen problem. I must test this.

rendering->smooth rendering->

unticked

rendering->dithering->

(0) Ordered Dithering
[v] use colored noise
[v] change dither for every frame

trade quality for performance->

all unticked

STEP 4 -- Player --

I use the MPC BR player. In Options->Externe Filter add

[v] LAV Splitter
[v] LAV Video Decoder
[v] LAV Audio Decoder
[v] LAC Splitter Source
[v] madVR

All these filters are set to highest priority.
This works the same for MPC HC and Potplayer.

Note: If you use Bluesky FRC then you must also add this as a filter here. Set it to the highest priority and move it above madVR filter. Bluesky FRC must be put before mapVR.

STEP 5 -- Notes --

If you start MPC BE or if you change the slider bar in MPC BE then you will see some frame drops or repeats in crtl-J. that is normal.

If you set LAV, madVR and MPC BE as above and you still exprience judder then it is time to look at your display. You can assume that the chain above is doing it right, but the display may need some minor adjustments as well (like enabling the motion anhancer). This would be the last step.

Last edited by HillieSan; 7th December 2017 at 19:52.
HillieSan is offline   Reply With Quote
Old 7th December 2017, 20:07   #47600  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 610
Quote:
Originally Posted by HillieSan View Post
Please let me know what display you are using. It is important to know what the display is able to do.

In the meantime I give you some of my settings :-)

It wrote them here as 5 different steps. I hope that this will help.

-------------------------------------------------------------

STEP 1 -- Windows --

Delete reclock.
Update Windows and drivers.

STEP 2 -- LAV 0.70.2.80--

Hardware Decoder to use: D3D11
Hardware Device to use: Automatic (Native)
Software Deinterlacing Algorithm: No Software Deinterlacing

STEP 3 -- MADVR 0.92.9 --

devices->display->display modes->

[v] switch to match display mode...
(0) .. when playback starts

the rest is unticked or empty

processing->artifact removal->

all unticked

processing->image enhancements->

all unticked

scaling algorithms->chroma upscaling->

only Jinc ticked

scaling algorithms->image downscaling->

only SSIM ticked and set to '1D-strength 100%'

scaling algorithms->image upscaling->

option NGU Sharp is ticked and algoritm quality set to 'high',
all other options are set to 'let madVR decide'

Note: I think you should set algoritm quality to 'medium'

scaling algorithms->upscaling refinement->

all unticked

rendering->general settings->

[v] delay playback start until render queue is full
[v] use Direct3D 11 for presentation (Windows 7 and newer)
[v]present a frame for every VSync

all other options are uniticked

CPU queue size: 16
GPU queue size: 8

rendering->windows mode->

[v] present several frames in advanced

all default

rendering->exclusive mode->

all default

Note: I read here in forum that a buffer of 4 is better than 8 in order to avoid FSE black screen problem. I must test this.

rendering->smooth rendering->

unticked

rendering->dithering->

(0) Ordered Dithering
[v] use colored noise
[v] change dither for every frame

trade quality for performance->

all unticked

STEP 4 -- Player --

I use the MPC BR player. In Options->Externe Filter add

[v] LAV Splitter
[v] LAV Video Decoder
[v] LAV Audio Decoder
[v] LAC Splitter Source
[v] madVR

All these filters are set to highest priority.
This works the same for MPC HC and Potplayer.

Note: If you use Bluesky FRC then you must also add this as a filter here. Set it to the highest priority and move it above madVR filter. Bluesky FRC must be put before mapVR.

STEP 5 -- Notes --

If you start MPC BE or if you change the slider bar in MPC BE then you will see some frame drops or repeats in crtl-J. that is normal.

If you set LAV, madVR and MPC BE as above and you still exprience judder then it is time to look at your display. You can assume that the chain above is doing it right, but the display may need some minor adjustments as well (like enabling the motion anhancer). This would be the last step.


wow, cheers, i'll dial these in when i get home from work and get back to you.

edit - you are doing a lot of processing and shapening / deblacking here, these settings ruin my picture, I tend to have all this off as most of my stuff is 1080p and 4k, also by ticking all of the trade quality for performance boxes arent you degrading your image?


is there a reason you are using lav .80 instead of the latest 82?

Last edited by mclingo; 7th December 2017 at 20:17.
mclingo is online now   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.