Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD & BD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th October 2021, 15:09   #30921  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,931
Quote:
Originally Posted by gamete View Post
I can buy this pc in forum
No scam

But i ask to you if this pc can be good for male backup 4k in bd25

Thanks
Honestly, if you are planning to do 4K backups, you'd probably be better off investing in an NVIDIA video card that does encoding (mine is a GTX-1660). The prices have gone up recently (I'm guessing it's the global chip shortage -- but don't know). But, if you look around you can find them cheap enough. Encoding with the GPU is several times faster than CPU -- and 4K encoding can really bog down a CPU.

But, as always, that's just an opinion. Yours matters more.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 6th October 2021 at 15:12.
jdobbs is offline   Reply With Quote
Old 7th October 2021, 09:06   #30922  |  Link
Timmy256
Registered User
 
Join Date: Oct 2021
Posts: 16
Output Video Playing at 2x+ Speed

Hi, I hope you are all doing well.

I found out this great application for the first time and I've been trying to use to compress a Blu-Ray movie decrypted in my HDD (plain files). I've tried about 25 times; switching the settings around, and still have the same issue.

The movie is “A Glitch in the Matrix"; around 35 GB uncompressed. It consists of the menu, main movie, trailer and a Zoom webinar Q&A extra. The most important problem happens with this last extra video. No matter how many settings I switched around, it ends up with the video sped up about 2x (perhaps even more) and the audio running normally. Here are a couple of facts:

- I'm trying this on a fresh copy of Windows 10; with everything installed and configured following the readme file and the “Inspect” reports turns out everything OK (posted at the bottom)
- If I try to preview the file by right clicking it within BD Rebuilder, it opens in Media Player Classic and it plays wrongly; exactly the same, with the video about twice as fast compared to the audio
- If I open the extra file directly from within the source folder, through VLC, it plays perfectly fine
- The file in question has two audio tracks that, seemingly, are exactly the same. It's not that one is 5.1 and the other Stereo (or something like that). This will be important later
- In my quest to find software to compress Blu Rays, I've tried DVDFab and exactly the same issue resulted after the process finished; with the video extremely sped up. After switching around several settings there, I've found that if I left the two audio tracks for the extra and use software compression (disabling Intel QuickSync), the finished video ended up right! But I'll really love to use BD Rebuilder instead; that's why I'm trying so hard to make it work
- If in DVDFab, I left only one audio track (no matter which one); even when disabling QuickSync and with the exact same settings as the previous point, the video again turned out to run extremely fast; while the audio plays normal. I have to left the two audio tracks in for it to render a fine, working video
- In my current settings, I have selected the option to not convert DTS, leave HD audio as is, etc; trying to minimize recoding as much as possible. The same issue still persists.
- Of course, I have tried the DirectshowSource, LAVF and FRIMSource serving settings; all producing the same results
- The only weird thing I've noticed is that, the log for that extra file, shows an “EXIT CODE: -2”, but continues processing as if nothing happened. Of course, I've tried searching for this exit code here and couldn't find anything about it

I don't know what issue exactly that damn extra video file has, that makes this fail over and over. I've been working on this for over a week; trying highest quality settings 2 pass (15+ hours), fast, auto, etc.; always the same result. The only thing that worked so far was DVDFab, if I configure it as described above.

Some questions that I have in my head:

- Why does that file has two seemingly audio tracks and why, if I only leave one in, DVDFab still produces a video 2x sped up?
- (This probably related to not knowing how BD Rebuilder works fully) Why when switching on and off the audio tracks in extra, other audio tracks (in different files), switch on and off along with it?
- Why the built in Media Player Classic preview also runs the source; untouched file at wrong speed, while VLC plays it fine? Does it have to do with some installed codecs? Remember, this is a fresh Windows 10 installation with nothing crazy going on and I've only ever used VLC for playing

An unrelated problem, but that also drove me nuts for the first couple of days, was that the process aborted around 50% with an audio recoding error. I think it's because the track in the main movie is DTS-HD and I've read in some old post that BD Rebuilder might have some problems with that? But should it still be able to convert that audio file too (hence the “leave HD audio alone” option)? When I activated that, BD Rebuilder doesn't try to touch the audio and fully completes, but would be nice to know also why it's not working for conversion of HD audio and if there was anything I could to to make it work too.

Would you please help me to troubleshoot this in any way you can? Or letting me know how to run some “forensics” on that extra file, to post its data here (codecs; anything that may be useful to troubleshoot)?

I'm posting all this information and anything I can think of at the end, for you to be able to see.

Thanks in advance for any help you can provide on this matter; as it's truly driving me crazy trying to find out exactly where the problem lies! .

OUTPUT LOG
[10/01/21] BD Rebuilder v0.61.22
[22:09:10] Source: A.GLITCH.IN.THE.MATRIX.2021.1080P.BLURAY.AVC.DTS-HD.MA.5.1-FGT
- Input BD size: 33.05 GB
- Approximate total content: [02:27:22.216]
- Target BD size: 22.95 GB
- Windows Version: 6.2 [9200]
- Auto Quality: Very Good (Very Fast), 1-Pass VBR
- Decoding/Frame serving: DirectShow
- Audio Settings: AC3=0 DTS=0 HD=1 Kbs=640
[22:09:11] PHASE ONE, Encoding
- [22:09:11] Processing: VID_00000 (1 of 5)
- [22:09:11] Extracting A/V streams [VID_00000]
- [22:23:23] Reencoding video [VID_00000]
- Source Video: MPEG-4 (AVC), 1920x1080
- Rate/Length: 23.976fps, 156,204 frames
- Bitrate: 21,721 Kbs
- [22:23:23] Reencoding: VID_00000, Pass 1 of 1
- [00:41:30] Video Encode complete
- [00:41:30] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [00:41:30] Multiplexing M2TS
- [00:55:44] Processing: VID_00001 (2 of 5)
- [00:55:44] Extracting A/V streams [VID_00001]
- [00:55:50] Reencoding video [VID_00001]
- Source Video: MPEG-4 (AVC), 1280x720
- Rate/Length: 59.940fps, 15 frames
- [00:55:50] Reencoding: VID_00001, Pass 1 of 1
- [00:55:51] Video Encode complete
- [00:55:51] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- Track 4353 (eng): Keeping original audio
- [00:55:51] Multiplexing M2TS
- [00:55:56] Processing: VID_00002 (3 of 5)
- [00:55:56] Extracting A/V streams [VID_00002]
- [00:56:10] Reencoding video [VID_00002]
- Source Video: MPEG-4 (AVC), 1920x1080
- Rate/Length: 23.976fps, 2,905 frames
- Bitrate: 13,820 Kbs
- [00:56:10] Reencoding: VID_00002, Pass 1 of 1
- [00:58:10] Video Encode complete
- [00:58:10] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [00:58:10] Multiplexing M2TS
- [00:58:26] Processing: VID_00007 (4 of 5)
- [00:58:26] Extracting A/V streams [VID_00007]
- [00:58:31] Reencoding video [VID_00007]
- Source Video: MPEG-4 (AVC), 1920x1080
- Rate/Length: 23.976fps, 15 frames
- Bitrate: 2,031 Kbs
- [00:58:31] Reencoding: VID_00007, Pass 1 of 1
- [00:58:32] Video Encode complete
- [00:58:32] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [00:58:32] Multiplexing M2TS
- [00:58:36] Processing: VID_00010 (5 of 5)
- [00:58:36] Extracting A/V streams [VID_00010]
EXIT CODE: -2
- Extracting video streams [VID_00010]
- Extracting audio/subtitle streams [VID_00010]
- [01:00:42] Reencoding video [VID_00010]
- Source Video: MPEG-4 (AVC), 1280x720
- Rate/Length: 59.940fps, 126,178 frames
- Bitrate: 2,075 Kbs
- [01:00:42] Reencoding: VID_00010, Pass 1 of 1
- [01:14:03] Video Encode complete
- [01:14:03] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- Track 4353 (eng): Keeping original audio
- [01:14:03] Multiplexing M2TS
[01:14:43]PHASE ONE complete
[01:14:43]PHASE TWO - Rebuild Started
- [01:14:43] Rebuilding BD file Structure
[01:14:51] - Encode and Rebuild complete
- WORKFILES folder removed.
[01:14:53] JOB: A.GLITCH.IN.THE.MATRIX.2021.1080P.BLURAY.AVC.DTS-HD.MA.5.1-FGT finished.

INSPECT LOG
[10/02/21] Checking System Settings
- BD-Rebuilder v0.61.22
- Windows Version: 6.2 [9200]
- Working Path Free Space: 1,331.18GB
- AVISYNTH Version: 2.6.0.6, Ok
- LAVFILTERS: Ok
- X264: Ok
- X265: Ok
- AFTEN: Ok
- FAAC: Ok
- MP4BOX: Ok
- WAVI: Ok
- TSMUXER: Ok
- FRIMEncode: Ok
- FRIMDecode: Ok
[10/02/21] Systems Settings Check complete

LAST SETTINGS USED


THE FILE IN QUESTION OF THE EXTRA IN BD REBUILDER


THE ORIGINAL FILE CODEC INFO FROM VLC


THE SPED UP FILE CODEC INFO FROM VLC


MESSAGE THAT CAME OUT IN CAMTASIA WHILE IMPORTING THE SPED UP FILE TO CREATE THE SAMPLE (Does it mean anything that Camtasia detected the output as “High Frame Rate”?)


ORIGINAL VIDEO SAMPLE
https://youtu.be/1PCVyu4la00

SPED UP VIDEO SAMPLE
https://youtu.be/QAoe__M8kOI
Timmy256 is offline   Reply With Quote
Old 8th October 2021, 21:21   #30923  |  Link
jetli
Registered User
 
Join Date: Aug 2010
Posts: 22
version 61.22, movie only mode

movie ends instead of repeats and restarts at beginning.
what is causing this.
can i fix it back to restart movie at beginning after the end?
thanks tony
jetli is offline   Reply With Quote
Old 8th October 2021, 23:59   #30924  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,931
Quote:
Originally Posted by jetli View Post
movie ends instead of repeats and restarts at beginning.
what is causing this.
can i fix it back to restart movie at beginning after the end?
thanks tony
Nothing has changed related to that in this version. But there is a hidden option to enable that behavior. See HIDDENOPTS.TXT.

You can add:

MOVIE_ONLY_LOOP=1

to rebuilder.ini.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 9th October 2021 at 00:01.
jdobbs is offline   Reply With Quote
Old 12th October 2021, 15:59   #30925  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,931
@Timmy256

Please review rules 7 and 8. Repeating a post (I've removed the repeat), especially one as large as yours, isn't appropriate. If you do it again I'll be forced to issue a strike. It's good that you provide detail, but I'd suggest you make the images smaller -- when a post is as large as yours and has giant images dominating the view, people tend to just skip over it.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 12th October 2021 at 16:07.
jdobbs is offline   Reply With Quote
Old 17th October 2021, 01:00   #30926  |  Link
Timmy256
Registered User
 
Join Date: Oct 2021
Posts: 16
Thanks @jdobbs!

Sorry for the repost. I though that my post wasn’t working, after waiting for a week to register and post; hence why I reposted. I didn’t see it here, neither did I get any notification saying that it wasn’t approved for some reason.

I’ll try to re-adapt it to fit the rules you mentioned. I’ve tried to include as much detail as possible, as the support posts I’ve read, pretty much always miss a lot of detail on the issue; that’s why I went overboard.

Would it be OK to try posting after I readapt it to the rules or is there any way to pre-check with you if it’s OK by then?

Thanks again!

Last edited by Timmy256; 17th October 2021 at 01:03.
Timmy256 is offline   Reply With Quote
Old 17th October 2021, 01:57   #30927  |  Link
videoh
Useful n00b
 
Join Date: Jul 2014
Posts: 1,667
Welcome to the forum Timmy! Sending you a friend request.
videoh is offline   Reply With Quote
Old 20th October 2021, 01:38   #30928  |  Link
Timmy256
Registered User
 
Join Date: Oct 2021
Posts: 16
Thanks videoh! I just accepted it.
Timmy256 is offline   Reply With Quote
Old 20th October 2021, 03:36   #30929  |  Link
videoh
Useful n00b
 
Join Date: Jul 2014
Posts: 1,667
Thank you. Onward and upward, Timmy.
videoh is offline   Reply With Quote
Old 13th November 2021, 17:53   #30930  |  Link
LowDead
Elit Amans
 
Join Date: Feb 2005
Location: Sweden
Posts: 275
A couple of interesting updates/fixes from NVEncC 5.35, if you want to add it to the next BDRB release jdobbs.

Latest NVEenC
__________________
Windows 11 Pro 64-bit, AMD Ryzen 9 5950X@3.40GHz, 32GB, NVIDIA RTX 2070 8GB, PIONEER BDR-S09XLT, ASUS BW-16D1HT, LG CX 65", Panasonic DP-UB820EB-K, Sony PS3 & PS5
LowDead is offline   Reply With Quote
Old 15th November 2021, 14:25   #30931  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,931
Quote:
Originally Posted by LowDead View Post
A couple of interesting updates/fixes from NVEncC 5.35, if you want to add it to the next BDRB release jdobbs.

Latest NVEenC
I'll do some testing an add it to the next release.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 16th November 2021, 09:31   #30932  |  Link
RetsimLegin
Registered User
 
Join Date: Apr 2021
Posts: 31
Quote:
Originally Posted by jdobbs
Modified the method for reencoding E-AC3 files that are imported. Some systems and sources had randomly experienced channel count discrepancies in the old method.
Just confirming - I have recently worked a few E-AC3 titles and have not seen the previous miscalculation of channel numbers recur. Thanks.
RetsimLegin is offline   Reply With Quote
Old 16th November 2021, 17:18   #30933  |  Link
SquallMX
Special SeeD
 
Join Date: Nov 2002
Location: Mexico
Posts: 314
I'm getting desync subtitles on v0.61.25 even when using "No Reencode":

Code:
[11/16/21] BD Rebuilder v0.61.25
[09:44:30] Source:  MAD_MAX_3_BEYOND_THUNDERDOME
  - Input BD size: 28.25 GB
  - Approximate total content: [02:01:48.667]
  - Target BD size: 28.32 GB
  - Windows Version: 6.2 [9200]
  - MOVIE and MENUS mode enabled
  - Quality: High Quality (Default), Two Pass
  - X264 Tweak(s) enabled
  - Decoding/Frame serving: DGDecNV
  - Audio Settings: AC3=0 DTS=0 HD=1 Kbs=640
[09:44:34] PHASE ONE, Encoding
 - [09:44:34] Blanking: VID_00007 (1 of 38)
 - [09:44:34] Blanking: VID_00016 (2 of 38)
 - [09:44:34] Blanking: VID_00035 (3 of 38)
 - [09:44:34] Blanking: VID_00042 (4 of 38)
 - [09:44:34] Blanking: VID_00043 (5 of 38)
 - [09:44:34] Blanking: VID_00046 (6 of 38)
 - [09:44:34] Blanking: VID_00024 (7 of 38)
 - [09:44:34] Blanking: VID_00037 (8 of 38)
 - [09:44:34] Blanking: VID_00051 (9 of 38)
 - [09:44:34] Blanking: VID_00021 (10 of 38)
 - [09:44:34] Blanking: VID_00048 (11 of 38)
 - [09:44:34] Blanking: VID_00052 (12 of 38)
 - [09:44:34] Blanking: VID_00038 (13 of 38)
 - [09:44:34] Blanking: VID_00039 (14 of 38)
 - [09:44:34] Blanking: VID_00050 (15 of 38)
 - [09:44:34] Blanking: VID_00047 (16 of 38)
 - [09:44:34] Blanking: VID_00022 (17 of 38)
 - [09:44:34] Blanking: VID_00041 (18 of 38)
 - [09:44:34] Blanking: VID_00034 (19 of 38)
 - [09:44:34] Blanking: VID_00049 (20 of 38)
 - [09:44:34] Blanking: VID_00008 (21 of 38)
 - [09:44:34] Blanking: VID_00045 (22 of 38)
 - [09:44:34] Blanking: VID_00044 (23 of 38)
 - [09:44:34] Blanking: VID_00055 (24 of 38)
 - [09:44:34] Blanking: VID_00010 (25 of 38)
 - [09:44:34] Blanking: VID_00018 (26 of 38)
 - [09:44:34] Blanking: VID_00069 (27 of 38)
 - [09:44:34] Blanking: VID_00011 (28 of 38)
 - [09:44:34] Blanking: VID_00006 (29 of 38)
 - [09:44:34] Processing: VID_00003 (30 of 38)
 - [09:44:34] Extracting A/V streams [VID_00003]
 - [09:44:38] Reencoding video [VID_00003]
 - [09:44:38] Keeping original video (no reencode)
 - [09:44:38] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
 - [09:44:38] Multiplexing M2TS
 - [09:44:42] Blanking: VID_00002 (31 of 38)
 - [09:44:42] Blanking: VID_00004 (32 of 38)
 - [09:44:42] Blanking: VID_00012 (33 of 38)
 - [09:44:42] Blanking: VID_00014 (34 of 38)
 - [09:44:42] Blanking: VID_00013 (35 of 38)
 - [09:44:42] Processing: VID_00057 (36 of 38)
 - [09:44:42] Extracting A/V streams [VID_00057]
 - [09:44:47] Reencoding video [VID_00057]
 - [09:44:47] Keeping original video (no reencode)
 - [09:44:47] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
 - [09:44:47] Multiplexing M2TS
 - [09:44:51] Blanking: VID_00015 (37 of 38)
 - [09:44:51] Processing: VID_00061 (38 of 38)
 - [09:44:51] Extracting A/V streams [VID_00061]
 - [09:45:30] Reencoding video [VID_00061]
 - [09:45:30] Keeping original video (no reencode)
 - [09:45:30] Processing audio tracks
   - Track 4352 (eng): Keeping original audio
   - Track 4353 (fra): Keeping original audio
   - Track 4354 (deu): Keeping original audio
   - Track 4355 (ita): Keeping original audio
   - Track 4356 (spa): Keeping original audio
   - Track 4357 (spa): Keeping original audio
   - Track 4358 (por): Keeping original audio
   - Track 4359 (ces): Keeping original audio
   - Track 4360 (hun): Keeping original audio
   - Track 4361 (pol): Keeping original audio
   - Track 4362 (rus): Keeping original audio
   - Track 4363 (jpn): Keeping original audio
 - [09:45:30] Multiplexing M2TS
[09:46:07]PHASE ONE complete
[09:46:07]PHASE TWO - Rebuild Started
 - [09:46:07] Rebuilding BD file Structure
[09:46:33] - Encode and Rebuild complete
[09:46:33] JOB: MAD_MAX_3_BEYOND_THUNDERDOME finished.
Code:
[Status]
LABEL=MAD_MAX_3_BEYOND_THUNDERDOME
VERSION=v0.61.25
SOURCE_SIZE=30331871654
SOURCE_VIDEO_SIZE=29999794176
TARGET_SIZE=30408704000
REDUCTION=1.00256109577117
RESIZE_1080=0
RESIZE_1440=0
AUDIO_TO_KEEP=all
KEEP_HD_AUDIO=-1
SUBS_TO_KEEP=all
BACKUP_MODE=0
MOVIEONLY_TYPE=0
USE_LAVF=0
INSTANCES=1
DGDECNV=-1
DGDECIM=0
FRIMSOURCE=0
FFMS2=0
SSIF_MODE=0
UHD_V3_MODE=0
QUICK=1
ENCODE_STEP=0
COMPLETED=38
REBUILD_COMPLETE=1
[00007]
USE_ORIGINAL=1
[00016]
USE_ORIGINAL=1
[00035]
USE_ORIGINAL=1
[00042]
USE_ORIGINAL=1
[00043]
USE_ORIGINAL=1
[00046]
USE_ORIGINAL=1
[00024]
USE_ORIGINAL=1
[00037]
USE_ORIGINAL=1
[00051]
USE_ORIGINAL=1
[00021]
USE_ORIGINAL=1
[00048]
USE_ORIGINAL=1
[00052]
USE_ORIGINAL=1
[00038]
USE_ORIGINAL=1
[00039]
USE_ORIGINAL=1
[00050]
USE_ORIGINAL=1
[00047]
USE_ORIGINAL=1
[00022]
USE_ORIGINAL=1
[00041]
USE_ORIGINAL=1
[00034]
USE_ORIGINAL=1
[00049]
USE_ORIGINAL=1
[00008]
USE_ORIGINAL=1
[00045]
USE_ORIGINAL=1
[00044]
USE_ORIGINAL=1
[00055]
USE_ORIGINAL=1
[00010]
USE_ORIGINAL=1
[00018]
USE_ORIGINAL=1
[00069]
USE_ORIGINAL=1
[00011]
USE_ORIGINAL=1
[00006]
USE_ORIGINAL=1
[00003]
USE_ORIGINAL=1
AUDIO=1
PGS=
APULLDOWN=0
S1440=0
VIDEO2=0
V2MBRATE=0
M2TS_TARGET=14419941
NSTART=27000000
NEND=27495495
NSIZE=14383104
FLINK=0
MLINK=0
[00002]
USE_ORIGINAL=1
[00004]
USE_ORIGINAL=1
[00012]
USE_ORIGINAL=1
[00014]
USE_ORIGINAL=1
[00013]
USE_ORIGINAL=1
[00057]
USE_ORIGINAL=1
AUDIO=1
PGS=
APULLDOWN=0
S1440=0
VIDEO2=0
V2MBRATE=0
M2TS_TARGET=152693680
NSTART=27000000
NEND=31930550
NSIZE=152371200
FLINK=0
MLINK=0
[00015]
USE_ORIGINAL=1
[00061]
USE_ORIGINAL=1
AUDIO=111111111111
PGS=1111111111111111111111111111111
APULLDOWN=0
S1440=0
VIDEO2=0
V2MBRATE=0
M2TS_TARGET=29909872218
NSTART=27000000
NEND=315822909
NSIZE=27788673024
FLINK=0
MLINK=0
This is the subtitle from the non-procesed BD (demuxed using TSMuxer):
https://1drv.ms/u/s!AiCgDguh7E_OgZdr...abQuw?e=8dJRZt

This is the subtitle from the output BD created by BD-Rebuilder (demuxed using TSMuxer):
https://1drv.ms/u/s!AiCgDguh7E_OgZdq...-G2Nw?e=0AbAFy


Last edited by jdobbs; 17th November 2021 at 18:42.
SquallMX is offline   Reply With Quote
Old 17th November 2021, 05:26   #30934  |  Link
MrVideo
Registered User
 
MrVideo's Avatar
 
Join Date: May 2007
Location: Wisconsin
Posts: 2,024
Please "code" wrap the text, don't "quote" wrap it.

Thanks

Last edited by MrVideo; 18th November 2021 at 08:10.
MrVideo is offline   Reply With Quote
Old 19th November 2021, 12:09   #30935  |  Link
lauguru
Registered User
 
Join Date: May 2004
Posts: 242
Hello, after a long time without hardly using computers, I would like to know what is the best configuration to convert full uhd with custom 48200mb, Nvenc codec to obtain the highest quality (vbr), ENCODE_QUALITY = 4 (ultra high extremly slow), what else could I add o remove?. Thanks

other question for update the new Nvenc codec 5.41https://github.com/rigaya/NVEnc/releases?page=1 in bd rebuilder copy and paste the files from https://github.com/rigaya/NVEnc/rele...cC_5.41_x64.7z and paste in path bdrebuilder /tools /nvenc an rename NVEncC64.exe to NVEncC.exe correct?

Quote:
[Options]
[Options]
VERSION=0.61.0.25
ENCODER=1
MODE=0
ENCODE_QUALITY=4
AUTO_TWOPASSONLY=1
ONEPASS_ENCODING=2
B_PYRAMID=1
QUALITY_ULTRA=2
UHD_MAXRATE=60000
UHD_VBV_BUFFER=60000
AUTO_QUALITY=0
TARGET_SIZE=48200
AUDIO_TO_KEEP=all
SUBS_TO_KEEP=all
SD_CONVERT=0
OPEN_GOP=0
RESIZE_1080=0
RESIZE_1440=0
RESIZE_720=0
DEINTERLACE=1
SD_TO_1080=0
IGNORE_3D=0
CONVERT_WIDE=0
DTS_REENCODE=0
AC3_REENCODE=0
AC3_640=1
AC3_192=0
KEEP_HD_AUDIO=1
AUDIO_DRC=0
DECODER=0
AVCHD=1
REMOVE_WORKFILES=0
REMOVE_OUTPUT=0
USE_FILTERS=0
BDMV_CERT_ONLY=0
IVTC_PULLDOWN=0
ASSUME_DVD_PAL=0
FRIMSOURCE=0
COMPLETION_BEEP=0
OUTPUT_SBS=0
NEROAAC=0
SUPTITLE=0
PGSTOSRT=0
AUDIO_TRACK_LIMIT=0
SUBTITLE_TRACK_LIMIT=1
CUSTOM_TARGET_SIZE=48000
NVENC_CAPABLE=1
[Paths]
SOURCE_PATH=G:\
WORKING_PATH=E:

Last edited by lauguru; 19th November 2021 at 15:09.
lauguru is offline   Reply With Quote
Old 23rd November 2021, 08:46   #30936  |  Link
RetsimLegin
Registered User
 
Join Date: Apr 2021
Posts: 31
@jdobbs I encountered something entirely new yesterday.
I'm not going into where or how I got the source but the video is encoded at EXACTLY 24fps (not 23.976) - which I gather (from here https://forum.doom9.org/showthread.php?t=154533) IS a valid frame rate for BD-Video. The video does need re-encoding as it has letterboxed content and the black bars aren't in the source (i.e. it's not 1080 pixels high).
BDRB re-encoded the video at 23.976 an re-encoded the EC3 audio without other amendment (i.e. equivalent to 24fps) - meaning that the lip-sync drifted throughout and was was off by something like 1/2 second at the end.

So instead, I'm having to try avidemux to re-encode both whilst retaining the 24fps timing.
RetsimLegin is offline   Reply With Quote
Old 23rd November 2021, 14:24   #30937  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,931
Quote:
Originally Posted by RetsimLegin View Post
@jdobbs I encountered something entirely new yesterday.
I'm not going into where or how I got the source but the video is encoded at EXACTLY 24fps (not 23.976) - which I gather (from here https://forum.doom9.org/showthread.php?t=154533) IS a valid frame rate for BD-Video. The video does need re-encoding as it has letterboxed content and the black bars aren't in the source (i.e. it's not 1080 pixels high).
BDRB re-encoded the video at 23.976 an re-encoded the EC3 audio without other amendment (i.e. equivalent to 24fps) - meaning that the lip-sync drifted throughout and was was off by something like 1/2 second at the end.

So instead, I'm having to try avidemux to re-encode both whilst retaining the 24fps timing.
When BD-RB converts rates, it should also adjust the audio. Can you look at the AVS for audio and see if it does?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 23rd November 2021, 17:04   #30938  |  Link
Mark_Venture
Registered User
 
Join Date: Jan 2010
Posts: 220
not a bug, but a question... (should I be asking outside of this thread??)

When doing Alt-Movie Only for a normal Blurays, I had been selecting "MKV Container, 1920x1080, Intact Audio" . It works great and I'm happy with the output. Looking at Alternate.txt it has vFormat=5 (where 5=1920x1080). Does it actually resize the video on a normal bluray? I mean, a typical bluray is 1080p, so I would think it shouldn't, but I have to ask. Or does it cause black bars inserted or something to make the video a full 1080 lines for movies that aren't 16:9 aspect ratio or something?

When I do UHD disks, I've been using "MKV Container, HEVC, NO_RESIZE, Intact Audio" which has vFormat=7 (where 7=No Resizing)

Other than h264 vs H265, if I switch to "MKV Container, HEVC, NO_RESIZE, Intact Audio" for all, should I expect the same output for my regular blurays?
Mark_Venture is offline   Reply With Quote
Old 23rd November 2021, 18:36   #30939  |  Link
RetsimLegin
Registered User
 
Join Date: Apr 2021
Posts: 31
Quote:
Originally Posted by jdobbs View Post
Can you look at the AVS for audio and see if it does?
AVS? (sorry!)

Certainly
a) the BDRB output lost sync
b) the AVIDEMUX output (24p exactly) did not
c) ...and neither does the original
RetsimLegin is offline   Reply With Quote
Old 23rd November 2021, 23:32   #30940  |  Link
MrVideo
Registered User
 
MrVideo's Avatar
 
Join Date: May 2007
Location: Wisconsin
Posts: 2,024
Quote:
Originally Posted by jdobbs View Post
When BD-RB converts rates, it should also adjust the audio. Can you look at the AVS for audio and see if it does?
That begs the question... why is BDRB converting 24fps to 23.976 in the first place?
MrVideo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.