Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th September 2012, 18:33   #1  |  Link
datauser
Registered User
 
datauser's Avatar
 
Join Date: Oct 2010
Posts: 100
LAME 3.99 New VBR sound artifacting!

After reading all the extensive audio literature on reasons not to use CBR anymore and the new vaunted VBR presets being the recommended I gave it a try. Usually I only went as far as using trusted abr settings and CBR was enough for me.

I used the highest quality settings for 112kbps with bitrate going as low as 96kbps at 44.1khz. My file in certain parts sounded like a mosquito's buzzing. Just horrible! I used old VBR LAME presets and it was fine just like its abr. Then I read that the new VBR may cause artifacts yet it is still highly recommended for usage in LAME 3.99.5! Why?

Last edited by datauser; 24th September 2012 at 18:36.
datauser is offline   Reply With Quote
Old 25th September 2012, 01:08   #2  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,234
If you use VBR, you shouldn't have 112kbps files! With VBR, you should NOT set bitrate constraints (-b and -B), as it sounds like you have done. Also, the highest quality settings is achieved with the option -q0 (that's a zero not an O).

The idea of VBR is you select a VBR quality level, and let the algorithms choose the best rate for that quality level for that point in time, and leave all other settings untouched. This may mean for very simple audio you get a lower overall bitrate, and for complex audio a higher overall bitrate. What are you trying to encode? 112kbps is really too low for CD quality music, and that is true of any codec for MP3.

Now for the -q and the -V (big V, LAME options are case sensitive) settings, the lower the value the higher the quality. The value for q does not affect file size, it is merely an option for the quality and precision of the algorithm use to compress. Very much highly recommend setting this to 0. The -h option sets q to '2', which isn't really much different to '0', but since you shouldn't really notice a different in compression speed '0' is definitely fine!

Now for -V, this is the thing that affects bitrate. Remember it is a quality based setting, not a bitrate based, so the overall bitrate could be either very low or high depending on what you want to compress. It only uses the bit's necessary to encode the audio to a specific size. This can be used for 1-pass encoding. ABR on the other hand is only suited for 2-pass, because it needs to know the whole file and distribute bits accordingly to match the intended bitrate.

I personally like a -V of 4. If the output bitrate is a little high, you can use 5, but I wouldn't recommend using a higher value (and hence, lower quality) value than that.

Remember, and this is VERY important, DO NOT set bitrate constraints when using VBR mode.
burfadel is offline   Reply With Quote
Old 25th September 2012, 11:33   #3  |  Link
datauser
Registered User
 
datauser's Avatar
 
Join Date: Oct 2010
Posts: 100
If I encode to music I never go less than 224kbps. No, you have me wrong I was encoding a video track using XmediaRecode and setting its(GUI) to vbr automatically went to 64kbps min and 112kbps with VBR5 at default. All I altered was this low min up to 96kbps which is not far different from an AutoGK test I did with VBR 112 which came out perfectly encoded as min 100kbps and max 112kbs with no artifacts. The only additional setting I introduced in my XmediaRecode was "Very high quality Q=0." Thinking it was the software I tried a few other encoders like Fairstars using auto vbr new and same artifacts resulted.

After reading at link below which too reports of artifacts by this new vbr setting I have confirmed it for myself.

http://wiki.hydrogenaudio.org/index.php?title=Lame

Quoted from above site:

Prior to LAME 3.98, the --vbr-new switch enabled the new VBR mode. This is now the default VBR mode, with the old mode being available via --vbr-old. In terms of quality, the new mode appears to be better than the old, but reports of artifacts when using the new mode do exist. Despite these possible issues, the new mode is currently recommended due to both the speed and quality increases afforded by the new algorithm...

Last edited by datauser; 25th September 2012 at 11:42.
datauser is offline   Reply With Quote
Old 1st October 2012, 20:24   #4  |  Link
murdertrk
Registered User
 
Join Date: Mar 2012
Posts: 2
Why dont you use ABR instead?
murdertrk is offline   Reply With Quote
Old 1st October 2012, 21:46   #5  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,234
Yes, good point murdertrk. The idea of VBR is not to have any constraints on bitrate, it is designed to encode to a specific quality level. Minimum and maximum bitrates should NOT be specified. You are getting artifacts because of the maximum bitrate being 112kbps. That is too low for MP3 when trying to encode music or complex audio. As a sidenote, when encoding using AAC don't be fooled by not having artifacts, by setting a low quality/bitrate it merely discards audio information to achieve the targets. This means that the audio will have a much lower fidelity than it otherwise would have, but still be artifact free (this is a bit of a an oversimplification).

Anyways, if you must have a specific bitrate requirement to meet a filesize target, use ABR. By setting an ABR to say, 128kbps, the encoder will do 2 passes. The first is an analysis of the audio stream, determining which parts need less bits and which parts need more bits. Many non-complex parts of the file may only need low bitrate (even 64kbps) to sound good, other parts may need higher bitrates, say 160kbps in bursts, to sound good. But the average will be 128.

I recommend a V setting of -V4 (although -V5 isn't too bad) and -q0. Don't mess with min/max bitrates, it will stuff up the quality. Also use LAME 3.99.5 (if not LAME3.100a0). LAME 3.98 is actually quite old.
burfadel is offline   Reply With Quote
Old 2nd October 2012, 04:31   #6  |  Link
IgorC
Registered User
 
Join Date: Apr 2004
Posts: 1,319
Personal Listening Test of LAME encoders, 3.97/3.98.4/3.99.5 at ~135 kbps

After 5 years of active development any audio or video format reaches its maturity. After that there are only speed and usability improvements.
IgorC is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.