Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Announcements and Chat > General Discussion

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th October 2018, 20:38   #1  |  Link
empleat
Registered User
 
Join Date: Jun 2018
Posts: 24
mpc + madvr: full color range pixelation on dark background

Hey,
do anyone use full color range ever ?
I was using limited range since forever, because on full color range movie is pixelated, on background of dark scenes. And also problem with full color range, it is to dark, if you increase gamma, or brightness even slightly, it becomes to pixelated.

I also don't understand this, i attached metadata picture, there is at the same time that color depth: 8bit, but than under color range is: limited. So what, it is full range or limited ? i am confused.
Attached Images
 

Last edited by empleat; 14th October 2018 at 20:42.
empleat is offline   Reply With Quote
Old 14th October 2018, 20:49   #2  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,570
Most content (TV broadcasts, streaming, DVD, Blu-Ray) is encoded as limited range. PC displays expect full range (often called "PC range" for that reason). So madvr converts the limited range content to full range for display.

Why are dark scenes often pixelated? Because our encoders suck on dark scenes and need more bitrate than we give them. If you increase the brightness too much you will see it more often because then you can actually see the different blocks in dark areas are of different shades instead of being all solid black. So use more bitrate when encoding, try to put more bits into dark areas (play with aq/psy), use 10 bits encoding. For display try to activate banding and compression artifact filtering in madvr (settings->processing->artifact removal).


P.S.: it takes forever for image attachments to be approved on doom9 so I can't see your screenshot.
sneaker_ger is offline   Reply With Quote
Old 14th October 2018, 21:14   #3  |  Link
empleat
Registered User
 
Join Date: Jun 2018
Posts: 24
Ye that's what i though, there is actually no way i would be able using full color range for that kind of files i am watching, that screen i sent that wasn't actually that bad, bitrate: 4.6k.
And second issue, it is to dark, but increasing gamma, or brightness isn't good idea either, so there is no way...
I tried enable that filters, but i didn't even noticed difference, i was watching limited range since ever so it is whatever, was just interested if it is me, or full color range suck.
empleat is offline   Reply With Quote
Old 14th October 2018, 21:32   #4  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,570
Quote:
Originally Posted by empleat View Post
I tried enable that filters, but i didn't even noticed difference
Maybe you need to increase their strengths.
sneaker_ger is offline   Reply With Quote
Old 14th October 2018, 22:05   #5  |  Link
empleat
Registered User
 
Join Date: Jun 2018
Posts: 24
With enabled reduce banding and reduce compression artifacts enabled together, it helps quite, but it doesn't look that good either.
Debanding strength must be set to high, otherwise it doesn't work. And reduce compression artifacts strength at least to 6 and quality don't know, i have it on high, very high makes movie laggy.
And using +10 brightness and 2.00 gamma, otherwise it would be to dark.
But still far from perfect.
In darker scenes it is better now than on limited range, i took one scene and on limited there were much less details discernible than in full color range, but it performs worse in normal scenes in daylight, it looks a bit blurry, especially hair and it done something to face too.
Actually it is not that bad in daylight scenes, depends, if hair is captured from close distance, or face, actually i think it now looks good, even for low quality movies it is much better. Thank you for advice.
Not still sure what i will be using, but now it seems okay, i will try find some 10 bit movie with high bitrate tomorrow to test it out, how would it look on high quality movie.

Btw do you know whether netflix streams in full color range by default, it would depend probably on titles as well, because you was saying that majority tv shows is in limited range.

Last edited by empleat; 14th October 2018 at 22:18.
empleat is offline   Reply With Quote
Old 14th October 2018, 22:25   #6  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,570
Practically all consumer content is limited range. That includes Netflix.
sneaker_ger is offline   Reply With Quote
Old 15th October 2018, 02:49   #7  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,475
Quote:
Originally Posted by empleat View Post
Hey,
do anyone use full color range ever ?
I was using limited range since forever, because on full color range movie is pixelated, on background of dark scenes. And also problem with full color range, it is to dark, if you increase gamma, or brightness even slightly, it becomes to pixelated.
"Dark scenes becoming pixelated" sounds like dark scenes showing blocking or compression artefacts when you increase the brightness/gamma. They'd normally be harder to see when the correct levels are used.

How is your PC connected and is it connected to a TV or PC monitor? Many devices can be set to expect either limited range or full range levels over HDMI. If it's set for limited range input then the TV/Monitor will expand the levels to full range itself.

Maybe your TV/Monitor is set to expect limited range levels. If you send it a full range levels the picture will probably look too dark. If it's expecting full range levels and you send it limited range, the picture can look a bit "washed out".

There should also be settings in your video card's control panel for adjusting the output levels for video.

Traditionally, TVs expect limited range levels and PC monitors expect full range, but most recent TVs probably allow you to choose. For my Samsung TV the setting is called "HDMI Black Level" and counter-intuitively, "normal" means full range input while "low" means limited range input.

The LCD monitor I bought a while ago had the HDMI inputs set to limited range by default, even though it's a PC monitor.

DVI and VGA inputs would normally be full range.

Last edited by hello_hello; 15th October 2018 at 02:55.
hello_hello is offline   Reply With Quote
Old 15th October 2018, 10:38   #8  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 6,920
Quote:
I also don't understand this, i attached metadata picture, there is at the same time that color depth: 8bit, but than under color range is: limited. So what, it is full range or limited ? i am confused.
because no one really answer your underlying question.
the meta data of a file just tells a video renderer.

so there are multiply places ranges are used.
in video files as meta data it's pretty much always limited range.
the GPU driver which always assumes full range input and has option for range outputs
your end device which is usually not smart enough to understand the incoming signal. TV usual except limited range for RGB signal and PC monitors usually full range RGB.

this looks way more complicated than it is. with default setting in madVR and a not broken file you can ignore both and you only have to check the range setting in the GPU driver and or the TV.
huhn is offline   Reply With Quote
Old 15th October 2018, 23:54   #9  |  Link
empleat
Registered User
 
Join Date: Jun 2018
Posts: 24
How do i make dark objects lighter. This is actually 5.5k bitrate. Hair is to dark, there is no detail visible it is like in painting black squares LOL.
And also uniforms are dark as hell. I tried all - increase black level, reducing contrasts helped. I were googling various setting and tried various effects in pot player and tried all hotkeys in mad vr and tried switch on/off 100 permutations of different setting. There is actually no way, seems source is garbage, is there any way to reduce dark and make detail more visible. Tried gamma correction, it doesn't seem to do anything with built-in renderer. Tried all setting there is. Isn't there a way to reduce somehow darkness, perhaps there is something to do, i don't know i am not expert. It is what it is, i don't think there is anything i can do.

Last edited by empleat; 16th October 2018 at 00:11.
empleat is offline   Reply With Quote
Old 16th October 2018, 00:30   #10  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 6,920
did you check if your screen is doing it correct?
the way to "fix" would be calibration with a meter and if dark parts are to dark for you you would use a lower gamma of 2.0 or something like this.
huhn is offline   Reply With Quote
Old 16th October 2018, 13:13   #11  |  Link
empleat
Registered User
 
Join Date: Jun 2018
Posts: 24
Ye my screen is set to full range, if you meant that.
I am currently using gamma 1.95 and it has no effect on this whatsoever, it will be probably source, i tried even gamma 1.8 and it has no effect on black in this case. But lowering gamma helped me in general with darkness. It's best it's gonna get probably. I thought maybe there are some tweaks except gamma, to reduce darkness and color banding, it is so dark, it is like pure black with no detail. No idea what yet might help, if there is anything.

EDIT:And i found out changing gamma, brightness and what not, negatively affects picture, there are white dots and pixelation on background, so i reverted all changes and now using +9 black level, which results in much better picture.
I changed black level using hotkeys and it doesn't even remember and there is no setting to change it otherwise. I currently created profile on monitor but i would rather set it globally in madvr.

Last edited by empleat; 16th October 2018 at 18:40.
empleat is offline   Reply With Quote
Old 17th October 2018, 02:40   #12  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 6,920
no i'm talking about real calibration.

gamma changing in madVR doesn't work with the calibration tab you need both the color and gamma and the calibration tab to change the gamma. not with HDR sdr conversation but it is as it is...

this will obviously not change the blocking issue.
huhn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.