Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 18th January 2021, 10:26   #1  |  Link
For Fun
Registered User
 
Join Date: Oct 2020
Posts: 11
Mpv shaders won't work?

Can someone explain where I did wrong?

I did follow the anime4k instruction but shaders wont show up? did try shift + I and then 2 and it didn't work?

this is how mine `mpv.conf` is setup:

profile=gpu-hq
autofit=50%
deband=no
autofit=50%
hwdec=auto-copy
screenshot-format=png
screenshot-high-bit-depth=yes
screenshot-png-compression=7
volume=100
volume-max=200

glsl-shader="C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_Denoise_Bilateral_Mode.glsl"
glsl-shader="C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_Deblur_DoG.glsl"
glsl-shader="C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_DarkLines_HQ.glsl"
glsl-shader="C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_ThinLines_HQ.glsl"
glsl-shader="C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_Upscale_CNN_M_x2_Deblur.glsl"

Last edited by For Fun; 18th January 2021 at 15:21.
For Fun is offline   Reply With Quote
Old 18th January 2021, 10:44   #2  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: On thin ice
Posts: 6,717
Your file is named mpv.config? Try mpv.conf
__________________
mpv.net - StaxRip - MediaInfo.NET - Get-MediaInfo - More
stax76 is offline   Reply With Quote
Old 18th January 2021, 11:56   #3  |  Link
For Fun
Registered User
 
Join Date: Oct 2020
Posts: 11
Quote:
Originally Posted by stax76 View Post
Your file is named mpv.config? Try mpv.conf
İt is conf sorry I did write it wrong

Last edited by For Fun; 18th January 2021 at 12:01.
For Fun is offline   Reply With Quote
Old 18th January 2021, 12:11   #4  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: On thin ice
Posts: 6,717
You can show stats with key t, it will show you that d3d11 is used by default, this is the best choice on Windows btw., but your shaders are opengl, I assume you need to enable opengl, you can try:

gpu-api = opengl


I'm not interested in shaders, but there is a thread were you can ask:

https://forum.doom9.org/showthread.php?t=181584


Other mpv or mpv.net questions here:

https://forum.doom9.org/showthread.php?t=174841&page=18
__________________
mpv.net - StaxRip - MediaInfo.NET - Get-MediaInfo - More
stax76 is offline   Reply With Quote
Old 18th January 2021, 13:02   #5  |  Link
pirlouy
_
 
Join Date: May 2008
Location: France
Posts: 663
You can view errors with mpv.com instead of usual mpv.exe.

Go into mpv folder, open a cmd, use the command: mpv.com path_to_your_file
and when you use your shaders, you might have errors which could help you identify your problem.

Like stax76, I'm not into shaders, so can't help that much.

For your shortcuts ("shift I then 2"), it depends on your input.conf file.
pirlouy is offline   Reply With Quote
Old 18th January 2021, 16:15   #6  |  Link
sarsaK
Registered User
 
Join Date: Aug 2020
Location: Turkey
Posts: 12
input.config
CTRL+6 change-list glsl-shaders toggle "~~/shaders/SSimDownscaler.glsl"
CTRL+7 change-list glsl-shaders append "~~/shaders/FineSharp.glsl"


"~~/shaders/FineSharp.glsl" = "C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_Denoise_Bilateral_Mode.glsl" glsl-shader="C:\Users\aydin\AppData\Roaming\mpv\shaders\Anime4K_Deblur_DoG.glsl"

Last edited by sarsaK; 18th January 2021 at 16:18.
sarsaK is offline   Reply With Quote
Old 21st January 2021, 12:20   #7  |  Link
butterw2
Registered User
 
Join Date: Jun 2020
Posts: 208
Re: Mpv shaders won't work?

To troubleshoot in mpv, start via command-line (error messages will be directly visible)
if necessary use -v verbose mode, or even more complete --log-file mode.
you can disable all config files with --no-config, or just override the shader chain with --glsl-shaders

If your issue is that no shaders are working, you should test with a single much simpler shader such as invert or black&white
ex: mpv --glsl-shaders=bw.hook "b:\Videos\video.mp4"

- shaders can use any file extension.
- shaders that are not found are simply not loaded.
- if there is a syntax error in a shader it will output a blue screen.
butterw2 is offline   Reply With Quote
Reply

Tags
mpv

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.