Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD & BD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 22nd October 2013, 16:11   #18041  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,863
Quote:
Originally Posted by AmigaFuture View Post
For a moment I thought there was something malfunctioning with Doom9's Web Page software when I saw the above JDobbs quote. I never saw a quote altered like that before till now.

Anyway... Dobbs, thanks for the IVTC_480i=n and IVTC_SELECTION=n options. They've proven a very useful combination for TiVo HD 1080i files.
Which quote was that? Did I alter something?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 22nd October 2013, 20:34   #18042  |  Link
g00g
Registered User
 
Join Date: Mar 2005
Posts: 29
Quote:
Originally Posted by gonca View Post
g00g
In this case don't use DVD_RB as a middle man. Import the DVD with BD_RB. Sometimes a backup of a backup is not a good idea.
Already tried that but it makes no difference.

As I have done all my backups via DVD_RB so fare and have never had any sync problems, I think this is another kind of problem.

Thanks.
g00g is offline   Reply With Quote
Old 22nd October 2013, 20:36   #18043  |  Link
g00g
Registered User
 
Join Date: Mar 2005
Posts: 29
Quote:
Originally Posted by gonca View Post
Are you doing full disc or movie only backups?
I am doing movie-only backups.
g00g is offline   Reply With Quote
Old 22nd October 2013, 21:49   #18044  |  Link
gonca
Registered User
 
Join Date: Jul 2012
Posts: 1,068
Quote:
Originally Posted by jdobbs View Post
I call it "playlist obfuscation". If you are ripping with AnyDVD, by the way, you often don't have to worry about this. Much of the time AnyDVD detects the correct playlist and puts it in a file called "disc.inf". BD-RB looks at that file to see if a playlist is listed, and chooses the correct one.
Playlist obfuscation. I kept trying to think of the term and it wouldn't come to me. Thanks. AnyDVD picks the correct one most of the times but every so often it will pick the wrong one. I notice that on some of these the US - Canada releases will have a different correct playlist even though all the playlist numbers are the same, apparently different parts of the US could have different correct playlists.
gonca is offline   Reply With Quote
Old 22nd October 2013, 22:00   #18045  |  Link
Ch3vr0n
Registered User
 
Join Date: Jan 2009
Posts: 1,366
If it picks the wrong playlist you need to inform the folks at slysoft and provide a logfile for the affected disc so they can fix it that anydvd picks the right one
Ch3vr0n is offline   Reply With Quote
Old 22nd October 2013, 22:10   #18046  |  Link
RobertM
Registered User
 
Join Date: Apr 2011
Posts: 429
Quote:
Originally Posted by gonca View Post
I notice that on some of these the US - Canada releases will have a different correct playlist even though all the playlist numbers are the same, apparently different parts of the US could have different correct playlists.
I agree, absolutely. I recently did 'Now You See Me' and it took quite a while to find the correct playlist from dozens of playlists with almost the same play length. I found that the 'obfuscated' playlists usually had repeating video segments, where a short video segment was duplicated with different m2ts file names and was then included multiple times in the playlist. I've seen this before, and now that I've got a feel for the pattern I think the next time will be quicker
RobertM is offline   Reply With Quote
Old 22nd October 2013, 22:55   #18047  |  Link
AmigaFuture
Registered User
 
AmigaFuture's Avatar
 
Join Date: Apr 2003
Location: Within the main Source.
Posts: 877
Quote:
Originally Posted by jdobbs View Post
Which quote was that? Did I alter something?
You didn't. I noticed this:

From this:
Quote:
Originally Posted by jdobbs
I have SALT running now... if you can wait a day or two it will be fixed.
To this..in a reply by steveg32..

Quote:
Quote:
Originally Posted by jdobbs
i have salt running now... If you can wait a day or two it will be fixed.
hooray! :d
Which is why I wondered about the Software Doom9 is using. A fun observation.
__________________
Life is not a journey to the grave; but rather to skid out broadside, thoroughly used, torn and warn and loudly proclaim; WOW; What a ride!!! Soon, I'm going to do it AGAiN in different skin!!
AmigaFuture is offline   Reply With Quote
Old 22nd October 2013, 23:09   #18048  |  Link
gonca
Registered User
 
Join Date: Jul 2012
Posts: 1,068
Quote:
Originally Posted by Ch3vr0n View Post
If it picks the wrong playlist you need to inform the folks at slysoft and provide a logfile for the affected disc so they can fix it that anydvd picks the right one
I realize that, however if a couple of people from my "region" have already submitted logs it may be better to be patient and wait for the Slysoft team to do its thing.
gonca is offline   Reply With Quote
Old 22nd October 2013, 23:29   #18049  |  Link
Lathe
Registered User
 
Lathe's Avatar
 
Join Date: Aug 2005
Posts: 1,042
Quote:
Originally Posted by AmigaFuture View Post
You didn't. I noticed this:

From this:


To this..in a reply by steveg32..



Which is why I wondered about the Software Doom9 is using. A fun observation.
AF, you are one OBSERVANT li'l bugger!
Lathe is offline   Reply With Quote
Old 23rd October 2013, 00:06   #18050  |  Link
AmigaFuture
Registered User
 
AmigaFuture's Avatar
 
Join Date: Apr 2003
Location: Within the main Source.
Posts: 877
Quote:
Originally Posted by Lathe View Post
AF, you are one OBSERVANT li'l bugger!
Hahaha!! Thanks. I Am (Usually...). I've also been told that many times in my life. Which is also why I can see quality differences in Video that most don't see and say is not possible. ;-) Annnnnything is possible...with focus and vibrational awareness. For more awesome insights into human possibilities...may I suggest Stan Lee's Superhumans?
__________________
Life is not a journey to the grave; but rather to skid out broadside, thoroughly used, torn and warn and loudly proclaim; WOW; What a ride!!! Soon, I'm going to do it AGAiN in different skin!!
AmigaFuture is offline   Reply With Quote
Old 23rd October 2013, 07:59   #18051  |  Link
Audiophile1178
Registered User
 
Join Date: Sep 2009
Posts: 83
Jdobbs, I just wanted to inform you that I came across another disc with the improper mPID number to the dolby digital commentary tracks in the playlist. This movie (X-MEN: Wolverine) has 3 PIP videos and 3 DTS Express audio tracks. From what I can see I believe that BDRebuilder is somehow thinking that the DTS Express tracks belong in the main audio section and assigning the mPID numbers to the DD commentary tracks after the DTS Express tracks thus labeling the DD commentary tracks as hidden as noted in BDinfo. For instance on this disc there's the main DTS-HD.MA track that gets the value of 1200 and then I believe that BDRebuilder leaves the following values of 1201-1203 for the DTS Express tracks (that aren't in the list nor belong in that Au list) as there's three of them and then goes on to assign the DD tracks the values of 1204 and 1205. As you can see the DD tracks are far off from one number as they should have 1201 and 1202 as noted correctly in the clipinf screenshot shown below.

Source Info:

Playlist:


Clipinf:


BDinfo:


BDRebuilder output info:

BDedit Playlist (Note incorrect mPID numbers circled in RED):


BDedit Clipinf (The DD tracks are correct in the Clipinf file):


BDinfo Screenshot of DD tracks hidden and not working due to incorrect mPID numbers:


You may take notice that in the BDedit playlist tab that there isn't any PIP videos or audio tracks shown. That's because there's four different playlist for this movie each having their own unique characteristics of what video/audio tracks are included in each one of them.

I'm also currently doing "Gangster Squad" which has a PIP & DTS Express track in it so I'm expecting that the DD audio commentary track will be one number off in the playlist since there's only one DTS Express track on this disc to trip it up.

Hopefully, these screenshots are helpful to you and if you need anymore info just let me know and I'll be glad to provide it to you to help assist you in this problem.

Last edited by Audiophile1178; 24th October 2013 at 19:57.
Audiophile1178 is offline   Reply With Quote
Old 23rd October 2013, 13:03   #18052  |  Link
laserfan
Aging Video Hobbyist
 
Join Date: Dec 2004
Location: Off the Map
Posts: 2,463
Quote:
Originally Posted by Audiophile1178 View Post
Yea, I was going to post that if he changed each mPID in the playlist down one number that it might work as it should. This would be a lot easier and only take a min to do rather than have to run the whole disc again through BDRebuilder.

Try changing it to these values and see if it works:

1100 DTS-HD XLL, Multi-ch., 48 kHz, eng
1101 DD, Stereo, 48 kHz, eng
1102 DD, Stereo, 48 kHz, eng
1100 DTS-HD XLL, Multi-ch., 48 kHz, fra
1100 DD, Stereo, 48 kHz, spa
1103 DD, Stereo, 48 kHz, eng
FWIW AP I did try your suggestion and it didn't work. There's something more involved with this methinks, and I expect it may take a while, once he confirms the problem, for our capable host to unravel the mystery.
laserfan is offline   Reply With Quote
Old 23rd October 2013, 13:22   #18053  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,863
Quote:
Originally Posted by laserfan View Post
FWIW AP I did try your suggestion and it didn't work. There's something more involved with this methinks, and I expect it may take a while, once he confirms the problem, for our capable host to unravel the mystery.
I've fixed it. I did a full backup of SALT yesterday using your INI settings and it worked correctly.

It was caused by the audio tracks being out-of-order in the original CLPI. There's nothing in the spec that says they have to be in order -- but until this disc I hadn't seen any that weren't sequential. Anyway, its done.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 23rd October 2013 at 13:25.
jdobbs is offline   Reply With Quote
Old 23rd October 2013, 17:51   #18054  |  Link
laserfan
Aging Video Hobbyist
 
Join Date: Dec 2004
Location: Off the Map
Posts: 2,463
Great to hear! Do you have an ETA for the new release e.g. Sunday "as usual"?
laserfan is offline   Reply With Quote
Old 23rd October 2013, 17:51   #18055  |  Link
Audiophile1178
Registered User
 
Join Date: Sep 2009
Posts: 83
Quote:
Originally Posted by laserfan View Post
FWIW AP I did try your suggestion and it didn't work. There's something more involved with this methinks, and I expect it may take a while, once he confirms the problem, for our capable host to unravel the mystery.
Yea, I just looked at your screenshots again and realized that you have 7 DD eng tracks in your clipinf file but you only stated that there were 3 DD eng tracks in the playlist that you had selected. You also stated that there were two other playlists so I only had 1/3 of the information and I'd be pretty certain that the other two playlists would be setup slightly different. I'd imagine that the other 4 DD eng tracks would go in the other two playlists somewhere but without having the disc in front of me it's pretty hard to give you 100% correct information as there's still 2/3 of the info still missing. I'm guessing that some of those DD tracks are hidden on certain playlists which is why there's only 3 on that one playlist that you posted. Like I said before it was merely a suggestion on what I've been doing to get my audio tracks working again but apparently you issue was a bit more involved. Anyway, jdobbs has you covered and you'll be good to go once he posts the new version.

Quote:
Originally Posted by jdobbs View Post
I've fixed it. I did a full backup of SALT yesterday using your INI settings and it worked correctly.

It was caused by the audio tracks being out-of-order in the original CLPI. There's nothing in the spec that says they have to be in order -- but until this disc I hadn't seen any that weren't sequential. Anyway, its done.
Will this fix my issue as well?

BTW, I just did "Ganster Squad" last night and everything turned out fine. This bug was not present. Maybe it only happens when there's more than one playlist for the movie? Which may be why Ganster Squad wasn't effected as it only has one playlist for the movie.
Audiophile1178 is offline   Reply With Quote
Old 23rd October 2013, 17:57   #18056  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,863
Quote:
Originally Posted by Audiophile1178 View Post
Will this fix my issue as well?
You didn't post the original CLPI so I can't say for sure -- but it's likely it will.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 23rd October 2013, 18:04   #18057  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,863
Quote:
Originally Posted by laserfan View Post
Great to hear! Do you have an ETA for the new release e.g. Sunday "as usual"?
I've got what I believe to be a minor bug that I need to run down first -- then it should be ready.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 24th October 2013, 20:17   #18058  |  Link
Audiophile1178
Registered User
 
Join Date: Sep 2009
Posts: 83
Quote:
Originally Posted by jdobbs View Post
You didn't post the original CLPI so I can't say for sure -- but it's likely it will.
I modified my post #18052 to include that info. If you need anything else let me know.

When you release the next version I'll test it out on these discs to see if it's fixed. From my understanding, if I follow the same process (removing audio tracks, blanking vids, etc) but don't encode the disc and run it through BDRebuilder it should tell me if the bug is present or not without having to go through the encoding process?

On a side note, would you ever consider adding my feature request into BDRebuilder (Post #180002 feature request #2) of manually marking vid's as extras? I'm merely just asking as I have two discs that I want to encode that have seamless branching with DTS Express and I'm wondering if I should try to figure out how to encode these discs the way that I want it (using CRF on extras) or wait for your implementation. Please understand that I'm not asking that it get done now but merely wondering if it's something that'll be added on your to do list so that I know how to proceed with these discs.

Again, thank you for this wonderful program and your continuing support for it!
Audiophile1178 is offline   Reply With Quote
Old 24th October 2013, 20:34   #18059  |  Link
Audiophile1178
Registered User
 
Join Date: Sep 2009
Posts: 83
jdobbs, I just found out that it looks like the recently updated tsMuxeR now supports DTS Express as I was able to demux the 3 DTS Express audio tracks for X-MEN: WOLVERINE. Will this mean that BDRebuilder will now support DTS Express properly to work correctly on all players?

Last edited by Audiophile1178; 24th October 2013 at 20:45.
Audiophile1178 is offline   Reply With Quote
Old 24th October 2013, 20:53   #18060  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,863
Quote:
Originally Posted by Audiophile1178 View Post
jdobbs, I just found out that it looks like the recently updated tsMuxeR now supports DTS Express as I was able to demux the 3 DTS Express audio tracks for X-MEN: WOLVERINE. Will this mean that BDRebuilder will now support DTS Express properly to work correctly on all players?
Yes... but that version of TSMUXER is still in early beta (it was alpha not long ago). I'll support it as soon as I've tested it enough and know it's stable.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.