Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Newbies

Reply
 
Thread Tools Search this Thread Display Modes
Old 19th July 2014, 14:32   #1  |  Link
dror.sharon
Registered User
 
Join Date: Jul 2014
Posts: 26
YAMB audio

Hello!
I've been using Handbrake to encode movies to my iPad 4, and it works perfectly.
However, at times I have an mp4 file, and then I want to add another track, usually the commentaries track from a Blu Ray which I didn't add originally.
Now, I found YAMB and it indeed allows me to combine several track to the film. However, the end result is that all the tracks play at the same time, and iTunes doesn't find different tracks, just one track made of all the other tracks combined.

Is there a way to fix this?

Thanks for the help!
dror.sharon is offline   Reply With Quote
Old 19th July 2014, 21:31   #2  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,300
Try re-muxing with MkvToMp4 or via command line with the new mp4box. I don't like the way mp4box is integrated into the entire GPAC package as I only need mp4box but installing the entire thing seems to be ok (via a custom install at least).

Don't be fooled by the name, MkvToMp4 seems to have expanded its functionality.
Asmodian is offline   Reply With Quote
Old 20th July 2014, 08:48   #3  |  Link
fvisagie
Registered User
 
Join Date: Aug 2008
Location: Isle of Man
Posts: 588
if you would like to see how ffmpeg works for you, you could use the syntax:
Code:
ffmpeg -i handbrakefile.mp4 -i commentaryfile.mp4 -map 1,0 -c copy newfile.mp4
'-i' quite obviously specifies the two input files, '-map 1,0' specifies that the 2nd input file (commentary) be synched to the 1st input file and '-c copy' specifies that no re-encoding be done. Therefore this command line assumes your commentary track is already in a format suitable for MP4 and iPad.
fvisagie is offline   Reply With Quote
Old 20th July 2014, 08:54   #4  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,548
You could try My MP4Box GUI. It comes with MP4Box so you don't need to download it separately. I gave up on YAMB a long time ago. I don't think it's been updated for quite a while and I couldn't always get it to do what I thought it should be doing when muxing anyway.

It sounds more like a player issue than a muxing issue to me though. I rarely use MP4 and don't have an ianything installed, but if itunes won't let you select a specific audio track, can you use a different player? Or at least try a different player to confirm it's an itunes issue before you waste too much time trying to fix the problem the wrong way.... so to speak. It sounds like the audio tracks are being muxed correctly but they're all being decoded at the same time.

MeGUI also has an MP4 muxer under it's Tools menu. It also uses MP4Box to do the work. I just thought I'd mention it, as it can be used as a MP4Box GUI.
hello_hello is offline   Reply With Quote
Old 20th July 2014, 11:13   #5  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 680
Quote:
Originally Posted by fvisagie View Post
Code:
ffmpeg -i handbrakefile.mp4 -i commentaryfile.mp4 -map 1,0 -c copy newfile.mp4
'-i' quite obviously specifies the two input files, '-map 1,0' specifies that the 2nd input file (commentary) be synched to the 1st input file...
-map 1,0 is first of all incorrect. The correct syntax is -map 1:0, but with -map 1:0 you only forward the 2nd input's videostream, completely ignoring the 1st input. The following would be better:
Code:
ffmpeg.exe -i <input1> -i <input2> -map 0 -map 1:1 -c copy <output>
-map 0 forwards all streams of <input1> and -map 1:1 forwards only the 2nd track (the audiotrack) of <input2>.
__________________
My hobby website
Reino is offline   Reply With Quote
Old 20th July 2014, 11:57   #6  |  Link
fvisagie
Registered User
 
Join Date: Aug 2008
Location: Isle of Man
Posts: 588
Quote:
Originally Posted by CoRoNe View Post
-map 1,0 is first of all incorrect. The correct syntax is -map 1:0
No, the correct syntax for specifying that all streams from the 2nd input be synched to the first input file is '-map 1,0'. From the documentation:
Quote:
-map [-]input_file_id[:stream_specifier][,sync_file_id[:stream_specifier]] | [linklabel] (output)

... Each input stream is identified by the input file index input_file_id and the input stream index input_stream_id within the input file. Both indices start at 0. If specified, sync_file_id:stream_specifier sets which input stream is used as a presentation sync reference.
Note the comma as well as the optional [:stream_specifier] following 'sync_file_id'.

But the command I suggested did miss out the next part
Quote:
The first -map option on the command line specifies the source for output stream 0, the second -map option specifies the source for output stream 1, etc.
as you point out below.

Quote:
but with -map 1:0 you only forward the 2nd input's videostream, completely ignoring the 1st input. The following would be better:
Code:
ffmpeg.exe -i <input1> -i <input2> -map 0 -map 1:1 -c copy <output>
-map 0 forwards all streams of <input1> and -map 1:1 forwards only the 2nd track (the audiotrack) of <input2>.
Adding the synch specifier:
Code:
ffmpeg.exe -i <input1> -i <input2> -map 0 -map 1:1,0 -c copy <output>
This would work for <input2> containing video and audio, in that order. If audio is the first or only track (as assumed in the original ffmpeg suggestion), the following should be used
Code:
ffmpeg.exe -i <input1> -i <input2> -map 0 -map 1:0,0 -c copy <output>
fvisagie is offline   Reply With Quote
Old 22nd July 2014, 15:58   #7  |  Link
dror.sharon
Registered User
 
Join Date: Jul 2014
Posts: 26
Thanx all!
I don't really use command lines, since I have no idea how to use them.

Will report about the results soon!
dror.sharon is offline   Reply With Quote
Old 22nd July 2014, 20:36   #8  |  Link
dror.sharon
Registered User
 
Join Date: Jul 2014
Posts: 26
Well I used MKVtoMP4 to add the commentary track. VLC player plays it fine, but iTunes won't recognize it at all!
I drag it to the iTunes window, and it isn't added to the movies list. Now, I have A LOT of "home made" movies (basically my entire Blu Ray collection...), and it never had that problem before.
I used the files that iTunes originally recognized (MP4 before adding the commentaries). I tryed both MP4 file format and M4V with two different movies, but nothing seems to work...

Any other ideas?
dror.sharon is offline   Reply With Quote
Old 23rd July 2014, 01:40   #9  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,300
You do have the "Mp4 atom correction for Apple devices" checked right? 8-bit H.264 and <=160 Kbps stereo AAC?
Asmodian is offline   Reply With Quote
Old 24th July 2014, 01:14   #10  |  Link
dror.sharon
Registered User
 
Join Date: Jul 2014
Posts: 26
OK guys!
It seems the movies actually WERE transfered to iTunes, it just placed them in Movies instead of Home Videos, which is why I didn't find them.

So, to sum up, the situation is resolved and everything is working perfectly!

So resolved!

Thanx a lot everyone, you're great!
dror.sharon is offline   Reply With Quote
Reply

Tags
mp4, tracks, yamb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.