Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th December 2009, 22:27   #1  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
Megui v0.3.1.1051 x264 r1183 vs newer megui+x264

hey all, iv been using Megui v0.3.1.1051 along with x264 r1183, this is the latest version supported by megui according to the update info within megui itself.

now i have no issues or problems with this encoding setup i use, encodes look great and there are no errors or issues.

question is, i have read the newer x264 changelog showing all the new stuff thats been added since version 1183, like macroblock tree, newer adaptive quantization methods and weighted prediction etc. the thing is, are these new changes considered to still be experimental? or are they fully stable to be using them on doing my final encodes of family digicam videos?

if i wanted to use the latest x264 revision, is there any update to megui that will allow me to use it in conjuction? or would i be needed a new front end gui or have to resort to command line interface etc.

final question, what sort of difference in percentages would i be looking at in performance and quality going from x264 r1183 to the latest version?
edit: forgot to add i always encode using dxva insane for my SD content at level 3.2, level 9 RD refinement etc with all slow options enabled 9 ref frames.
and videos have to work on standalone playback devices, the WDTV is the one i use most often.

thanks all.

Last edited by Cyber-Mav; 7th December 2009 at 22:35.
Cyber-Mav is offline   Reply With Quote
Old 7th December 2009, 23:36   #2  |  Link
Nightshiver
Quality Freak
 
Join Date: Jun 2007
Location: Area 52
Posts: 597
If they were not stable, they wouldn't be released on the front page of x264.nl
Nightshiver is offline   Reply With Quote
Old 8th December 2009, 00:17   #3  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
oh, dang, i didnt know that. thanks for the reply nightshiver.

is there a way to get megui working with the latest x264 build? from what i can tell the megui 1051 build im using wont be compatible.

thanks
Cyber-Mav is offline   Reply With Quote
Old 8th December 2009, 01:01   #4  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Use the patched 1057 build. It's totally stable.
Inspector.Gadget is offline   Reply With Quote
Old 8th December 2009, 01:32   #5  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
thanks inspector i have done just that, after reading on this forum i set my megui to update from the development builds, so now its got 1057 installed and im currently running a test encode with no errors so far.

one question i have so far, the VBV buffer compliance, its currenlty set to 0 for min and max, what shoudl i set it to so that i have dxva compliance and hardware players like my WDTV can play back encodes with no issues?

thansk for all the help guys i really appreciate it.
Cyber-Mav is offline   Reply With Quote
Old 8th December 2009, 02:13   #6  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
i got a problem, megui doesnt seem to be saving my profile. it always reverts back to default, the old version was fine, whats up with this new version?
Cyber-Mav is offline   Reply With Quote
Old 8th December 2009, 02:50   #7  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Check "advanced settings" in the config panel to ensure the correct command line gets passed.
Inspector.Gadget is offline   Reply With Quote
Old 8th December 2009, 03:01   #8  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
i ticked the advanced settings box, i make my changes to the scratchfile profile and then make a new profile called "MavSD" and i click update button, i exit megui and go back in and its not saved any of the advanced options iv set such as refernce frames = 9 and bframes = 3.
it uses the placebo defults of 16refs and 16bframes.

however checking the MavSD.xml file in the megui profiles folder in notepad shows all my selected settings in there. but megui's gui setup for xvid doesnt show the changes.
Cyber-Mav is offline   Reply With Quote
Old 8th December 2009, 03:37   #9  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
I'm not having that problem here. Try a clean install of the patched 1057, and follow the steps in qu4ntum5uicide's post as far as updating.
Inspector.Gadget is offline   Reply With Quote
Old 8th December 2009, 04:13   #10  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
ahh well iv had enough for tonight, iv set the updater back to its original stable releases mode. and iv "downdated" back to 1051 version and everything is working fine again with profiles being saved properly and my test encode worked fine too.

i have a feeling that i shoudl have tried a clean install of the 1057 version, which is probably my specific issue here. i will give it a go tomorrow by uninstalling megui first
then downloading the installer for 1057 and manually installing from there.

i noticed on 1057's update options that it doesnt have the latest version of x264 listed, it was an older build 1309 available for update. any idea if megui1057 support the latest x264 r1360?
Cyber-Mav is offline   Reply With Quote
Old 8th December 2009, 04:59   #11  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Yes. Every build released lately works fine.
Inspector.Gadget is offline   Reply With Quote
Old 12th December 2009, 14:48   #12  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
ok i did clean install and it seems to be holding my profile changes now. i got a quick question, can B-pyramid be enabled along with MB-Tree? i searched the forum and found references to people saying b-pyramid is not compatible with mbtree. so not entirely sure here.
Cyber-Mav is offline   Reply With Quote
Old 12th December 2009, 15:19   #13  |  Link
Cyber-Mav
Registered User
 
Join Date: Dec 2005
Posts: 244
just went over the x264 changelog, and revision 1367 has Add support for MB-tree + B-pyramid listed so i guess that answers my previous question.
Cyber-Mav is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:17.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.