Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th April 2021, 05:13   #8461  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,307
Now it looks perfect
Klaus1189 is offline   Reply With Quote
Old 13th April 2021, 05:16   #8462  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,307
Quote:
Originally Posted by Aleksoid1978 View Post
As i see from log - youtube page parse successfully, but unable connect to direct link. I don't know why it's happened.

P.S. Try reset settings.
I resetted settings and it doesn't help.
I can do further tests if you want me to.
Klaus1189 is offline   Reply With Quote
Old 15th April 2021, 02:24   #8463  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,558
Quote:
Originally Posted by Klaus1189 View Post
I can do further tests if you want me to.
https://disk.yandex.ru/d/tCBU0sWL-9CoTw
run this in cmd, what text output ?
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 15th April 2021, 05:05   #8464  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,307
Quote:
Originally Posted by Aleksoid1978 View Post
https://disk.yandex.ru/d/tCBU0sWL-9CoTw
run this in cmd, what text output ?
Sent you p.m.
Klaus1189 is offline   Reply With Quote
Old 15th April 2021, 06:37   #8465  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,558
Another - https://disk.yandex.ru/d/YUV_-CMHmi2eeA
run this in cmd, output text for me.

Also test build, check internal Youtube parser - https://disk.yandex.ru/d/xMuv6-rfFSacLg
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 15th April 2021, 08:39   #8466  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,307
Currently at work, will do in about 7 hours.
Klaus1189 is offline   Reply With Quote
Old 15th April 2021, 10:11   #8467  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 93
Tried the latest test build with about 10 problematic videos and it works!

Another (old) issue: youtube-dl sometimes shows higher resolutions than MPC-BE, e.g. 1080p instead 480p. This might be related to rotation flags. The downloaded video and audio files are bit-identical though.

Last edited by mogli; 15th April 2021 at 10:25.
mogli is offline   Reply With Quote
Old 15th April 2021, 10:26   #8468  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,558
For youtube-dl different settings then internal parser.
If some bug with youtube-dl and settings - give me problem url.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 15th April 2021, 13:11   #8469  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 93
This video using the built-in web page parser is shown as 360p under 'Navigate -> Jump to' but plays and downloads as 720p.

Also if there is just a picture with sound one again gets 'Cannot render this file'.
mogli is offline   Reply With Quote
Old 15th April 2021, 13:21   #8470  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,558
Quote:
Originally Posted by mogli View Post
This video using the built-in web page parser is shown as 360p under 'Navigate -> Jump to' but plays and downloads as 720p.

Also if there is just a picture with sound one again gets 'Cannot render this file'.
1 - it's "marked" as 360p, there is nothing to change.
2 - play good for me.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 15th April 2021, 16:00   #8471  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,307
Quote:
Originally Posted by Aleksoid1978 View Post
Another - https://disk.yandex.ru/d/YUV_-CMHmi2eeA
run this in cmd, output text for me.
Sent you p.m.

Quote:
Originally Posted by Aleksoid1978 View Post
Also test build, check internal Youtube parser - https://disk.yandex.ru/d/xMuv6-rfFSacLg
I tried the following problem videos:
https://www.youtube.com/watch?v=LFhllsDVz4c
https://www.youtube.com/watch?v=_tNU6dpjIyM
Both play perfectly with this testbuild and its internal parser and youtube-dl disabled in options.

https://www.youtube.com/watch?v=T5fmUAJ9k3M
In Firefox it shows 360p, and so does MPC-BE, so fine imho.

youtube-dl -F https://www.youtube.com/watch?v=T5fmUAJ9k3M shows:
Code:
139          m4a        audio only DASH audio   50k , m4a_dash container, mp4a.40.5 (22050Hz), 1.36MiB
140          m4a        audio only tiny  129k , m4a_dash container, mp4a.40.2@129k (44100Hz), 3.62MiB
251          webm       audio only tiny  130k , webm_dash container, opus @130k (48000Hz), 3.63MiB
278          webm       82x144     DASH video   95k , webm_dash container, vp9, 30fps, video only
160          mp4        82x144     DASH video  108k , mp4_dash container, avc1.4d400b, 30fps, video only
242          webm       136x240    DASH video  220k , webm_dash container, vp9, 30fps, video only
133          mp4        136x240    DASH video  242k , mp4_dash container, avc1.4d400c, 30fps, video only
134          mp4        204x360    240p  166k , mp4_dash container, avc1.4d400d@ 166k, 30fps, video only, 4.65MiB
243          webm       204x360    DASH video  405k , webm_dash container, vp9, 30fps, video only
244          webm       272x480    DASH video  752k , webm_dash container, vp9, 30fps, video only
135          mp4        272x480    DASH video 1155k , mp4_dash container, avc1.4d400b, 30fps, video only
136          mp4        408x720    360p  579k , mp4_dash container, avc1.4d401e@ 579k, 30fps, video only, 16.19MiB
247          webm       408x720    DASH video 1505k , webm_dash container, vp9, 30fps, video only
18           mp4        204x360    240p  417k , avc1.42001E, 30fps, mp4a.40.2 (44100Hz), 11.65MiB (best)
which confirms "360p" is fine.
Klaus1189 is offline   Reply With Quote
Old 15th April 2021, 16:43   #8472  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 93
@Klaus
I'm talking about No. 136 in particular: The resolution is stated as 408x720 but the next column says 360p. I think YT just uses what's smaller, the width in this case, and then it would fit 360p = 640x360 because 408 < 640. However all media players always seem to use the height instead.
But it's fine.
mogli is offline   Reply With Quote
Old 15th April 2021, 16:55   #8473  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,307
Yes, I agree, that's why I used quotation marks for 360p. It is the way Google describes the resolution of their videos. It is at least not smaller than exact 360p but it is indeed too small for 480p and it describes the shorter width of the video. The video is just rotated. I am also fine with that.
Klaus1189 is offline   Reply With Quote
Old 15th April 2021, 17:24   #8474  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,498
MPC-BE 1.5.7 (build 6180) stable with digital signature (SF.net).

List of changes.

MPC-BE Nightly builds: main file store, alternative 1, alternative 2
Also new and old versions can be found on VideoHelp.com.

Donate.

Last edited by v0lt; 16th April 2021 at 03:47.
v0lt is offline   Reply With Quote
Old 15th April 2021, 19:01   #8475  |  Link
mogli
Registered User
 
Join Date: May 2015
Posts: 93
The YT fix seems to be unreliable: I just tried to watch a few videos and got "invalid" about 5 or 6 times before it worked. As soon as one video worked all other videos worked too.

Also when using MPC-BE with youtube-dl it puts opus in m4a which is incompatible with some apps. Can that be prevented?
mogli is offline   Reply With Quote
Old 15th April 2021, 22:08   #8476  |  Link
hubi73
Registered User
 
Join Date: Mar 2011
Location: Germany
Posts: 50
For me, the test build runs like a charm.

I was wondering if the cookie is gone after closing the player and new set on the next run or if it was set permanently.
I'm afraid that Google will track me.
hubi73 is offline   Reply With Quote
Old 15th April 2021, 23:50   #8477  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,558
Quote:
Originally Posted by mogli View Post
The YT fix seems to be unreliable: I just tried to watch a few videos and got "invalid" about 5 or 6 times before it worked. As soon as one video worked all other videos worked too.

Also when using MPC-BE with youtube-dl it puts opus in m4a which is incompatible with some apps. Can that be prevented?
https://disk.yandex.ru/d/MEeU92WMxmE3bw

About opus - youtube-dl not put It is stored like this on YouTube itself.
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Last edited by Aleksoid1978; 16th April 2021 at 01:37.
Aleksoid1978 is offline   Reply With Quote
Old 16th April 2021, 00:00   #8478  |  Link
hajj_3
Registered User
 
Join Date: Mar 2004
Posts: 1,016
mediainfo 21.03 was released a few weeks ago but wasn't included in the v1.5.7 stable.
hajj_3 is offline   Reply With Quote
Old 16th April 2021, 00:12   #8479  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,558
Quote:
Originally Posted by hajj_3 View Post
mediainfo 21.03 was released a few weeks ago but wasn't included in the v1.5.7 stable.
So what ?
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old 16th April 2021, 02:13   #8480  |  Link
Perenista
Registered User
 
Join Date: Oct 2013
Posts: 115
How can I make MPC-BE subtitles to appear exactly as they are with MPC-HC? It seems options to adjust them properly are lacking for BE.
Perenista is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.