Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 27th February 2019, 11:14   #281  |  Link
vanden
Registered User
 
Join Date: Sep 2007
Posts: 99
Hello,

when I do a "Run Compressibility Check" I have an error Error :
Code:
Error Compressibility Check using x265 2.9+34 (2.0.0.1)

Compressibility Check using x265 2.9+34 failed with exit code: -1073741795 (0xC000001D)

The exit code might be a system error code: {EXCEPTION}
Instruction non autorisée
Tentative d’exécution d’une instruction interdite.


--------------- Compressibility Check using x265 2.9+34 ---------------

"C:\Program Files\Staxrip.2.x64\Apps\Support\avs2pipemod\avs2pipemod64.exe" -y4mp F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_new_source_CompCheck.avs | "C:\Program Files\Staxrip.2.x64\Apps\Encoders\x265\x265.exe" --crf 18 --output-depth 10 --master-display "G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,1)" --colorprim bt2020 --colormatrix bt2020nc --transfer smpte2084 --range limited --max-cll "1529,380" --hdr --repeat-headers --hrd --aud --frames 8358 --y4m --output F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_new_source_CompCheck.hevc -

avs2pipemod[info]: writing 8358 frames of 24000/1001 fps, 3840x1606,
sar 0:0, YUV-420-planar-8bit progressive video.
avs2pipemod[info]: finished, wrote 0 frames [0%].
avs2pipemod[info]: total elapsed time is 1.470 sec.
avs2pipemod[error]: only wrote 0 of 8358 frames.



StaxRip.ErrorAbortException: Compressibility Check using x265 2.9+34 failed with exit code: -1073741795 (0xC000001D)

The exit code might be a system error code: {EXCEPTION}
Instruction non autorisée
Tentative d’exécution d’une instruction interdite.


--------------- Compressibility Check using x265 2.9+34 ---------------

"C:\Program Files\Staxrip.2.x64\Apps\Support\avs2pipemod\avs2pipemod64.exe" -y4mp F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_new_source_CompCheck.avs | "C:\Program Files\Staxrip.2.x64\Apps\Encoders\x265\x265.exe" --crf 18 --output-depth 10 --master-display "G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,1)" --colorprim bt2020 --colormatrix bt2020nc --transfer smpte2084 --range limited --max-cll "1529,380" --hdr --repeat-headers --hrd --aud --frames 8358 --y4m --output F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_new_source_CompCheck.hevc -

avs2pipemod[info]: writing 8358 frames of 24000/1001 fps, 3840x1606,
sar 0:0, YUV-420-planar-8bit progressive video.
avs2pipemod[info]: finished, wrote 0 frames [0%].
avs2pipemod[info]: total elapsed time is 1.470 sec.
avs2pipemod[error]: only wrote 0 of 8358 frames.


   à StaxRip.Proc.Start()
   à StaxRip.x265Enc.Encode(String passName, String commandLine, ProcessPriorityClass priority)
   à StaxRip.x265Enc.RunCompCheck()
Does anyone have an idea of the problem ?
And same with encode :
Quote:
Error Video encoding using x265 2.9+34 (2.0.0.1)

Video encoding using x265 2.9+34 failed with exit code: -1073741795 (0xC000001D)

The exit code might be a system error code: {EXCEPTION}
Instruction non autorisée
Tentative d’exécution d’une instruction interdite.


------------------- Video encoding using x265 2.9+34 -------------------

"C:\Program Files\Staxrip.2.x64\Apps\Support\avs2pipemod\avs2pipemod64.exe" -y4mp F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_track1_[eng].avs | "C:\Program Files\Staxrip.2.x64\Apps\Encoders\x265\x265.exe" --pass 1 --bitrate 6014 --preset slow --tune fastdecode --output-depth 10 --master-display "G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,1)" --colorprim bt2020 --colormatrix bt2020nc --transfer smpte2084 --range limited --max-cll "1529,380" --hdr --repeat-headers --hrd --aud --frames 167130 --y4m --stats F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_track1_[eng].stats --output NUL -

avs2pipemod[info]: writing 167130 frames of 24000/1001 fps, 3840x1606,
sar 0:0, YUV-420-planar-8bit progressive video.
avs2pipemod[info]: finished, wrote 0 frames [0%].
avs2pipemod[info]: total elapsed time is 1.196 sec.
avs2pipemod[error]: only wrote 0 of 167130 frames.



StaxRip.ErrorAbortException: Video encoding using x265 2.9+34 failed with exit code: -1073741795 (0xC000001D)

The exit code might be a system error code: {EXCEPTION}
Instruction non autorisée
Tentative d’exécution d’une instruction interdite.


------------------- Video encoding using x265 2.9+34 -------------------

"C:\Program Files\Staxrip.2.x64\Apps\Support\avs2pipemod\avs2pipemod64.exe" -y4mp F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_track1_[eng].avs | "C:\Program Files\Staxrip.2.x64\Apps\Encoders\x265\x265.exe" --pass 1 --bitrate 6014 --preset slow --tune fastdecode --output-depth 10 --master-display "G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,1)" --colorprim bt2020 --colormatrix bt2020nc --transfer smpte2084 --range limited --max-cll "1529,380" --hdr --repeat-headers --hrd --aud --frames 167130 --y4m --stats F:\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_temp\Passengers.2016.2160p.UHD.BluRay.HEVC.HDR.Muti.VFF.DTS-HD.MA-tlub_track1_[eng].stats --output NUL -

avs2pipemod[info]: writing 167130 frames of 24000/1001 fps, 3840x1606,
sar 0:0, YUV-420-planar-8bit progressive video.
avs2pipemod[info]: finished, wrote 0 frames [0%].
avs2pipemod[info]: total elapsed time is 1.196 sec.
avs2pipemod[error]: only wrote 0 of 167130 frames.


à StaxRip.Proc.Start()
à StaxRip.x265Enc.Encode(String passName, String commandLine, ProcessPriorityClass priority)
à StaxRip.x265Enc.Encode()
à StaxRip.GlobalClass.ProcessVideo()
à System.Threading.Tasks.Parallel.<>c__DisplayClass4_0.<Invoke>b__0()
--- Fin de la trace de la pile à partir de l'emplacement précédent au niveau duquel l'exception a été levée ---
à System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
à StaxRip.GlobalClass.ProcessJob(String jobPath)
Work with x264 ... !!

Last edited by vanden; 27th February 2019 at 14:30.
vanden is offline  
Old 28th February 2019, 15:56   #282  |  Link
vanden
Registered User
 
Join Date: Sep 2007
Posts: 99
Well finally I found the problem : it is the x265 version provided by staxrip (2.9 + 34) that does not work at home.
Replace with version 3.0_Au + 7 it works.

I still have some questions my source file is 420 10bit HDR :

1. In the AVS file I have: format = "YUV420P8" and in the encoding log I have :
avs2pipemod [info]: writing 2843 frames of 24000/1001 fps, 3840x1600,
sar 0: 0, YUV-420-planar-8bit progressive video.
y4m [info]: 3840x1600 fps 24000/1001 i420p8 unknown frame count
raw [info]: output file: NUL

Normally it should not be 10 bit ?

2. in the encoding log I also :
x265 [warning]: NAL HRD parameters require VBV parameters, ignored

What do these parameters correspond to ?

3. Is it better to use LSMASHSource.dll or ffms2.dll ?

Are there any other parameters to modify to encode in HDR ?
vanden is offline  
Old 28th February 2019, 16:05   #283  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,565
1. Your AviSynth script seems to convert to 8 bit.
2. --vbv-maxrate and --vbv-bufsize
3. ffms2 is a bit simpler because it supports native high-bitdepth formats. (i.e. it might solve question/problem 1)
sneaker_ger is offline  
Old 28th February 2019, 17:03   #284  |  Link
vanden
Registered User
 
Join Date: Sep 2007
Posts: 99
OK, thanks

I redid a test with ffms2 but in the encoding log I always 8bit :
Code:
------------------ Video encoding using x265 3.0_Au+7 ------------------

"C:\Program Files\Staxrip.2.x64\Apps\Support\avs2pipemod\avs2pipemod64.exe" -y4mp F:\Lucy_temp\Test-001_new.avs | "C:\Program Files\Staxrip.2.x64\Apps\Encoders\x265\x265.exe" --pass 1 --bitrate 9161 --output-depth 10 --master-display "G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,1)" --colorprim bt2020 --colormatrix bt2020nc --transfer smpte2084 --range limited --max-cll "1000,400" --hdr --repeat-headers --hrd --aud --frames 2843 --y4m --stats F:\Lucy_temp\Test-001_new.stats --output NUL -

avs2pipemod[info]: writing 2843 frames of 24000/1001 fps, 3840x1600,
sar 0:0, YUV-420-planar-8bit progressive video.
y4m  [info]: 3840x1600 fps 24000/1001 i420p8 unknown frame count
raw  [info]: output file: NUL
x265 [info]: HEVC encoder version 3.0_Au+7-cb3e172a5f51
x265 [info]: build info [Windows][GCC 8.2.1][64 bit] 10bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.1 Cache64
x265 [info]: Main 10 profile, Level-5 (Main tier)
x265 [info]: Thread pool created using 24 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 4 / wpp(25 rows)
x265 [warning]: NAL HRD parameters require VBV parameters, ignored
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 23 / 250 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 20 / 4 / 2
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 2 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : ABR-9161 kbps / 0.60
x265 [info]: tools: rd=3 psy-rd=2.00 rskip signhide tmvp strong-intra-smoothing
x265 [info]: tools: lslices=8 deblock sao stats-write
can it be necessary to specify 10 bit in the file avs ?
My AVS :
Code:
LoadCPlugin("C:\Program Files\Staxrip.2.x64\Apps\Plugins\both\ffms2\ffms2.dll")
FFVideoSource("F:\Lucy_temp\Test-001.mkv", colorspace = "YV12", \
              cachefile = "F:\Lucy_temp\Test-001.ffindex")
What are the value for --vbv-maxrate and --vbv-bufsize on Bluray UHD ?

Last edited by vanden; 28th February 2019 at 17:25.
vanden is offline  
Old 28th February 2019, 17:07   #285  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,565
Try to remove "colorspace" parameter:
Code:
LoadCPlugin("C:\Program Files\Staxrip.2.x64\Apps\Plugins\both\ffms2\ffms2.dll")
FFVideoSource("F:\Lucy_temp\Test-001.mkv", cachefile = "F:\Lucy_temp\Test-001.ffindex")
sneaker_ger is offline  
Old 28th February 2019, 17:20   #286  |  Link
vanden
Registered User
 
Join Date: Sep 2007
Posts: 99
Super it works ! Thank you !
Code:
avs2pipemod[info]: writing 2843 frames of 24000/1001 fps, 3840x1600,
sar 0:0, YUV-420-planar-10bit progressive video.
y4m  [info]: 3840x1600 fps 24000/1001 i420p10 unknown frame count
vanden is offline  
Old 28th February 2019, 23:20   #287  |  Link
Magik Mark
Registered User
 
Join Date: Dec 2014
Posts: 660
Guys,

Is there a guideline in coverting UHD hdr(mkv) to Blueray(mkv)?
__________________
Aora Master - Intel i9 - RTX 2060 - DDR4 24GB Predator - LG OLED C9 - Yamaha A3030 - Windows 10 x64 - Kodi with DSplayer - Lav - MadVR
Magik Mark is offline  
Old 1st March 2019, 00:34   #288  |  Link
vanden
Registered User
 
Join Date: Sep 2007
Posts: 99
Just resize in 1920x1080, do a tone mapping (+Add/Color/HDRCore/Tone Mapping).
Choose between DGReinhard and DGHable.
Encode in x264.
vanden is offline  
Old 1st March 2019, 04:50   #289  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Quote:
Originally Posted by vanden View Post
OK, thanks

I redid a test with ffms2 but in the encoding log I always 8bit :

What are the value for --vbv-maxrate and --vbv-bufsize on Bluray UHD ?
If not defined it uses the default value which is 0.

--blu-ray-compat to x265, enforcing profile, level and tier limits as well as GOP structure limitations defined by the Blu-Ray Disc Association.

If I recall Flag is mainly for Legacy devices, It does nothing for newer hardware that has HDR / UHD support.

Many of the auto Switches are set to 8 Bit, I should remove them, Since allot are creating more problems then they solve.
Revan654 is offline  
Old 1st March 2019, 04:54   #290  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Quote:
Originally Posted by sneaker_ger View Post
1. Your AviSynth script seems to convert to 8 bit.
2. --vbv-maxrate and --vbv-bufsize
3. ffms2 is a bit simpler because it supports native high-bitdepth formats. (i.e. it might solve question/problem 1)
3. Kind of, It's support some. I could never get some P010 source to load correctly. Same goes with other 10Bit+ Formats.
Revan654 is offline  
Old 1st March 2019, 05:06   #291  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Quote:
Originally Posted by vanden View Post
Well finally I found the problem : it is the x265 version provided by staxrip (2.9 + 34) that does not work at home.
Replace with version 3.0_Au + 7 it works.

I still have some questions my source file is 420 10bit HDR :

1. In the AVS file I have: format = "YUV420P8" and in the encoding log I have :
avs2pipemod [info]: writing 2843 frames of 24000/1001 fps, 3840x1600,
sar 0: 0, YUV-420-planar-8bit progressive video.
y4m [info]: 3840x1600 fps 24000/1001 i420p8 unknown frame count
raw [info]: output file: NUL

Normally it should not be 10 bit ?

2. in the encoding log I also :
x265 [warning]: NAL HRD parameters require VBV parameters, ignored

What do these parameters correspond to ?

3. Is it better to use LSMASHSource.dll or ffms2.dll ?

Are there any other parameters to modify to encode in HDR ?
Yes, All Flags & data required have been posted a few pages back. You need to met all of them for certain functions to work(x265).

StaxRip switched to 3.0 awhile ago.

FYI, I have no idea if x265 flag HRD Concat is correctly marked or not. the cli list it as ---hrd-concat and the doc has it as the normal two dash flag --hrd-concat. I assume it an oversight in the cli

If it's MP4 LSMASHSource(LWLibavVideoSource should be used since it has a larger range of support) Just be careful with ffms2 it has a history of reporting incorrect metadata since it doesn't read certain mediaFiles correctly.
Revan654 is offline  
Old 1st March 2019, 20:18   #292  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Anyone Here who codes or using VS 2019 RC build? Notice any type freezing where you can't type anyone without re-clicking the screen?

Revan654 is offline  
Old 4th March 2019, 10:14   #293  |  Link
Magik Mark
Registered User
 
Join Date: Dec 2014
Posts: 660
Raven,

There are times the default source doesn't work. I have to explicitly put "LWLibavVideoSource". I was wondering why does it create a "*.lwi" file in the source directory instead in the designated temp folder?
__________________
Aora Master - Intel i9 - RTX 2060 - DDR4 24GB Predator - LG OLED C9 - Yamaha A3030 - Windows 10 x64 - Kodi with DSplayer - Lav - MadVR
Magik Mark is offline  
Old 4th March 2019, 19:31   #294  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Quote:
Originally Posted by Magik Mark View Post
Raven,

There are times the default source doesn't work. I have to explicitly put "LWLibavVideoSource". I was wondering why does it create a "*.lwi" file in the source directory instead in the designated temp folder?
Technically ffms2 should work the best with most formats. It's why it's listed as default. it's just best guess based on what has worked in the past. Of course with newer formats being released it's hard to judge now of days.

I really wish some more sourcefilters would get released to expand source filter choices.

DG Index works the best with most common formats(minus webm (Since there VP9 or VP8) and Apple encoded mp4 files. videoh has apple supported files planned for releases sometime in the future. The tool is Well worth the small fee if you got hardware that supports it.

.lwi is created where ever the source is (This is hard coded inside the dll), I can't do anything about that Since it's not directly tied to StaxRip.

If you call ffms2 without indexing it will create a similar type file. Technically I could tell StaxRip to delete the file Once encoding is complete. However It could screw things up with the encoding process if you try to encode it again.

With the Thumbnailer, I have it set to auto delete the index file once done.
Revan654 is offline  
Old 4th March 2019, 19:33   #295  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
VS 2019 Visual Basic Setting: This feature is not available yet(Where C# version is). I guess MS really wants to kill of VB and WinForms based on whats being updated in dotnet 4.8.
Revan654 is offline  
Old 5th March 2019, 05:08   #296  |  Link
Natty
Noob
 
Join Date: Mar 2017
Posts: 221
latest ffms2 has so many bugs so you may try to use older version. this is a new trend.

https://forum.doom9.org/showthread.p...97#post1866797
Natty is offline  
Old 6th March 2019, 03:15   #297  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Quote:
Originally Posted by Natty View Post
latest ffms2 has so many bugs so you may try to use older version. this is a new trend.

https://forum.doom9.org/showthread.p...97#post1866797
StaxRip doesn't use the base ffms2(It's Included if Needed). It uses ffms2 C-plugin.
Revan654 is offline  
Old 6th March 2019, 08:43   #298  |  Link
zildan
Registered User
 
Join Date: Feb 2019
Posts: 1
StaxRip is the best tool,
congratulations

Please add
ffmpeg | AMD | Amd H.264 -c:v h264_amf
ffmpeg | AMD | Amd H.265 -c:v hevc_amf

VCEEncC replace with version 4.02 by rigaya, build Dec 11 2018 21:03:34,

and add :

--crop <int>,<int>,<int>,<int>
set crop pixels of left, up, right, bottom.

option.


I have Amd Ryzen7 with VEGA 10

With VCEEncC (x64) 4.02 it encodes 120 FPS 1080 HEVC using LAV Video Decoder 0.73.1

thank you

Last edited by zildan; 7th March 2019 at 23:04.
zildan is offline  
Old 7th March 2019, 19:00   #299  |  Link
suckerpuncher
Registered User
 
Join Date: Jun 2005
Posts: 11
@Revan654
Thanks for your work on StaxRip. Is there any ETA on an updated version?

Last edited by suckerpuncher; 7th March 2019 at 20:12.
suckerpuncher is offline  
Old 8th March 2019, 01:35   #300  |  Link
Revan654
Registered User
 
Revan654's Avatar
 
Join Date: May 2004
Posts: 324
Quote:
Originally Posted by suckerpuncher View Post
@Revan654
Thanks for your work on StaxRip. Is there any ETA on an updated version?
There always a newer Beta release in the pipeline.
Revan654 is offline  
Closed Thread

Tags
aac, hdr, hevc, nvenc, staxrip, x264, x265

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.